Question about American Pro Car Audio & Video

1 Answer

My car amp wont come out of protection mode.

I was using this amp for a month and it was working great. But suddenly it went into protection mode and wont come out. I have done everything in the trouble shooting booklet. The ohm load for the sub is correct. the ground and 12v wiring is correct. Just as soon as i turn on my deck it goes straight into protection.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 110 Answers

Hey i had this happen to me, pull the deck out and move the rca cables to a different channel and see if that does not fix it. i blew out my sub pre out channel in my deck and had to use the rear pre outs. try this and let me know what you come up with. good luck

Posted on Mar 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power protect mode: can it be recovered manually


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
A thumbs up would be greatly appreciated if this answer is helpful to you

Jan 04, 2015 | Car Audio & Video

2 Answers

Amp Protection Mode


TRY DISCONNECTING IT FROM THE BATTERY FOR ABOUT AN HOUR. SEE IF THAT HELPS.

Nov 17, 2013 | Car Audio & Video

1 Answer

Protect mode


Protection circuit.
Checek the wiring of the amp and speakers, don' forget to look for shorts at the speakers. Make sure no wires are touching each other

Apr 30, 2010 | Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2...

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

3 Answers

My kenwood kvt 514 is in protect mode


It sounds like your amp is not grounded properly and is tryin to use your radio as a ground through the RCA's or there is a bad channel (dead short) in the amp.

Jun 02, 2009 | Car Audio & Video

1 Answer

Amp went into protect, but front speakers sound distorted too


If the amp still goes into protect mode, the easiest thing to do is disconnect the RCA cables from the amp and see if still goes into protect mode (after turning off/on). If it does, the issue lies in the amp or the wiring to/from the amp (most likely case). Check to make sure no speaker wires came loose and touched +12V or ground (car body). From the sound of it, my guess is something internal to the amp died and will need repair.

Mar 22, 2008 | Car Audio & Video

1 Answer

Amp in protect mode


Most time they go to protect there is something shorted in power supply. And at times it could be a bad amplifier transistor.

Dec 17, 2007 | Audio Players & Recorders

2 Answers

Rockford P550.2 going into protect mode


Does it shut off for a couple of minutes or a couple of seconds? Is the amp hot when it shuts off? Are you sure you have the speakers wired to an acceptable ohm load for the amp? Have you measured the voltage at the amp (across the B+ and ground terminals) to make sure it's not dropping too low on hard bass notes?

Oct 08, 2007 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

282 people viewed this question

Ask a Question

Usually answered in minutes!

Top American Pro Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Are you an American Pro Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...