Question about Hoover Portapower C2094 Bagged Canister Vacuum

1 Answer

Hoover Portapower hose won't stay on, when it does poor suction.

Hi, when I got this Hoover Portapower used the cloth bag had about an inch of stuff built up on the inside of it. I got the adapter and replaced the cloth bag with paper. Still has very poor suction. Also the hose doesn't stay on well, so when I carry it up the staircase to vacuum the hose keeps falling off. I can't see any way to fasten it. Thank for any suggestions for either or both problems. Katy

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

In reply to the problem you have about the hose not staying attached very well, we had this problem years ago with one of our old cylinder vacs. Sometimes after several years of the hose connector being rotated to attach/remove it from the machine, the lugs that lock it into the hole can wear down or become mis-shapen as they are only made of plastic.

I have a UK model Hoover Portapower and luckily have never had this problem as I hardly remove the hose at all (except when emptying the bag). If you remove the hose from the machine and have a look at the connecting part of the hose where it attaches to the machine, there should be two lugs/clips either side of it. If these lugs look a bit mis-shapen or the plastic on them looks worn, then the hose will not fit the two slots either side of the hole on the inlet fully hence the hose being loose. The only way to cure this problem is either put a little bit of electrical tape on them which will stick the hose to the machine better as that's what we did. Overall though you are probably best replacing the hose for a new one if this is the case as these lugs will then be the correct shape to fit the machine properly on a brand new one :)

Posted on Jan 13, 2010

  • chrisgranton Jan 13, 2010

    Regarding the poor suction, have you tried cleaning the internal secondary filter? This is located behind the bag door when you remove the bag from the machine. Sometimes if this is clogged with dust/debris it can reduce suction. As the filter is these machines are not removeable, if you use an old toothbrush or small brush (similar in size) the filter can be cleaned by gently brushing it. In my instruction manual for my UK model Hoover Portapower, Hoover state this is the way to clean this filter.



    Hope this helps.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i stop the dust/dirt from coming out of the hose tube when i remove the hose to use attachments?


It sounds like your hose is stopped up. This is a common problem with bagless machines. It's a good idea to buy a bag type vacuum cleaner when this one quits. Most of these chinese made , bagless cleaners only last one year and don't perform very well either. They stop up easily because of poor suction and poor design.

May 08, 2014 | Hoover UH70120 WindTunnel TSeries Rewind...

1 Answer

Hoover has poor suction


Do you have a clog in the hose or where the hose meets the internal parts of the Hoover? Also, have you bothered to change the bag. My husband doesn't think of changing bags or filters. Hoover is a good product.

Apr 06, 2012 | Vacuums

1 Answer

Is there a switch to turn-off the tools so that


On the Hoover U6311-900 there is no switch that turns off the suction to the tool hose. That hose is attached to the head of the vacuum on the side via a spring loaded "door". Just twist the hose to remove it, the door will close and you will have full suction again.

Apr 06, 2010 | Hoover U6311-930 Power Drive Bagged...

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Poor suction (new bag, clean filter, clear hose)


check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?)

May 01, 2009 | Vacuums

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover U5468-900 WindTunnel Supreme suction is suddenly poor


The other possibility is there is a blockage in the foot. these models have dual channel air flow (windtunnel) and become blocked when not cleaned depending on use. under the roller there is a cavity that can be removed for cleaning. a hot motor can be caused by poor air flow.

Mar 15, 2009 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

Panasonic MC-E468 vacuum cleaner loss of suction


HI If the cleaner is loosing suction make sure to check all inspection tubes and the dirt channel hoses after the spinning brush. Also check the main hose for any clogging. One of the worst faults of this model is clogging hoses. Hope that helps you.

Feb 27, 2009 | Panasonic MC-E583 Bagged Upright Vacuum

1 Answer

Hoover Canister Pulled Vacuum Cleaner


go to thehooverstore and search for your machine. there are exploded diagrams for all hoover machines with parts lists and prices.

Sep 04, 2007 | Hoover Portapower C2094 Bagged Canister...

1 Answer

My Hoover is picking dust , very poorly


The Telios has a bad design on the handle and it sounds like something has definately got stuck. Unfortunately the nature of the cheap European design means the handle can only be removed by someone who owns a vice in their garage without breaking the removal points. Alternatively find a long bamboo stick or pole to put inside the hose mount which connects normally from the main bin of the Telios (not the other way around up the handle) which has no sharp edges and push up and down vigourously to dislodge any clogged dirt which may have inadverntely got stuck either by the handle or in the hose itself.

Another thing to do is to check the suction from the Telios itself by removing the hose. If there is suction coming from the main dirt bag/bin door with the hose removed then there is no problem other than a clogged hose and handle. Hoover updated the handle and hose in 1999 and spares can be found by looking on Ebay.co.uk for cheaper prices.

Aug 12, 2007 | Hoover S3330 / S3332 Straight Suction...

Not finding what you are looking for?

Open Questions:

0 Answers

Query relating to Hoover Portapower (UK model S1126) Hi, I have the old UK version of the Hoover Portapower (model no S1126) which is beige coloured with an orange and black stripe on the left hand side. I bought this machine off EBay and it is immaculate and according to the seller has hardly ever been used. The machine works very well and with great suction. I turned it on however the other week to clean a room and it had been running a while a few minutes before cleaning this room and was fine. On turning it on again I noticed the motor did not sound quite right for a second or so as it sounded a little slow to power up fully but then was fine so thought nothing of it. When I turned the machine off again, I heard a squealing sound coming from the motor as it winded down. I have tried machine since and hoovered car with it the other day as I thought I would test it incase the motor was burning out and there was no problems or strange sounds at all. Any idea of what the squealing may have been and will it now be ok in the future? When I hoovered the car the machine was in use again for about half an hour so would have thought if the motor was on the way out after it squealing a few weeks ago it would have blown whilst hoovering the car which it didn't. If I experience a motor burnout in the future what exactly happens and will I get injured by it? Many thanks if anybody knows what the squealing sound could have been. I'm thinking possibly some debris or something got sucked into it? I know my model is not the C2094 but thought with it being more or less the same machine, it wouldn?t make any difference.

Aug 11, 2009 | Hoover Portapower C2094 Bagged Canister...

Hoover Portapower C2094 Bagged Canister Vacuum Logo

Related Topics:

126 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...