Question about Audiovox AVT-1475 13" TV

1 Answer

Audiovox 12 volt avt-1475 tv problem

I have a problem with the tv not comming on. but we have sound. i checked most of the circuits and i have found nothing. but if i push the power button on and off fast. i will get the tube to come on for a sec as its arcing. can this be a bad flyback transformer? if so where can i get a new flyback?

Posted by on

  • 20 more comments 
  • sal sportiello
    sal sportiello Mar 02, 2009

    yes checked b+

  • sal sportiello
    sal sportiello Mar 02, 2009

    pushing power on and off. tube will get light up and come on with crackle for 2-3 sec. then goes out. dead again.

  • Anonymous Mar 02, 2009

    electech1 here

    does the mylar by the horizontal and flyback look bulged on the sides ?

  • sal sportiello
    sal sportiello Mar 03, 2009

    no it looks good. the only thing i replaced is a resistor that was burnt to a crisp. 1/2 watt 10 ohm and a capacitor that has shrunk. there seems to be a load or short on this path. resistor seem to be getting hot like hell. it all seems to lead back to the flyback some how? can this be the problem. this is burning me out! lol what would be the best way to check the flyback transformer.

  • sal sportiello
    sal sportiello Mar 03, 2009

    yes! as im checking it now. i said the same when looking at it. i checked the vertical ic to make sure. it checked good. just remember that pushing this power button in fast on & off makes the crt light up and work. the only thing is arcing. then its out again. just like that.

  • sal sportiello
    sal sportiello Mar 03, 2009

    OK i'm having fun now! im going on 4 hours. this is what i came up with. there was no spark on disgharge at all. and in the vertical ic section there is a transistor that is acting funny.and im having a hard time crossing c2500 i can't find the replacement. now i have removed the flyback to test it. now im looking how to check it??????

  • sal sportiello
    sal sportiello Mar 03, 2009

    ok im going to fold it up tonight. ill get back to you on this. the info is great.it's nice to know you can have some good help out there. you have me on ends. lol i would have to get some transistors to replace. im looking better then i did. thanks

  • sal sportiello
    sal sportiello Mar 04, 2009

    ok, back to working in this tv. i have made more tests on the board and found that the transistors are ok. i have found a high gain transistor that was making me think a bit. it was testing fast on/off. i see that some transistors test that way. i have found a capacitor that was bad. not shorted just low. but the hv is not hot at all.no glow on the neck! like i said the first time. power botton on/off fast turns on the hv for 3-6 sec. them it's off again. this is making me think that that flyback is the problem? also i can't get my meter to go down to the lowest scale to read it the right way.almost all the pins seems shorted. does anyone out there know where i can get this flyback. ?????????? thanks guys



    43-74-140

    cfb-2/03

    farade 144238

    960906

    10 pins

  • sal sportiello
    sal sportiello Mar 06, 2009

    thanks guys for looking out here! i see that i'm a stand still with this flyback transformer. i hope i can find one. i may not be looking in the right spot. it looks like this part sank like the titanic did. lol

  • sal sportiello
    sal sportiello Mar 06, 2009

    man good bless ya. thats it. going to order on today ill let you know how it works out. this is got to be it.

  • buddy37 May 25, 2009

    audiovox 12 volt avt-1475 tv problem---With power on, there is sound, but no picture. The system, mounted in a Chev. van conversion, has an attached Audiovox video cassette player. What might be the problem with the TV and how do I fix it so I can at least play VHS cassettes after the broadcast digital TV cutover?

  • jason May 11, 2010
  • jason May 11, 2010

    does this look like it ?

  • jason May 11, 2010

    sorry no luck yet

  • jason May 11, 2010

    ok ,till later

  • jason May 11, 2010

    also click this link for the hv prob.

    http://www.repairfaq.org/samnew/tvfaq/tv...

  • jason May 11, 2010

    ok , here is a good place for testing procedures and safety percautions for the flyback http://www.repairfaq.org/samnew/tvfaq/tv...



    do you see the numbers on the transistor ? you can cross reference the numbers here http://nte01.nteinc.com/nte/NTExRefSemiP...$$Search?OpenForm

    and if you can't find it there let me know the numbers on it , also if you get no discharge then it may be that the flyback is not charging up , so let me know what you get

  • jason May 11, 2010

    sorry had to do some stuff , but the only ways to tell if the flyback is bad is to ground the hot to chassis ground with a suitable voltage screwdriver or be real careful with another and see if there is a strong arc , or to unsolder the flyback and do a continuity check on the pins and hot of the flyback, after discharge of flyback

  • jason May 11, 2010

    also check zener diodes and voltage regulator IC for a short or open

  • jason May 11, 2010

    yes this is where the problem is going to be around or in line, circuit with.

    is the cap and resistor inline with or circuit of the horizotal or vertical IC ?

  • jason May 11, 2010

    does the mylar by the horizontal and flyback look bulged on the sides ?

  • jason May 11, 2010

    have you checked power going to the flyback ?

    also follow voltage from the plug power thru

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 899 Answers

Success!
this is the flyback for the 9 - 13 in craig / audiovox tv and at about the middle of the page is where it is for sale ,mc- fbc-015, 43-74-1402
http://www.technotronic-dimensions.com/Products2a_z.html

Posted on Mar 06, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My audiovox 13" monitor in my van shows only a 2-3" bar of gray static through the center of the screen. What is the problem? I can't seem to get my video channel or the menu even with the remote co


Visually check elec.capasitors, then measure output voltages of power supply. First of all, try to find service manual with schematic diagram in Internet. Vertical or horizontal scan seems to be fault.

Dec 28, 2014 | Audiovox AVT-1475 13" TV

1 Answer

Schematic Diagram for Audiovox AVT-1475


Send your email address to me by Fixya, and get back a copy of the schematic you need by return mail.

Oct 30, 2012 | Audiovox AVT-1475 13" TV

1 Answer

Cant get case off need to replace antena


Sometimes the case can get stuck a little, after all the screws are out, pull from the top and work your way down.

Nov 21, 2011 | Audiovox AVT-1475 13" TV

1 Answer

Where can buy a dc power cord for an audiovox model avt-1475?


Tries websites like Amazon.com,Ebay.com,Partstore.com to buy a new a/c power cord.

May 12, 2011 | Audiovox AVT-1475 13" TV

1 Answer

Missing fuse and fuse cap.


PartStore.com 1-866-925-7278
Mats Electronics 1-800-628-1118

May 11, 2010 | Audiovox AVT-1475 13" TV

1 Answer

No picture


If this is connected to a VHS or DVD player or roof antenna, when problem occurs Check to see that the video in to TV cable is tight. If so you my need a new cable

Aug 14, 2008 | Audiovox AVT-1475 13" TV

1 Answer

Sound won't work


Most likely the audio output stage in the TV is blown!

You will have to bring the set in for service. Most likely they will have to change audio output IC and some support components.

Jerry G.

Apr 19, 2008 | Audiovox AVT-1475 13" TV

1 Answer

Vertical hold on tv


no control over the remote..but impossible not to have vertical hold control in the TV itself. it should have one maybe at the back.

Apr 07, 2008 | Audiovox AVT-1475 13" TV

1 Answer

Audiovox AVT-1475 13" TV


YOu can buy a power cable at your local Radio Shack store....

Dec 17, 2007 | Audiovox AVT-1475 13" TV

Not finding what you are looking for?
Audiovox AVT-1475 13" TV Logo

Related Topics:

556 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audiovox Televison & Video Experts

The Knight
The Knight

Level 3 Expert

69654 Answers

olayoju victor

Level 2 Expert

191 Answers

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

Are you an Audiovox Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...