Question about Apollo Pool & Spa

Open Question

We justed turned our apollo spa{galaxy} back on. Three blinking lights are flashing and the water is not heating up. The spa seems to have good preasure or is the preasure switch gone bad. please help steven

Posted by on

5 Suggested Answers

  • 246 Answers

SOURCE: Hayward Colorlogic Light flashes like a strobe

OK I GUESS U HAVE A AUTHOMATIC CONTROL CHECK T RELAY FOR 120 V THAN CHECK FOR V AT THE JUCTION BOX IF V LIGHT MUST BE REPLACE.

Posted on Sep 17, 2009

  • 2 Answers

SOURCE: Parking Lights Not Working

Have ypu checked the fuses under the dash? These are located under a removal panel above the brake pedal.

Posted on Jun 23, 2008

  • 86 Answers

SOURCE: The water wont heat in the dishwasher

Hi, well i think you might have your hands full here! You could be looking at a couple of faults with this. If it wasnt heating then the first p[lace to look is defently the heater and components first! But you should also check that it is filling up to the correct level to or other wise it might not switch the heater on! I know that zanussi have some problems with the sump operated pressure switches which allow the correct amount of water in before it starts to heat, so maybe look at this first. Most of the sumps can be cleaned out easy but some need a replacement sump to be fitted.

Posted on Jan 02, 2009

  • 5 Answers

SOURCE: No Heat from Spa

Tcarrigan,

Heater contactors "buzzing": Do you mean normal buzzing or extra loud buzzing? Loud buzzing or chattering can be caused by low voltage to a contactor. If normal sounds, then probably the relays on the contactors is working, but the contacts may be stuck, or burned enough so as not to make contact. First, get a voltmeter and check for 240 volts AC at the heater contactor terminals. If the voltage is low, most likely you need to check the contactors further. Check for dirty contacts, clean if needed. If the contacts are not moving when energized, then you will probably need to replace one or both of the contactors.

Posted on Jan 18, 2009

PartsCenter
  • 125 Answers

SOURCE: Spa water drains to pool

Here is a link to the Aqualink website so you can download a trouble shooting guide.

Posted on Feb 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My apollo spa galaxy II D20Nj will not heat past 85 can you tell me what I should do or part to get to fix this serial #BSJLJEG


make sure spa setting is at 104 degrees if at 104 degrees see control system if ok change temp sensor either in heater or control unit

Dec 07, 2013 | Jandy Laars LX Pool Heater / 400,000 BTU /...

1 Answer

The instrumentation panel says "SL" and the spa isn't heating.How do I get it to heat again?


You have it in "Sleep" mode. Spa will not heat normally in this mode...

If the SL Message is Alternating with the Water Temp in the Display Screen (we call this "Flashing Sleep"), the Spa is Operating in the Sleep Heating Mode.

If the SL Message is ON Solid (Not Flashing) in the Display window of the panel, the Spa is Operating in the Sleep Heating Mode, but there is No current water temperature because the Spa is between Filter Cycles.

Between Filter Cycles, while in the Economy or Sleep Heating Modes, the Pump has not turned ON and the Last Water Temperature is not Current. To read the Current Water Temperature, either Change to Standard Heating Mode or turn On the Heating Related Pump, and wait at least 2 Minutes.

SL or SLP is one of the Modes you can program your spa into:
EC - Economy
ST/Std - Standard
SL/SLP - Sleep

It is advised you keep your spa in Standard mode. Push the Jets button then immediately push the light button. Each press of the light button will scroll between these three modes.

Good Luck

Aug 27, 2013 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

My Apollo hot tub stopped heating and the first set of jets are not working and both seemed to have gone out at the same time. The second set of jets and the air are fine. Does anyone have any ideas of...


You're pump #1 has failed. Your spa has 2 water pumps and an air pump. Number 1 pump pushes water through the heater. Pump 2 simply supplies the second set of jets with water. The air pump simply pushes air through the air jets.
If pump one fails you will have no heat and the first set of jets will not turn on. Pump 1 is the most prone to failure because it kicks on any time the spa needs to filter or heat. This happens automatically every day so pump 1 works much harder than pump 2. Your heater has a safety mechanism that makes sure that water is flowing through the heater when it kicks on. If there is a problem with pump 1 your heater will not kick on. There are stickers on your #1 pump. Get the model number off of the sticker and order a replacement pump from a web site like www.spapartsdepot.com. If you give them the model number of the pump they can send you a replacement. I'm 100% sure that's the problem. I'm not affiliated in any way with the web site I mentioned but I'm pretty sure they will have the pump you need. Good luck!

Mar 24, 2013 | Apollo Pool & Spa

1 Answer

Hydro-Quip pack in my Hydro-Spa hot tub no heat.


Hi,
3 Flashing dots (display) - Water flow problem check for closed valves, dirty filters, water level, pump/wet end operation/defective pressure switch.
If your spa has been off for a while its likely something is blocking the lines.
Flashing dots & Lit light on display - Hi-limit trip, reset power to clear.

Nov 16, 2011 | Hydro Quip Inc Pool & Spa

1 Answer

The heat of the water is only going to 92 degrees, but it is set at 102. There are three blinking lights under the temp readout. I don't know how to procede.


Is the heater shutting off at 92. If so you have a thermostat problem. If not, then the heater is incapable of reaching the desired temp. The most likely culprit is the bypass valve. See your owners manual on the location of this valve and the part number you need to get a new one.

Apr 13, 2011 | Apollo Pool & Spa

1 Answer

Power light blinks after blower turns on. Water is barely coming out luke warm after 30m of running. No other status lights lit.


The water is mixed with cool water as it leaves the heater and will only be eight to ten degres hotter than when it goes into the heater so as to avoide scalding. You need to ck the total heat rise of the water after about an hour in a spa and after about three or four hours in a pool.

Nov 21, 2009 | Jandy Laars Lt 400,000 Btu Heater

1 Answer

Control Display keeps changing numbers


we unplugged the refrigerator for a bit over 1 minute and replugged and problem went away.

Jan 11, 2009 | LG LRFD21855 Stainless Steel French Door...

1 Answer

Whirlpool quiet partner I won't run just keeps blinking


is the cean light blinking 7 times and then repaeating?? If so this is a water heating fault and means that the computer sensed that the water temp didnt rise just 3deg in the last main wash cycle. If its not blinking 7times then repeat, it sounds like the user interface (membrane switches) have failed. Let me know more and i can help.

Apr 19, 2008 | Whirlpool GU2400XTP Built-in Dishwasher

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

543 people viewed this question

Ask a Question

Usually answered in minutes!

Top Apollo Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1224 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

3539 Answers

Are you an Apollo Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...