Question about Soundstorm 2000W MOSFET 4 Ch Amp w/Remote F4500 Car Audio Amplifier

1 Answer

My amp just ?

Was working earlier was going in and out strong then soft then it was going on for like 10 secs then went off how can i check this

Posted by on

  • Chris Thompson May 11, 2010

    Check your Hot and Ground and make sure you have secure connections

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 61 Answers

Add a bigger ground wire or move the ground wire to a new spot (make sure ground is bigger than power wire) or it could be fuse on amp but i think its a ground

Posted on Mar 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I bought sj-5501 Sharp fridge . Yesterday I have no lighting on the front panel display of the refrigerator The refrigerator works right What could be the reason ? Thanks,


You can try one of these;

1. Hold down "Energy Saving" and "Lighting" buttons simultaneously for 10 seconds (or top left & right buttons). Display panel returns immediately

2. press the Freezer and Ref buttons at the same time for 8 secs and Bam!!!! Bac 2 normal!

3. pressed the power freeze and vacation buttons for about 3 secs and it worked

4. I held the top left and top right soft touch buttons on the screen itself (which I think is the power save and the lighting buttons) and held for about 8 - 10 secs and it reset

Hope it helps. Its in the combination of two buttons pressed simultaneously. Try your luck.

May 16, 2016 | Refrigerators

1 Answer

I have a trio v2fm 4gb and it won't. Go past the main menu


there is usually a soft reset for when these things freeze, go on internet & find what yours is, usually combo of holding down 2 buttons at same time for 10-20 secs.

Jul 02, 2015 | Audio Players & Recorders

1 Answer

Used my garmin edge 305 today on the ride, it worked fine, powered off after the ride. Got home turned on to review my stats and then powered off and went to upload and wouldn't upload, so tried to turn it...


Edge 205 or 305 often crash, then impossible to power on again.

Here is the way to reset the Garmin edge :

Soft reset : hold mode and lap/reset buttons for 10 seconds
Hard reset : device should be powered down, hold start and mode buttons for 3 seconds then pulse press the lap/reset button.

After soft reset, you need to hold start button for up to 10 secs before it starts.

After hard reset, you will loose all your data, including profiles.

Jan 30, 2011 | Garmin Edge 305 GPS Receiver

2 Answers

The check engine light (spanner) came on and I saw a message saying that oil life is less that 15%. I quickly went and serviced the car but the spanner sign did no go. Please advise me on what to do.


Place the key into the #2 position (do not start engine). With the oil remaining light showing on the odometer, press and hold reset post for 10 seconds until it starts blinking, then let go. Press it again for 5 seconds and it should reset back to 100%.

Jan 24, 2011 | 2006 Honda Accord

1 Answer

I made a call from my iphone 3g. After the call my phone froze. Now it is not restarting. How to restart the phone. I have tried holding the button on the top right holding for about a minute but no...


1 : call on ur num from any other phone. if rings going means its software is malfunctioning . wait till the battery went all out ( u can check it while calling in 1 hour interval when u getting a powered off / not responding msg. get it charge n it ll be ok .. if ur using 3.1.2 firmware then i ll strongly recommand to reinstall the firmware as it might give u the same issue in future

2 : if ur phone is not responding n ur confirm its off.. press both home and head button for 9 sec then leave the home button n again press it for 10 sec n leave the head button after wards.. ur phone ll go into recovery mode. if still same issue.. contact the vendor to get the phone issue checked

Feb 20, 2010 | Apple iPhone 3G

2 Answers

What would cause the brushes to go so fast?


Yes, the bars on armature comutator are lifting, usually caused by heat. Only thing to do is replace armature and brushes, but best to also have field coil tested for shorts before buying new armature.

Jul 09, 2009 | Dewalt DW744S 10" Portable Table Saw with...

1 Answer

My amp just stopped making sound


you mite have blown a speaker that would cause the amp to short and over heat and turn its self off. you also should make sure its not your deck

Mar 01, 2009 | Soundstorm 2000W MOSFET 4 Ch Amp w/Remote...

Not finding what you are looking for?
Soundstorm 2000W MOSFET 4 Ch Amp w/Remote F4500 Car Audio Amplifier Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Soundstorm Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4823 Answers

yadayada
yadayada

Level 3 Expert

71694 Answers

The Knight
The Knight

Level 3 Expert

73150 Answers

Are you a Soundstorm Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...