Question about Peg Perego Vespa Scooter

1 Answer

Have lost all lights indicators and petrol gaugue reading. checked one fuse(7.5) were workin when last used

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Just had the same prob.

It could be a broken solder joint on the lighting coil on the stater plate.

Remove the flywheel and visually check. The smallest blob of solder cured this on my Px 200 disc.

Posted on Mar 08, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Peg Perego Gaucho 12v has will not run


Check the wires to accelerator switch and the switch itself. I had problems where the switch has a high resistance when checked with a meter. When the switch is depressed, it should only read a few ohms. Any higher, it should be replaced.

Aug 07, 2014 | Peg Perego Gaucho Rock'in

1 Answer

Peg perego john deere tractor charger indicator light does not light up and tractor does not take a charge - brand new


first of all check for at least 12 volts from the battery and the charger, you can test this using a multimeter, if the battery doesn't show
any volts, lift up one side of the blue plastic housing on the top and verify that both the positive and negative wires are plugged in

Sep 02, 2012 | Peg Perego John Deere Gator HPX Ride on...

1 Answer

I have just bought a 1978 Vespa 125 px I can't get leaded petrol what can I use ?


All Vespa's old or new run without need of lead as your engine internals are lubricated by either the gear oil or 2 stroke oil.

Jul 18, 2012 | Peg Perego Vespa Scooter

1 Answer

My vespa px 125 runs smoothly in 1st,2nd,3rd gear but shudders in 4th,does this sound major or easily fixed


Doesn't sound too serious. Sounds like a problem with your carb not delivering enough petrol or air. Get a decent garage to check it out.

Apr 15, 2011 | Peg Perego Vespa Scooter

1 Answer

I have a 2003 piaggio Skipper 125st. I started to have problems with the instrument panel/left indicator and am unable to find a solution: When the dipped or main beam lights are on, the fuel gauge needle...


i have the same thing i have a Y reg that is doing the same thing you need a new INSTRUMENT PANEL. and so do i due to weather damage they are hard to find but keep a eye out and you will find one

Feb 20, 2011 | Peg Perego Vespa Scooter

1 Answer

Ibought a john deere hpx ride on toy last Christmas.lasted for about 3 months-battery went dead.tried to charge it,put it back in,still nothing.i just sorta gave up.so last week found a place that sells...


hi, its probably the thermal breaker under the shifter. simply remove the screw on the aft side of the shifter holding it in and slide it forward and out of the way. the thermal breaker is the metal fuse looking thing, pry it out and replace it with a 40 amp fuse if you can find it. if you cant, i usually bypass it all together. dont worry about a short, the battery has a 30 amp fuse on it under the blue cover/handle.
good luck!

Dec 18, 2010 | Peg Perego John Deere Gator HPX Ride on...

3 Answers

My Piaggio Typhoon 50cc has no indicators or horn


Look under the front panel and make shure all the wires are plug in. check www.scootdawg.com for a complete list to trouble shot it.
Best Reguards

Larry

Jan 24, 2010 | Peg Perego Vespa Scooter

1 Answer

Vespa px lights do not work


check the connection of the bulb ensure itis fitted correctly also check fuses it maybe that the bulb for the lights has blown, it is common that the brake light is on a seperate fuse for safety.

Dec 02, 2009 | Peg Perego Vespa Scooter

1 Answer

When I plug the battery in to be charged the light on the charge stays green. The light never changes to orange/amber. This is not a new battery I have had it for a while.


Your SLA (Seal Lead Acid) battery is must likely past its useful life due to Sulfation and internal mechanical damage (corroded plates): your charger, like for most car lead acid battery charger is indicating that only a very small charging current is flowing just like when a battery if fully charged ... or the terminals are not connected (no current)! You can check if the charger is working by preferrably using a multimeter or connecting a know good battery unit to the charger.

May 17, 2009 | Peg Perego 12 Volt Rechargeable Battery

Not finding what you are looking for?
Peg Perego Vespa Scooter Logo

Related Topics:

289 people viewed this question

Ask a Question

Usually answered in minutes!

Top Peg Perego Toys Experts

Tony

Level 3 Expert

2598 Answers

Lawrence Oravetz

Level 3 Expert

7928 Answers

Mike Carew

Level 3 Expert

958 Answers

Are you a Peg Perego Toy Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...