Question about Ecoquest Living Air Classic Air Purifier

2 Answers

XL 15 took a dive of the shelf. Now DEAD!

After the fall I replaced the fuse and pluged the sensor back in. Fan runs fine and I have the orange light on, on the front panel. The light on the inside is now off. No ozone. Thanks - Dave

Posted by on

  • dellitron Apr 26, 2009

    everything works - motor - fan - but NO OZONE .. whats the fix ?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

One of the transformers on the board is glued in with RTV. A solid jolt and this comes detached. look through the front grill while its "on" you should see a glow from a neon lamp inside. If its not on chances are the circuit card is dead (should have about 350VDC plate voltage).
I have a used but good board if anyone needs one.
dale.gilchrist@gmail.com

Posted on Jul 02, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 80 Answers

Contact healthytech@triad.rr.com. They will be glad to help you.

Posted on Apr 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I put in a new Living Air XL-15 fan but no go.


Make sure that the pin on the back cover penetrates deeply enough into the unit to activate the power. I too couldn\'t figure out why mine wouldn\'t start until I pressed hard on the bottom right corner of the back cover. When I did the unit started immediately because the pin wasn\'t fully inserted. To solve the problem I held the cover tight with a piece of duct tape and haven\'t had a problem since.

Dec 13, 2013 | Alpine Air XL-15 Air Purifier

1 Answer

Living Air XL (no smell)


TEST THE CONTINUITY OF THE BULB AND THE WIRING AND THE PARTS INSIDE.


DOES THE UNIT STILL WORKS NORMALLY ASIDE FROM THE BULB?

Sep 25, 2008 | Alpine Air XL-15 Air Purifier

1 Answer

My xl-15 air purifier works but it does not blow out air with the purified smell. I think I see people calling it ozone.bthere used to be what looked to be an illuminated orange light behind the fan. It...


Easy. You need new plates in the machine. They cost about $15 a piece. Google 'ozone plates for XL-15' & sources will come up on where to buy them. Remember to clean the plates every 30-45 days w/ 50-50 solution of ammonia & water & a tooth brush on these plates. Dry thoroughly w/ hair dryer before putting back in machine.

Feb 15, 2011 | Alpine Air Purifiers

1 Answer

I just purchased a used Alpine Air XL-15 from ebay.no ozone spell


You probably have a burned out high voltage transformer. That's what produces the ozone. Helpful hint...........the high voltage transformer is also the one used in bug zappers

May 10, 2010 | Alpine Air XL-15 Air Purifier

4 Answers

I just purchased a used Alpine Air XL-15 from ebay that was listed "AS IS" because it didn't have the "3" ozone plates required for it to run. I have properly placed the new plates that I bought and the...


Also check the Fuse. Its on the back of the unit. Press in and turn to remove it. You may be able to just do a visual check and see if the fuse it is still good. however you may want to test it for continuity with a Multi-meter.


Mar 06, 2010 | Alpine Air XL-15 Air Purifier

1 Answer

No lights no fan on Alpine Air XL-15


Use a DVM continuity function to see if the fuse is blown, and check all the DO FIRST literature packed with the thing. You probably get to take a note out of the ionizer chamber.

May 13, 2008 | Alpine Air XL-15 Air Purifier

1 Answer

Living Air XL 15, no ozone


My XL-15 had the same problem a few years ago. I had a broken wire on the fan, and the Ozone problem turned out to be a problem with the power supply. I had to send it in to have it repaired.

Mar 18, 2008 | Ecoquest Living Air Classic Air Purifier

1 Answer

Living Air XL (no smell)


pull out the plates and clean contacts that touch plates with rubber eraser then put plates back in check switch on back of screen to make sure its making contact.
~~~creekkid~~~

Dec 19, 2007 | Alpine Air XL-15 Air Purifier

1 Answer

Fan is not turning on


The fan motor is probably locked up. You can either put a little oil to free it up (usually a temporary fix) or better yet replace the fan motor.

Oct 26, 2007 | Ecoquest Living Air Classic Air Purifier

Not finding what you are looking for?
Ecoquest Living Air Classic Air Purifier Logo

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ecoquest Air Purifiers Experts

Custom Exchange
Custom Exchange

Level 3 Expert

397 Answers

thevacdudes

Level 1 Expert

37 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you an Ecoquest Air Purifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...