Question about Metra Ford/Chry/Jeep 1974 99

1 Answer

Rough idel I have a 99 with a 4.0 that has a rough idel and the service engine light is on it smooths out just off idel and runs fine at higher rpms and under a load.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 57 Answers

If your check engine light is on, you can have the OBDII code read at most local autoparts stores. If you have a flashing check engine light, don't continue to drive as you will damage your catalytic converter. The auto parts store can tell you what the P-code is and what the possible parts replacement solution would be. Call ahead to make sure they offer this as a free service. If it is at idle, my hunch is you need to clean your throttle plate and throttle bores. You didn't say what kind of car or engine (Just 99 4.0L). So that's as specific as I can be.

Posted on Feb 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Blinking security light


try leaving key in run position see if it stops blinking could take up to 30 minutes turn off then back on when the light stops flashing. usually car will not start with security flashing mine will not but this will reset security.

Mar 14, 2014 | Blazer S10 1999 99

1 Answer

I have a 2000 chevy prism 1.8 trying to install a 99 corolla 1.8 engine. I got it in but wont start. the old engine had some type of sylinoid in the head with a electrical wire plug in, would this cause it...


in order to install another year motor in your car you need all the computers and modules the 99 corolla motor has that make it run ... now you have a harness in your car now that was set up for 2000 1.8 prism motor you need to know how to merge the two harnesses together to make the new motor run... like getting the right powers and ground and signal wires to send right info to power up computers and modules for the corrolla motor

Oct 28, 2013 | Metra 2000 Chevy Tracker/Metro/Prism

1 Answer

Engine lags behind tach


Is this a standard transmission or automatic? It sound as though the clutch (standard) is slipping, or the transmission (automatic ******) is slipping. Does this happen only when starting off from a stop, or only at highway speeds? There is very little chance the tach is reading the engine speed incorrectly. If so that would look and feel as though the engine was not revving up, as your speed isn't increasing even though the tach shows higher RPMs.

Jul 21, 2012 | Blazer S10 1998 98

1 Answer

97 pathfinder shutoff when u step on the brakes hard, now when I start it


The first thing is to make sure the truck is running good. A misfiring truck would cause a low idle and stall.
If the truck runs good then look at the throtle body, a dirty throtle plate will cause a stall and lower than normal idle. If its dirty use a tooth brush and some throtle body cleaner to clean plate. make sure to open the throtle plate by stepping on gas pedal or by hand where the gas pedal cable connects to throle body.


I would check the throtle plate first, also make sure air filter is good.

If all is clean, (plate) and engine is running smooth and no check engine light is on then i would check the idle air control valve.





GOOD DAY.

Mar 03, 2012 | Car Audio & Video Accessories

1 Answer

99 ford taurus runs intermitently


Some more info would be handy, like when it's running intermittently. Does it hesitate when you start to push the accelerator? or maybe when it's at a higher RPM? If so check your TPS (Throttle Position Sensor). But without more detailed info it'll be hard for anyone to give you some answers.

Dec 26, 2011 | Metra 99-5717 2004-2007 Ford Taurus Radio...

1 Answer

When my 99 camry has just under half a tank of gas and I turn on the a/c, @ between 25-35 mph it runs rough, like it doesn't want to accelerate


You may have water in the tank, try adding some water remover (any auto parts store) its only a couple of bucks, also you may have a bad in tank fuel filter/sock that's clogged and in need of replacing. Last the fuel pump may be going and if your gonna remove the tank I would recommend replacing it anyway.

Aug 06, 2009 | Metra Toyota Lead To Oem Radio 94 87

1 Answer

The check Gages light is on and the oil pressure gages is on 0 even why the car is running.


sounds like you have a blown fuse check all you fuses under the hood and under the dash...

Apr 08, 2009 | Metra Ford/Chry/Jeep 1974 99

1 Answer

Dodge 1500 service engine soon


Need to get A/C levels checked and might need more freon and go to the auto parts store and have them run an OBD2 scan on your truck. Than go to www.canobd2.com and put your vehicle and code in and see what that code is in reference to.

Mar 25, 2009 | Buck Dodge Ram 1500 2002 Car Radio/stereo...

Not finding what you are looking for?
Metra Ford/Chry/Jeep 1974 99 Logo

Related Topics:

133 people viewed this question

Ask a Question

Usually answered in minutes!

Top Metra Car Audio & Video Accessories Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

yadayada
yadayada

Level 3 Expert

60792 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Metra Car Audio and Video Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...