Question about SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive

2 Answers

Have a 160 GB ext. Hard drive - no longer made. Bought it over a year ago but never plugged it in until two day ago. The red light comes on but it does not show up under"My Computer" Took it to Best Buy and they confirmed it to be working. Took it back again to witness and sure enough it worked on a brand new laptop on display. They say I might update my windows XP. I did but to no avail. Can anyone help?? Brand: SimpleTech BOM# 96200-41001-052. Egon eherz@wt.net

Posted by on

  • frombr Mar 12, 2009

    My simpletech 160gb has just stopped working after i try to copy the Windows Recovery from my laptop
    No lights flashing anymore
    I canno see it in My Computer

    Does onyone can help me to fix this problem ?

    frombr@gmail.com

  • Suhrobjon89 May 13, 2009

    the problem with my Hard Drive is that: it turns red but it does not show up in computer. i do not know what to do with it. I tried it also in other pc's and still it does not work. Can someone help me pls with this problem. Thanx in advance.


×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,568 Answers

Although I have seen it fail often, in your case it is worthwhile to try the 'Add hardware' wizard in the Control Panel. If you have an installation disk of any kind, have it at hand. Let the system look for the drive (plugged in of course) and if it finds it and has no drivers for it, it will ask for the installation disk but you may have to tell Win where to look for it by drive letter. If you don't have an installation disk, you will have to go through the drivers list offered to see if SimpleTech is listed.
SimpleTech still has an active website so I would check there first:
SimpleTech support page
If you have no luck you find no driver, there are several websites that have a huge array of drivers for current and obsolete hardware.
Good luck- 

Posted on Feb 27, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I have the same drive. It has to do with the cable you are using. If you use the "Y" cable that came with it and plug the correct end into the usb of the coumputer, it will work. If you use any other standard usb cable, it will not work. The red light comes on to let you know it is receiving power, but a blue light will come on to let you know it is connected to your computer. So, you have to find a usb cable that will let it both receive power and connect to the computer. I misplaced my cable so I'm trying to find a replacement. I've tried 4 or 5 usb cables in the past and they didn't work, but when I plugged the one that came with it, it worked.

Posted on Dec 26, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Problem with the Mobile Disk External Data Storage Enclosure model HD-338-COMP for my 80gb Western Digital HD


just a suggestion but a few years ago is aeons in tech time maybe, just maybe the drivers for that ext drive were overlapped with OS X migration?

check apple site for more or ext drive site for latest drivers

Jun 02, 2012 | Beyond Micro Mobile / 250GB / 7200 / 8MB /...

1 Answer

Simpletech 250GB STORAGE S


try plugging your HD into another desktop/laptop to see if your HD is functioning well on a different computer. Could be the USB cable problem. 

Feb 01, 2009 | SimpleTech SimpleDrive 160 GB External USB...

1 Answer

Red Light


The red light came on when I plugged this drive into my laptop and was not recognized -- until I plugged in my laptop power adapter, then it showed right up! If you're on a laptop make sure you have the hard drive power plugged in as well as your laptop power.

Apr 30, 2008 | Western Digital FireWire/USB 2.0 Combo...

1 Answer

No power!!!


Do you hear any sound when you plug in ?? any light blinking?

Apr 07, 2008 | Maxtor Personal Storage 3200 (U01E200) 200...

1 Answer

Seagate SATA 160 GB (ST3160827AS) fried!


Are the logic board model numbers the same? How about year and batch manufature? check on that.

Sep 20, 2007 | Seagate (ST3160827AS) 160 GB Hard Drive

Not finding what you are looking for?
SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive Logo

Related Topics:

1,881 people viewed this question

Ask a Question

Usually answered in minutes!

Top SimpleTech Hard Drives Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Arcadian Duran
Arcadian Duran

Level 2 Expert

284 Answers

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Are you a SimpleTech Hard Drive Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...