Question about Kenwood Car Speakers & Subwoofers

1 Answer

I had my subs installed a month ago and a few days ago the subs are working,everythings connected but not working and my subs aren't blown out because i don't have my music that loud so whats the problem?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 110 Answers

What model kenwood speakers do you have? what head unit do you have? do you know how they hooked up the rca cables to the back of the deck? if this deck has got 3 pre outs you may have lost the sub pre-out. are you amp lights coming on? if you are still having problems you can take a 9v drill battery or bigger and touch the wires from the speaker to the battery, make sure positive to positive and neg. to neg. the speakers should pop if they are ok, that should re-assure you on the speakers. let me know and ill help where i can. good luck

Posted on Feb 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi i purchased the bnps102 woofers and used them for 2 weeks i really enjoyed them and i also purchased the pyle 1400 watt amp and a jvc deck along with the boss amp kit installation now the speakers about...


If the lights on your sub box aren't coming on it's either your ground of power wire came loose or the transformer blew. As for the subs, make sure all the connections are good, especially on your RCA wires. If your amp is getting power, then check your speaker connections. Also, make sure to turn the gain know up. The gain knob is located next to the RCA input on the amp. Let me know if this helps.

Aug 21, 2011 | Pyramid BNPS102 Car Subwoofer

1 Answer

Subwoofer buldging out problem


When speakers are wired in the wrong way the will do the "pushing out" you're describing. Basically the polarities have been reversed and if kept like this over a period of time will blow the speaker. Best thing to do is to disconnect the power by the negative on the amp and take out the fuse from the power supply. Check the wires running from the amp to the subs, negative to negative and positive to positive. I know it sounds basic but many people do mix it up! I would also check to see what channels the subs have been wired into?

Best way is to have one sub from channel 1 and the other sub from channel 2 for example. Or if its a bridged 4 channel amp, have 1 sub running from channel 1&2, and the second sub running from channel 3&4 still making sure of the polarities. Again this all depending what kind of amp and sub you have.

-----------------------------
For example;
A 4 channel (bridged) 1000W amp. 250W max per channel or 500W per 2 channels! So if you have 2 500W subs, by connecting one to a single channel will decrease subs ability due to the lack of power supplied. However by combining 2 channels you optimize the output!
---------------------------

Once you know all your wiring from your amp to subs are ok/good connections/good wires etc you shouldnt have to "wiggle the wires" to get it to work as this is just a bad connection. Also ensure that no 2 wires are touching. Make sure that the master volume on the amp is turned down. You dont need this to be on loud at all, in fact far from it or you'll risk damaging both the amp and subs!

Hope this helps!

May 27, 2009 | Car Speakers & Subwoofers

1 Answer

2 car subwoofers, one doesnt play


Short in amp ? try swiching wire's to speaker's around . if other speaker then work's , speaker's are both fine . if not , then short in amp , or blown channel in amp . get new one or find someone who know's more than i do about amp's

May 24, 2009 | Kicker CVR12 Car Subwoofer

1 Answer

Hi-- i have a question!


it could be a few problems either ur ground is in a bad spot or like mine i took it off and there was rust around it. Or your subs could possible be blown or maybe ur amp is pulling way to much juice try turning the gain down and if that doesnt work u have a short somewhere

Nov 17, 2008 | Directed 3124 Car Subwoofer

1 Answer

No Sound from Subwoofer


You should be able to check this yourself pretty easily, Just connect the power and turn it on. Connect an audio cable to the input. Make sure the level control on the sub is turned about halfway up or more. Now, touch your finger to the tip of the plug on the other end of the audio cable. You should get a nice hum out of the subwoofer. If not, then the sub is bad - if it has a user-replaceable fuse you might check that first. If you do get a hum out of it, then the sub is ok, and the problem is elsewhere. Might be a simple as a bad cable or an option on your amp/receiver is set wrong.

Feb 14, 2008 | Kenwood KSC-WA100 Car Subwoofer

2 Answers

Intermittent Problem Part 2


try getting new subs and an amp and see what happens. but i have two 12" pioneer subs and the wirings fine so i know they're blown.

Jan 16, 2008 | Sony XS-L1035 Car Subwoofer

1 Answer

My Subs blew out but I dont know why??


rewire the whole system with new wires,you could have a bad ground or wire try it first if that dont work rewire

Jan 08, 2008 | Jl Audio 12W3 Car Subwoofer

1 Answer

Smoke coming out of subs


If smoke has come out of the subwoofer, the speaker itself, that means the voice coils have been heated excessively and they are damaged or in this case, I'd say completely blown. Voice coils blow because they've been driven too hard, too much power, too much distortion for too long.

If you can get access to the front of the subwoofer speakers, gently put even pressure with your fingers near the middle of the cone, just around the edge of the centre dust cap and push gently and slightly inwards. If you hear or feel a "scratchy" type sound or feel, or if they dont move in freely, they are blown. And if that's the case, your amp could be damaged as well.

Most modern car amps have circuit protection and will shut down when they detect a load greater than they are used to so the amp MAY be ok. One way to test the amp is to hook another speaker to it, any speaker as a test is ok, and see if sound comes out. Make sure all power is off when connecting and disconnecting speakers!

Oct 17, 2007 | Jensen JX1200 Car Subwoofer

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Speakers & Subwoofers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Larry Spears
Larry Spears

Level 3 Expert

625 Answers

Are you a Kenwood Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...