Question about Kenmore 85930 PowerSpin Deluxe Upright Wet/Dry Vacuum

1 Answer

Hose does not dispense cleaning solution, and the cleaner solution will immediately go down to the dirty water tank. It can suction, though. Any tips?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kenmore Master
  • 1,564 Answers

Sounds to me as if you have calcium deposits from hard water.

Take your cleaner solution reservoir and fill it with Vinegar and Hot water. Place your machine in a dry bathtub and run it until the tank is empty. Do this a couple times. When it works properly run some clear water through.

Posted on Mar 20, 2013

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
reddevil6
  • 1673 Answers

SOURCE: Sudden loss of suction.

Check the inlet down by the brush roll to see if it is clogged. Also check the belt to be sure it is ok. Is there suction at the hose? If not then it is still clogged.

Posted on Feb 13, 2008

galati2k
  • 281 Answers

SOURCE: Auto-matic suction shut-off didn't resume once tank was emptied

look on the bottom of the tank and there should be a fitting on there take it off and clean..there should be some hind of float inside the tank.turn it right side up and tap on the tank the float might be stuck

Posted on Apr 28, 2009

  • 1 Answer

SOURCE: No suction in hose or base in Kenmore Powerspin

No suction in hose or base in Kenmore Powerspin

Posted on Jul 26, 2009

  • 67 Answers

SOURCE: I have a Kenmore Progressive Inteleclean Upright

Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog.

Posted on Sep 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is the recovery tank on Hoover f6212-900 not filling up?


Hello! There are a few things that can cause the cleaner to lose suction. Please try these quick steps.

1. Remove the dirty water tank.
2. Clear the filter screen of any dirt or debris.
3. Turn the cleaner on, check your motor suction by the filter screen.
4.. Replace the dirty water tank making sure it is flush to the cleaner on all sides.
5. Lift up on top of nozzle and slide off cleaner.
6. Wipe debris off nozzle and front of cleaner with a damp cloth.
7. Replace dirty water tank.

If you felt suction by the filter screen your suction should now be restored. Hope this was helpful!

Jul 21, 2014 | Hoover F6212-900 / F6215-900 SteamVac...

1 Answer

Why does my hoover steam vac only blow out


Hey there! The cleaner blowing out air instead of sucking is an indication that the unit is not sealed off properly. Follow these brief steps to restore suction to your cleaner.

1. Remove the clean water tank.

2. Recline the handle and let the cleaner lay flat.

3. Remove the dirty water tank lid.

4. Reposition the front panel located on the outside of the tank in the center. It should be flush to the tank, even straight across and pushed down as far as it will go.

5. Assemble the dirty water tank lid back on from the front to the back. The lid should not lift up from the front.

Give it a try! The cleaner should now have suction. Hope this helps!

Jun 02, 2014 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Won't pick up brown water


Hello! Follow these quick trouble-shooting steps to restore suction to your Hoover F5835900.

1. Remove the clean water tank.

2. Recline the handle and let the cleaner lay flat.

3. Remove the dirty water tank lid.

4. Reposition the front panel located on the outside of the tank in the center. It should be flush to the tank, even straight across and pushed down as far as it will go.

5. Assemble the dirty water tank lid back on from the front to the back. The lid should not lift up from the front.

Try it out. The cleaner should now have suction. Good luck!

May 31, 2014 | Hoover F5835900 Upright Steam Vacuum

2 Answers

Bissel Pro Heat carpet cleaner is not suctioning cleaning water off of the carpet back into the tank. How can I fix this?


There is a knob on the base that says floor and tools. Make sure that it is closing when you switch it to floor, Make sure that the hose works when you use it too. That will tell us what the problem is.

Jan 30, 2014 | Bissell 1699 ProHeat Clear View Upright...

1 Answer

My Hoover steam vac spin scrub will not suction up the cleaning solution . Why is there no suction?


p{margin-top:0px; margin-bottom:0px;} Hello,

Thank you for your recent e-mail. I am sorry to read about the problem that you are having with your cleaner.

Please make sure your recovery tank and lid are installed correctly and forming proper seals. Make sure that your filter is clean of any debris. Clean the screen in the tank lid. Make sure your nozzle and squeegee (if on your model) are free of dirt/lint/hair and attached in their holsters correctly. Make sure you do not have any clogs in the hose.

To restore suction, please try the following:

*Remove dirty water tank and clean filters- main reason for low suction is dirty filter

*Verify the dirty water tank cap is not missing.

*Verify dirty water tank lid is inserted completely into unit.

*When cleaning, the yellow float inside of dirty water tank should be free moving.


• First remove your clean water tank and unplug the machine
• Remove the dirty water tank lid and push the front panel piece (square plastic sliding piece in the front of tank) down to make sure it is inserted all the way.
• When reattaching the lid, hook the tabs on the front of the lid to the tank first, then click shut in the back. Pull up on the lid firmly, it should not lift at all. If it does, try reattaching as a seal needs to be formed for suction.
• Test to see if suction has been regained.

If these suggestions do not solve your issue please call a service center.

Your cleaner has at least a 6 month warranty for manufacturing defects. This warranty begins from the date of purchase, with the original sales receipt. If you do not have the original sales receipt, the warranty may be verified at the warranty repair center by MFG or serial number.

Please visit www.Hoover.com and click on service center locator for a list of authorized dealers in your area for service and warranty assistance.


Sincerely,

Hoover Customer Service 62
1-800-944-9200
Mon - Fri 8am to 7pm EST


**Please do not reply to this email address. This is for outgoing messages only.**

servlet.imageserver?oid=00da0000000yf5q&esid=018g0000005bxv6

ref:_00DA0Yf5Q._500G0AodT5:ref

Aug 08, 2012 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Featherlite model 3M-852H


see this instructions:God bless you
Ensure the Dirt Devil is connected to a working power supply if it does not turn on or operate. Check the fuse or breaker and replace or reset as necessary.

  • 2 Empty the dirty water tank if there is little or no suction. Turn off the Dirt Devil and grab the top of the dirty water tank. Push on the latch to release the tank and pull the tank off the base. Remove the lid and empty the dirty water into a sink. Replace the cap and hook the front of the tank onto the machine base. Hook the nozzle on the base so that the nozzle is level with the cleaner base. Push the back of the dirty water tank down and into position.


  • 3 Check the dirty water tank and empty as necessary if there is water leaking from the cleaner. Open the latch on the top of the solution reservoir and pull the reservoir forward. Fill with Dirt Devil brand cleaner to the fill mark. Fill the rest of the reservoir with hot water and close the cap. Replace on the base unit.
  • 4 Make sure the solution reservoir is seated firmly in the base unit if there is no cleaning solution dispensing from the unit. Fill the solution tank with cleaner and water if the level is low.
  • 5 Examine the hose and nozzles for possible obstructions if the carpet cleaner does not seem to be operating correctly. Remove any blockages.
  • Jul 19, 2012 | Vacuums

    1 Answer

    Tank not collecting dirty water


    You most likely have a break in your suction hose. check at the base where it attaches. When you bring back the handle release, you can see lt. If you have the type that has the external plug in for the water, then you probably don't have the hose part plugged in to the collection tank. in the front of the collection tank. Your motor shut off? Well, If you have the first variety cleaner w/built in hose, you may have sucked water into/onto your motor. If this is the case you need to bring it for service. otherwise, you could have a blockage in your collection hose, this would also explain the machine shut down, from the thermosat. A clogged machine will ultimately overheat, wont run again till cooled.

    Jul 18, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

    1 Answer

    Tools


    On the front of the dirty water tank is a block that you pull out(don't forget to put it back in when done, or you won't have any suction), Remove recovery tank front panel
    (F) by sliding it straight up.
    4. Replace panel with converter (G).
    Slide converter halfway down opening
    until it is firmly in place.
    5. Before connecting tube (H) to
    cleaner, make sure black tabs are
    extended by pulling tan collar
    toward tube.
    Open door on hood labeled “Stair/
    upholstery Cleaning Connection”.
    Press round solution tube connector
    onto round projection inside door.
    Press connector collar down firmly
    to ensure that it is fully connected.
    The tank replaces in a hingelike
    manner. Position front of lid
    under tabs (I) on front of tank. Rotate
    lid down onto tank.
    Make sure lid is secure on all
    sides before cleaning.
    For full suction, it is important that
    the recovery tank lid is properly
    secured before cleaning.
    Reverse procedure to remove
    hose and solution tube.
    Raise carpet cleaner handle to
    upright position.

    Sep 13, 2007 | Hoover SteamVac F5914-900 SpinScrub...

    3 Answers

    No suction


    Hmmm...I have the same problem...if you remove the water tank and the water collection bucket and look at what is remaining. Now step on the lever to lean the upright part back and there is a hose there that goes from the hand held hose into this hose into the dirty water tank. MINE is broken at that center point between the handheld hose and the dirty water square thingy...It's probably fixable...maybe this helps you?

    Nov 05, 2006 | Hoover F7431-900 SteamVac Vacuum

    Not finding what you are looking for?
    Kenmore 85930 PowerSpin Deluxe Upright Wet/Dry Vacuum Logo

    70 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Kenmore Vacuums Experts

    Les Dickinson
    Les Dickinson

    Level 3 Expert

    18429 Answers

    Chris Nomland
    Chris Nomland

    Level 2 Expert

    124 Answers

    Marvin
    Marvin

    Level 3 Expert

    85161 Answers

    Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...