Question about Profile BAJA HA700M Car Audio Amplifier

1 Answer

Protection light on a baja ha700m amp keep coming on what is it?

Why do my protection light comes on which makes the subs go out?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 80 Answers

You have your subs wired wrong for that amp!

Posted on Feb 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The protection light is on in my baja200


the ground might be bad make sure its thick as power cable and is touching bare metal

Mar 09, 2013 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

My baja car amp keeps poping fuses


due to a short you have fused two things together.try doing a continuity test between things that you know arent supposed to be conducting. like the connections near the fuse and where you connect the power, remote,ground wires

Apr 11, 2010 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

My jvc ax6300 amp is wired in and the protection light is on. no sound from the subs?


Try to rest amp (turn off power) be sure subs are disconnected. Se if protection light comes on. If it does the amp needs to be serviced porbably a burnt component. If the protection light does not come on, connect one sub at a time to see if either one surges. Could also be that the gain is turned up too much.

Nov 06, 2009 | JVC KS-AX6300 Car Audio Amplifier

1 Answer

Protection light comes on went the amp is turn on and it stays on for four seconds and then the amp turn on


Disconnect any speaker from the amp then re-power. If it still goes into protection, your amp needs serviced. Shorted output transistors most likely. And check your Sub for shorts as well. If the voicecoil on the sub is burnt, it will short any amp. If you can use a meter, check the resistance on the sub. Hope this helps

Jun 02, 2009 | Kicker KX Series 04KX1200.1 1200w RMS...

1 Answer

Memphis PR300.2 Amp protect light on


If it is not turning on your problem is it is not getting power. Check your fuses. The reason an amp goes into protect mode is usually because the subs are not wired up right. Make sure your fuses are good, you have a good ground, and make sure your amp turn on wire didn't come loose when you were putting the deck back in. As for the amp going into protect you probably wired the subs down to too few ohms and the amp you have can't handle it. Try hooking the subs up straight w/o bridgeing them and turn it up to see if it works. If you don't have problems with it then you wired your subs wrong.

Mar 22, 2009 | Car Audio & Video

1 Answer

Amp is shutting off after 10 min of driving!! please help!!


Does it happen at all volume levels?
What is the gain setting on the sub amp?
Have you checked for 12V @ remote turn on after problem occurs?
Sounds as if the remote turn on relay inside the amplifier is losing signal, or has become damaged. If the protection light does not light up, the problem is not thermal, shorting, or high/low voltage.
The amplifier is in need of repair. This is not an end-user fix. Looking at about $50 to repair.

Thanks for using FixYa- a FixYa rating is appreciated!!

Feb 18, 2009 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

My sub flickers on and off in my truck!!!


could be a number of things loose wires bad ground fuse on its way out or internal problems

Feb 13, 2009 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

My amp


Check your speakers with an ohm meter. They should have some resistance but not totally shorted. Its prob the amp that got fried. Connect the amp to the battery with no speakers attached to it if the protection light still comes on then the amp is blown.

If the amp is blown you can send it to people on ebay and get it fixed pretty cheap. Good luck!

Aug 18, 2008 | JBL GTO75.4 Car Audio Amplifier

1 Answer

Directed audio 800a amp the protection light keeps blinking


1. Check your grounds. (including grounds for your stereo)

2. Check to make sure the power cable you connected to your car battery is properly connected, and not coming into contact with anything metal.

3. Make sure you are using proper fuses.

4. Check your connection from your stereo to your amp, and your amp to your subs.

Jul 18, 2008 | Earthquake Sound XTREME 900W.5 Car Audio...

1 Answer

No power


Disconnect the sub or speakers and turn on the amp, see what happens. If the amp turn on without the protection light, then your sub is blown. Also check to make sure ALL your fuses are good including the one under the hood. If you have a meter, test the fuse for continuity. The problem can also be a bad ground.

Aug 19, 2007 | Kicker KX150.2 Car Audio Amplifier

Not finding what you are looking for?
Profile BAJA HA700M Car Audio Amplifier Logo

Related Topics:

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Profile Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Are you a Profile Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...