Question about Rockford Fosgate Punch P3002 Car Audio Amplifier

2 Answers

I have a PUNCH P3002 amp, it has power and the light on my remote knob is on and now all of a sudden the woofers are'nt working.I checked the grounds, the battery and speaker wire and found nothing obvious, what now?

Posted by on

  • kjames13176 Mar 03, 2009

    The protect light comes on and then the amp turns back on but nothing to the speakers and all the wire hookups are fine. The protect comes on as soon as the speaker begins to hit. IT work great when i originally put it in.

  • pbalien73 May 07, 2009

    I have the same issue except the fuse has blown twice now. Worked fine for 2 years now all of a sudden its not working. Powers up but protection light goes on and off. Help!

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Might be your rca connections if everything else seems 2 be working right. best thing 2 do is check each item seperately. you could use a friends car if he/she has a system. just make sure u know what your doin because u dont want to fry their set-up. but u can always have the amp bench tested @ a stereo shop or electronics store. someone somewhere close to u has a test bench u just might have to research a little. good luck. I have the same amp and they kick ***.

Posted on Oct 10, 2009

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Be sure the ground and remote are not touching within the amp

Posted on Feb 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rockford Fosgate P3002 stopped working


push down and up on your subs and see if they make a starching noise, if they do then they are blown. take a test light to the amp, on the power and the remote and see if it lights up. if it does then turn the amp down and with a small speaker plug it in to the speaker outs on the amp and see if it plays if not then your amp is bad.

Nov 26, 2013 | Rockford Fosgate Punch P3002 Car Audio...

1 Answer

My sub woofer has recently stopped working. I borrowed and hooked up a friend's subwoofer and still doesn't work. However all my other speakers in the car are still working. Could this be the amp? If the...


If you only have the sub connected to the amp, the other speakers would still play, if they are just connected to the head unit. I would check for power and remote power to the amp, and check the ground, if those are ok, I'd say the amp is bad.

May 21, 2010 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

How do you install an amp in new cars when the factory radio is basically an computer and doesn't come out of the dash?


You need to use a Hi Low Converter. They have a different name but I cant think of it right now. Basically it connects to your rear speaker and converts it to RCA connectors that you could connect to your amp. Then connect your amp to power (battery) and Ground to power it up. Last thing to do is connect yours speakers to the amp.

Also get a high Low converter with remote connection.

Apr 22, 2010 | Rockford Fosgate Punch P3002 Car Audio...

1 Answer

Amp not working to power sub woofer


remote wire/ fuse possible? have you checked?
traced all voltage?take and disconnect remote wire from amp and make short wire from remote to 12v if green light works then u may have bad remote wire or blown fuse.

Oct 05, 2009 | Kicker ZX10001 Car Audio Amplifier

1 Answer

P3002 protect light problem


sounds like u have shorted opt transistors no big deal goto nte electronics.com and replace . these amps r known 4 postive switching regulators going bad 3$ part rep[lace the #sholud be like tl 494cn square 14 pin blk long hopes this help u later dude

Mar 17, 2009 | Car Amplifiers

3 Answers

Amplifier has no sound


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Your amp is clipping.
A thumbs up would be greatly appreciated if this answer is helpful to you. amplifier-no-sound-peeu4x5nsxvd53n2rwetiqa4-3-0.jpg

Jan 10, 2009 | Rockford Fosgate Punch P325.1 Subwoofer...

1 Answer

Need to hook up two amps input and output


no, all u got 2do is run ur rca from the output of one too the input of the other

Jan 02, 2009 | Rockford Fosgate Punch P3002 Car Audio...

1 Answer

Rockford Fosgate P3002 Amp


what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Aug 22, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Blowing fuses


check your car battery and check your ground and check your power wire for any splits or cracks

Nov 22, 2006 | Rockford Fosgate Punch P3002 Car Audio...

Not finding what you are looking for?
Rockford Fosgate Punch P3002 Car Audio Amplifier Logo

Related Topics:

274 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Amplifiers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...