Question about Technics Amplifiers & Preamps

1 Answer

Volume erratic on technics sag76 model

I have an older technics SAG76 reciever, and the volume will suddenly go wide open even on a low setting. What is the fix, and could I attempt to repair it myself?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,175 Answers

Hi...
Buy some CAIG De-oxit.
It's made for cleaning contacts and controls.
You'll need to open the case ( UNPLUGGED)
and shoot some de-oxit into the volume control . There should be a **** or something to spray into.

You can get De-oxit at radio shack or partsexpress.com

Posted on Feb 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Technics 1080 pre amp volume control is not functioning correctly


Technics SE CA1080 Service Manual

there is a chip called an operational amplifier under a heat sink on the pcb,that fails when it get top volumed for two long theres regulators with heatsinks.
it is listed as,

Technics SE -CA1080 amplifier F61 fault,

May 13, 2015 | Technics Amplifiers & Preamps

2 Answers

Technics su-g75 amp goes to loud static after a few minutes


Hi Aawpharmd,

system control error.
please go for repair shop.
regards,
nuwan

Jan 13, 2014 | Technics SU-G75 Amplifier

1 Answer

My SU-G95 provides for switching between two sets of speakers (A & B) but there is no way I can see to get sound through both sets of speakers at the same time! Any suggestions? I expected to see the...


I can't find a manual or a decent picture of the rear panel but maybe that's because they don't want you running speakers in parallel as it may present a dangerously low impedance.

If you REALLY want to risk it just wire both sets of speakers to the same posts and watch out when turning up the volume. Monitor the amp for excessive heat in case it starts to cook itself. If theamp shuts down even once, UNDO the scheme.

The safer way, assuming the two sets of speakers' relative volume levels are about equal, is to run them in series with each other and present a higher (safer) impedance.

The recommended impedance is probably silk-screened right on the back.

Apr 15, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

14 speakers hooked up to home theater reciever,shuts off .5 vol


Hi,

Try less speakers.
The impedance will be to low for this amp.

Regards,
Gerard

May 10, 2010 | Yamaha P2500S Amplifier

1 Answer

Erratic volume from new turntable thru used amp


Glad to hear you got things worked out

-Scott

Apr 03, 2010 | Technics Amplifiers & Preamps

1 Answer

Technics SU-G88. When volume is wide open get small amnount of sound, as sugested I have already replaced the op ic IC602 and this did not help. Is it possible that both audio power modules bolted to the...


problem with electronics is there are so many possibilities! before changing the power amp i suggest u check all the paths from pre-amp to power amp. bad resistors cud be it, faulty capacitor cud be draining power to ground. insufficient power supply to final amp cud also be it. so before making any rash changing pls check all components including the power amp module.

Mar 14, 2010 | Technics Amplifiers & Preamps

1 Answer

Poor sound.


amp must have a phono input use it if it still has low volume you will need a preamp.radio shack model#42-172

Mar 13, 2009 | Technics Amplifiers & Preamps

1 Answer

Stereo reciever takes several seconds to power up


The power switch is arcing internally and needs to be replaced. This is a common problem with some older receivers. Sometimes the switch can be opened and the contacts burnished.

Dan

Mar 02, 2009 | Amplifiers & Preamps

1 Answer

No sound


What are you tring to amplify? try using a different input.
also try checking all the fuses! llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

Dec 24, 2007 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

212 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4593 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

Are you a Technics Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...