Question about Velodyne CT-100 Speaker

1 Answer

No sound for Velodyne ct-100 sub woofer

Velodyne ct-100 subwoofer, 6years old. Electic power is there. No blown up fuze. The woofer is working when removed and connect to a separate speaker. How to check the circuit board or transformer ? How to diagonistic and solve the problem ?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 124 Answers

Sounds like a dead amp. You could check the xformer output and the amp IC's with a VOM.

These amps do not cost a lot, about $40.00. and are easy to replace.

Contact Velodyne

Posted on Mar 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What can cause a sub woofer and room speaker woofer to stop


Check wiring for loose connection...may have to open speaker enclosure.

Jan 04, 2016 | Velodyne CHT-8 Subwoofer

2 Answers

I have connected the subwoofer to the pre-amp out



One of two things may be going on.

The amp has a fuse mounted on the PC board. The fuse may be blown.

The speaker may be bad. that may have blown the fuse.

You can test the speaker with a "D" battery.
Take the amp section out of the back, disconnect the speaker leads.
Touch the speaker leads to the poles of the battery. it should make a little thump and the cone should move freely.

Contact Velodyne for service.

Dec 21, 2009 | Velodyne CT-80 Subwoofer

1 Answer

Velodyne sub woofer: Series S Model: VA08BVX10


The volume control pot can be replaced.

Any good quality audio shop or electronics repair shop should be able to fix this.


Nov 17, 2009 | Velodyne SPL-1000 Subwoofer

1 Answer

Woofer,s outer ring is ripped.


To fix this problem, you will need to contact Velodyne.
They may be able to replace the surround or recone this driver.

Because this system has the "servo" control, you need to have the accelerometer conected to the amplifier. With out it, the amplifier will not operate.

Jan 03, 2009 | Velodyne VRP-1200 Subwoofer

1 Answer

No bass...


One of a few things.

The fuse inside the amplifier section is blown.
The amplifier has died
The speaker is dead.

Best to return to the place you purchased the unit or contact Velodyne for service.

Dec 16, 2008 | Velodyne VX-10 Subwoofer

1 Answer

Lost manuel


The Q55 is not a velodyne product

Nov 17, 2008 | Velodyne CT-80 Subwoofer

1 Answer

My Velodyne CT 80 powered subwoofer does not power on?


Fuse in amp may be blown or the amp is dead

Contact Velodyne, the replacment amp is not very expensive

Sep 03, 2008 | Velodyne Speakers & Subwoofers

1 Answer

Subwoofer will not work when connected


cheak setting in sterio out put for sub on ect does woofer have sperk wire going in and out use them then ok

Feb 11, 2008 | Velodyne CT-80 Subwoofer

Not finding what you are looking for?
Velodyne CT-100 Speaker Logo

601 people viewed this question

Ask a Question

Usually answered in minutes!

Top Velodyne Speakers & Subwoofers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Carlos Jaen

Level 3 Expert

435 Answers

Are you a Velodyne Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...