Question about Olympus EVOLT E-510 Body Only Digital Camera

2 Answers

Olympus Evolt e-510 vibrates when turning the camera off

I have a new Olympus E-510 that vibrates when the camera is turned off. This only seems to happen when one of the image stabilization modes is on. Is this normal??

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

It's the anti dust filter and you would have known if you had rear the manual !

Posted on Jun 29, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 919 Answers

The answer is yes. It is the camera mirror returning to its normal position when the camera is powered off.

Posted on Mar 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi you all, I have a Olympus Evolt E-510. I tried to update the firmware but something goes wrong... My son unhooked the cable and as result the camera does not turn on anymore. Any suggestion to re-f


What I understand is that the firmware needs to be in place to get the camera to accept a firmware update. Someone with the right tolls and an eprom programmer could probably load a new firmware on the camera, but that would be more expensive than having the manufacturer do it. I don't think that you can put it through a factory reset and get the existing firmware to boot up, so you may not have any option but to send it back to Olympus or buy another camera.

Sep 22, 2014 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

I have an Olympus E-510, and when taking a photo it takes a lot of times to save it in the memory card, and sometimes it takes so long that I have to turn off the camera to continue shooting. How can I...


Now,this you are memory card have any question,I suggest you to change memory card,if you need Olympus battery and charger,or else brand battery and charger,please for link http://www.batterieschargerstore.co.uk

Oct 10, 2011 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

How to use the Olympus 18-180mm f/3.5-6.3 ED Zuiko Digital Zoom Lens in low light.


The 510 seems to have trouble auto-focusing in low light. Manual focus works if there is enough light for your eyes.

Dec 16, 2009 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

Write protected-Olympus EVOLT E-510 Digital Camera.


Hi there
The write protect is on the memory card, take the card out and unlock it, it will be at the side of the card like this 59a6de4.jpg .
Good luck and thanks for using Fixya!!

May 15, 2009 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

Will Olympus RM-2 remote work with this camera


Yes the RM-2 is an accessory that can be used with this camera.

Apr 15, 2009 | Olympus Evolt E-510 Digital Camera

1 Answer

The flash will not "go off"


You could have burned bulb out.
But try checking settings for flash make sure they are turned on. You can due this through the menu functions.

Mar 08, 2009 | Olympus Camedia D-510 Zoom Digital Camera

2 Answers

Olympus E510, Flash Flicker


If you are in a low lit area with the camera dial set to Auto the flash will do a strobing type of flash trying to help allow more light into the scene. This is called the AF illuminator function. To just go ahead and take the image, put the camera dial to P (program Auto) go to Menu - go to Wrench 1 tab - then right arrow over and then down arrow to AF Illum - right arrow and turn this function from On to Off and then take the image in the P mode setting. No flash flicker should occur.

Nov 03, 2008 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

Olympus Evolt 510 LCD Issue.


I purchased a olympus evolt 510 - having problems taking picture in the dark. The camera will take 30 second to focus and sometimes will not take a picture at all. Also I find when I am in doors the camera will take a substantial amount of time to focus on an object this is specifically when the flash is in use. The flash seems to be adjusting flickering constantly. Seriously Annoying.

If you can be some assistance I would deeply appreciate it.

Best,

JP

Mar 25, 2008 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

Whirring sound when turning off olympus evolt e-510


Probably no problem. If RESET LENS is set to ON in the Wrench 1 menu, the attached lens will have its focus reset to infinity at power-off.

If IS is enabled when you turn the camera off, the IS gyro will spin down. Both of these things make some noise, but don't indicate any problem with the camera.

Mar 11, 2008 | Olympus EVOLT E-510 Body Only Digital...

3 Answers

Language setting on olympus E-510


http://www.digitalcamerainfo.com/content/Olympus-EVOLT-E-510-Digital-Camera-Review-14157/Design--Layout.htm

Mar 04, 2008 | Digital Cameras

Not finding what you are looking for?
Olympus EVOLT E-510 Body Only Digital Camera Logo

Related Topics:

318 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts

kakima

Level 3 Expert

96372 Answers

Willem.
Willem.

Level 2 Expert

345 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...