Question about Sony STR-DE475 Receiver

1 Answer

Sub not working with amp

Can you tell me how to get a sony amp STR-DE475 to work with a sony sub SA-W10 please. thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 151 Answers

Connect a sub cable to the amps sub OUTPUT then to the sub input turn the volume up half way on the sub then go to the amp setup menu and make sure the sub is switched on then set the cross over to suit your speakers,if your not sure set to 80hrtz.

Hope this helps.

CABLE GUY.

Posted on Feb 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a sony str-de475 and a kef PSW1000, i have the line in the left on the sub connected to the sub out on the amp, and the sub powers up, but im getting absolutly nothing from the amp and now all of a...


It's not clear if this has EVER worked or what is new in the scenario. The STR manual has setup instructions for supporting a sub. If you want to prove the sub itself works you could jack any source like, say, a CD player, into it to prove its amp will respond BUT IT WILL BE LOUD if it works.

Oct 05, 2011 | KEF Audio PSW 1000 Subwoofer

1 Answer

Helo ! I need to know why the subwoofer is silent when I connect it to my receiver-STR DE 475 . Plus , the sorround does not work . When I push the bottons , I either get the centre with the front...


Have you looked at the manual? There are procedures for adding a sub (which is NOT necessarily assumed to be there) and assigning bass to it.

http://www.retrevo.com/support/Sony-STR-DE475-Receivers-manual/id/387bh949/t/2/

Then there's the unidentified sub's manual and requirements to consider.

Sep 01, 2011 | Sony STR-DE475 Receiver

2 Answers

Right front channel not working


try to check balance adjustment if working.

Apr 16, 2010 | Sony STR-DE475 Receiver

1 Answer

Connecting a Sony Subwoofer SA-W2500 to a STR DE 598


It is based on your sub-woofer type..whether powered or passive sub woofer..
Assume that you have powered one..RCA sub woofer jack is the best to feed it ..you should use RCA sub woofer output on your receiver as well..good luck

Jan 08, 2010 | Sony STR-DE598 Receiver

1 Answer

Sony STR-DE475 - no surround sound


Thanks for all the info. It appears that the Receiver requires service as there is no test tone also. However, please clean the speaker cables and speaker jacks and reconnect. Also, try the steps mentioned in the link below.
http://www.kb.sony.com/selfservice/microsites/search.do?cmd=displayKC&externalId=C216020&fes=true&mdl=STRDE475

Sep 26, 2009 | Sony STR-DE475 Receiver

1 Answer

I have a sony STR-DE475 and the surround speakers have stopped working.


have you checked ur cables and connectors? check them with the multimeter and confirm

Jul 08, 2009 | Sony STR-DE475 Receiver

1 Answer

Working the Sony STR-DE475 5.1 Channels Receiver


It has a dedicated sub out. you need a phono connection on one end for the amp and the other end must have a compatable connection to your sub.

You will need a phono connection to the amp from your TV. You can utilise a scart lead that has phono outputs however a TV with audio outs (the red and white leads) is the default option.

Mar 31, 2009 | Sony STR-DE475 Receiver

1 Answer

No sound from rear speakers during test tone usng Sony STR-DE475


I had this problem last night.

To solve it, you can reset the amp by:

1) Put the receiver on stand-by
2) Hold down "MODE" button and press on button
3) "S.F. CLR" appears in the display and surround is back on.


Good luck

Dr Gardner

Jan 21, 2009 | Sony STR-DE475 Receiver

Not finding what you are looking for?
Sony STR-DE475 Receiver Logo

Related Topics:

162 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

4852 Answers

The Knight
The Knight

Level 3 Expert

72620 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...