Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

Hoover Self-Propelled WindTunnel U6436-900 cable problem

The Self-Propelled WindTunnel will not self propel. I am quite sure it has to do with the end of the cable line found just under the light. I do I re-attach that cable line to make the handle work and to make the the vacuum cleaner self-propel? Belts are fine and all has been cleaned. Any suggestions on how to attach the cable properly?

Posted by on

  • dublin6177 Feb 28, 2009

    Similar problem with my U6439-900. Mine goes forward but not backward in self-propelled mode.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 294 Answers

The flat belt should be changed if it has been longer than 9-12 months. Next I would remove the upper handle to inspect the top section of the control cable, sometimes it fray's and has a sponge feel (no positive control) to self propel. To set this adjustment, it is best to do withthe hood off of the lower section. I would also look at the cable jacket in the foot to make sure it is under the metal clamp. It must be under the clamp to work properly. To get it under the clamp loosen one hold down screw at the top and one in the back of the vacuum, remove clamp screws and put jacket into position and then secure all screws. Now set the adjustment, Install upper handle and set self propel to off. loosen cable from arm in foot with torx screw. manually move arm until the clutch is off both drive pads. This is a visual adjustment. then secure and reassemble vacuum.

Posted on Feb 28, 2009

1 Suggested Answer

nwj2468
  • 76 Answers

SOURCE: Hoover Self-propelled WindTunnel U6436-900 cable

the belt could be broken. check the belt for the drive system.

Posted on Apr 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover Windtunnel repair manual


click this link below to see repair video for self propelled mechanism
http://www.youtube.com/watch?v=K722IsUxjYM&feature=related

Sep 03, 2012 | Hoover Vacuums

1 Answer

Just replaced the belts on my Hoover Windtunnel II self-propelled vacuum. The brushes are now turning ok, but the self propelled feature is not working. Squeals when when you lock it in the upright...


Check the plastic part, which the the self propelled cable is attached to. (release the handle, tilt it back. You should be able to see the cable attached by a screw to a black plastic arm.) It is either broken or the cable is lose.

Nov 14, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Self propel unit broken


This is a farily common repair on this model. What ends up happening is that when someone picks up the vacuum cleaner2_bing.gif by the handle of the machine, which on this model also is the controller for the self-propelled transmission, it places too much strain on the actuator arm of the vacuum2_bing.gif cleaner.

You can do the best to try and not pick up the machine by the handle, but instead using the carrying handle on the back of the vacuum cleaner, this is distribute the weight much better, and even make the machine seem less heavy, and this will also prevent the actuator arm from breaking again in the future.

Now for fixing your vacuum, Please click the link below for an excellent tutorial on how to replace this part;

How To Replace The Actuator Arm On a Self-Propelled Hoover Windtunnel Upright Vacuum

Feb 23, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover windtunnel self-propelled - will not turn on


You probably need the switch replaced. It's fairly simple to do youself, and it is a known problem with these vacuums.
You can order the switch from hoover for about $10

Oct 08, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

How to install the belt on the hoover self propelled vac


Video Repair instructions on installation of Hoover Windtunnel Self-Propelled vacuum ;


If you found the video helpful, please be sure to rate it by clicking the thumbs up icon below. If you have any questions about this repair, please request a clarification below.

Thank you,

Chris

Jul 03, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Self-propelled WindTunnel U6436-900 cable


the belt could be broken. check the belt for the drive system.

Feb 24, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover self-propelled


No suction on Windtunnel 6630-900. All belts work, brush turns, it just won't pick up anything.

Sep 07, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Self-propelled Broken?


I have the same problem, found out there is a cable that is broken, I'm trying to figure out how to fix it.

Aug 11, 2008 | Hoover Self-Propelled WindTunnel Bagless...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

596 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...