Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

Self-propelled Hoover windtunnel (with bags) will not self-propel. Belts are all in order, but I am quite sure it has to do with the cable. How would I fix this and how does the end of the cable with a nut, connect?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 37 Answers

This might help - go to following website and look for "troubleshooting"
http://www.fixya.com/support/p40544-hoover_ultra_u6430_900_windtunnel_bagged/manual-4481/page-13

Posted on Feb 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to stop the main belt from comming off the motor shaft on a hoover modle u6634-900/windtunnel


Hello there! If you have replaced the belt and it is still slipping off, you may be not have the right belt for your vacuum. This unit takes a flat belt and a v-belt. Make sure you are replacing the belts with Genuine Hoover Parts. I have included the links below where you may go to order the belts specific to your cleaner.

WindTunnel PowerDrive Belt 2 Pack

WindTunnel Self Propelled Belt

Hope this helps!

Jun 21, 2014 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover Windtunnel repair manual


click this link below to see repair video for self propelled mechanism
http://www.youtube.com/watch?v=K722IsUxjYM&feature=related

Sep 03, 2012 | Hoover Vacuums

1 Answer

Just replaced the belts on my Hoover Windtunnel II self-propelled vacuum. The brushes are now turning ok, but the self propelled feature is not working. Squeals when when you lock it in the upright...


Check the plastic part, which the the self propelled cable is attached to. (release the handle, tilt it back. You should be able to see the cable attached by a screw to a black plastic arm.) It is either broken or the cable is lose.

Nov 14, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover self-propelled windtunnel U6430-900 flat belt gets hot & becomes hard to push. It has a filter bag. Purchased 8/2/01. Took one plate off bottom. Used a compressor to blow out dirt & dust. ...


Belts get hot when fibers from carpet get wound arounf the belts mounting shaft. Best to take a razor and cut off any fibers so the belt doesn't get hot again

Aug 10, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Self propelled feature does not work. I replaced


There is a cable from the handle down to the transmission on this machine that breaks all the time or the cable is mounted to a plastic piece that is broken. That will need to be replaced.

Nov 28, 2009 | Hoover U6476-910 WindTunnel Upright Vacuum...

1 Answer

Hoover windtunnel self-propelled - will not turn on


You probably need the switch replaced. It's fairly simple to do youself, and it is a known problem with these vacuums.
You can order the switch from hoover for about $10

Oct 08, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Self-Propelled WindTunnel U6436-900 cable problem


The flat belt should be changed if it has been longer than 9-12 months. Next I would remove the upper handle to inspect the top section of the control cable, sometimes it fray's and has a sponge feel (no positive control) to self propel. To set this adjustment, it is best to do withthe hood off of the lower section. I would also look at the cable jacket in the foot to make sure it is under the metal clamp. It must be under the clamp to work properly. To get it under the clamp loosen one hold down screw at the top and one in the back of the vacuum, remove clamp screws and put jacket into position and then secure all screws. Now set the adjustment, Install upper handle and set self propel to off. loosen cable from arm in foot with torx screw. manually move arm until the clutch is off both drive pads. This is a visual adjustment. then secure and reassemble vacuum.

Feb 24, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

Self Propelled does not work


if you look below the headlamp of your vac you will find a cable that attach's to a piece called the actuator arm. either this piece is likely broke or the cable itself. always work the power drive smoothly or things will break. also could be that the smooth belt is stretched and will cause the same problem. belts should be replaced every 4 months. good news is all parts above should be under $5. dont let anyone tell you that you need a power drive assy, that usually isnt the case. good luck!!!

Sep 24, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover self-propelled


No suction on Windtunnel 6630-900. All belts work, brush turns, it just won't pick up anything.

Sep 07, 2008 | Hoover Self-Propelled WindTunnel Bagless...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

221 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...