Question about Behringer EUROPOWER EP1500 Car Audio Amplifier

1 Answer

Behringer 1500 red light. Amp powers up fan comes on then a have a channel A red light that doesn't go out. No Sound

Posted by on

  • djrobneal00 Feb 24, 2009

    have the amp completely unhooked and no wires attached. so most likely the channel is bad. but i still can't get sound out of cannel b either. it done this right in the middle of a show. luckely around closing time. thanks

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

RED LIGHT MEANS THERE IS EITHER WIRES TOUCHING OR A BAD GROUND. IN WORSE CASE SCENERIO THE A CHANNEL IS BLOWN

Posted on Feb 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp will not put out sound The red light comes on


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Dec 28, 2009 | Solid Audio Formula Series F2000 2-Channel...

1 Answer

Behringer pmh mixer manual. 20 channel 800watt powered mixer no speaker output. I need to test the power supply and the amp modual. Thanks


Are there lights or effects windows lit up? If so, the power supply is likely OK.

If neither speaker is working, that is bad however make sure all your trims and sliders are right to send audio through. Some have a standby switch.

This probably has an HCA2400 amp board in it and those can burn up for various reasons including loose speaker cables.

Nov 28, 2009 | Behringer POWERED MIXER, 20 CH, 400 WTS...

1 Answer

Monitor blowen, mixer-monitor channel went out


THE MONITOR OUTPUT AMP MAY HAVE BLOWN...COULD MAY ONLY BE THAT THE JACK IS BAD OR JUST A COLD SOLDER JOINT.....OR IT COULD BE JUST ABOUT ANYTHING IN THE MONITOR CHANNEL PUSH BUTTON MASTER VOL FOR THAT CHANNEL TAKE IT APART TAKE A LOOK AROUND BEFORE YOU BRING IT TO A REPAIR SHOP IT CANT HURT GOOD LUCK

Jan 07, 2009 | Behringer POWERED MIXER, 20 CH, 400 WTS...

1 Answer

New behringer powered mixer, comes on, but doesn't hear anything.


Fan comes on with temperature rise. Not a problem if off till you start driving speakers loud.

Make sure standby switch is up. The slide switch is up to A/B.
The main fader iis up. Your input fader(s) are up. The trim controls are up enough. Inputs are plugged to input and not the inserts.

Be careful... this unit has a lot of power and can blow speakers.

Nov 23, 2008 | Behringer POWERED MIXER, 20 CH, 400 WTS...

1 Answer

Thumping speakers - no power light is on - wired correctly


the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers


It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Oct 31, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

QSC 2450 Power amplifier


i have a pyle pro 1000 watt max 2 channel mono and 2 channel stereo and when i get that thing loud the little red light cums on basically what i mean is that the amp on channel one is cooked i myself i wouldn't even use it y cause more damage

Apr 03, 2008 | QSC RMX-2450 Car Audio Amplifier

1 Answer

Multipal amps


make sure your speakers are connected correctly if subs and are inside the box then check connections also at times the rca at the back of the head unit can disconnect. if power light is on then error is either speakers not connected correctly, rca faulty or not connected or speaker output on amp is blown

Jan 03, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Not producing sound


It sounds like the power supply may have failed. I'm not familiar with that particular Boss amp but many amplifiers will light the power indicator even though the amp isn't operating.

Have you checked your speakers to see if they're blown?

Have you checked the wiring to make sure the speakers are still connected to the amp?

Dec 19, 2007 | Car Amplifiers

1 Answer

Amp not putting out sound


This is not a problem that a normal comsumer should try to repair themselves. It's time to take it to a pro. It sounds like you have blown out at least one of your output channels. If you are getting any red light at all then the good news is that the power supply section of the amp is probably still good. About half of all the electronics in your amp is for the power supply section. The other half is for the actual amplifiers of the amp. Good luck, I hope it's not too bad.

Jun 14, 2007 | Alphasonik PMZ12005A Car Audio Amplifier

Not finding what you are looking for?
Behringer EUROPOWER EP1500 Car Audio Amplifier Logo

Related Topics:

273 people viewed this question

Ask a Question

Usually answered in minutes!

Top Behringer Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Behringer Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...