Question about Kenwood KAC-9102D Car Audio Amplifier

2 Answers

I have two 12 inch spx subs and a Lightning Audio B4.250.2 amp, and im having truble with the amp actually coming on . Everything is hooked up to the back of the amp but yet it still doesn't come on. What might the problem be?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

You probably have your remote wire wrong to the deck take a wire an but it from the power and attach over to the remote amp will probably power up but will not turn off with the stereo will at least show you your issue

Posted on Apr 06, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 124 Answers

Check the ground wire going from the Amp. Let me know!

Posted on Feb 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is better? 2 12 inch subs each sub 750 watt for 2 15 inch lightning audio b1 bolt subs?


The simple rule of thumb is the bigger the better but there also is another theory if you have too many driver delivering the same frequency you might end up having phase cancellation at some point.
In other words unless all the driver are placed the same distance from your ears you will end up having cancellation of bass at some or different frequencies.So moral of the story is - More is not always good !!

Jul 15, 2011 | Lightning Audio B1.15.8 Car Subwoofer

2 Answers

BP1200.1 Car Audio Amplifier: is that amp good for 2 12 inches subs kickers 600...


that will most definitely be the best amp you will own and the only amp you will ever need to purchase.

May 13, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Amp burned out but fuses still good?


this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

1 Answer

Sub making horrible thumping garbage sounds


you need an noise filter in line. It's been a few years since I've had a system but I had the same problem. High power amps like the one you have can actually pick up on the electric pulses from your ignition system. I think I got mine at walmart, or auto zone, somewhere like that. Their pretty cheap too. I don't remember how its hooked up, but If you know how to hook and amp up, this should be no problem.

Jun 23, 2009 | Hifonics Zeus Z400 Car Audio Amplifier

1 Answer

Blown amp possibly?


i have the same amp with the same problem.....your best bet is to do what i did get a better amp(audio pipe,spx,kicker,punch,etc) do not get pioneer amp or sony anything

Jun 20, 2009 | Kenwood KAC-X501F Car Audio Amplifier

1 Answer

Amp runs but then will just turn off and red light comes on


you may have fried the amp pre outs in the head deck, try the amps on another stereo

Jun 01, 2009 | Lightning Audio Bolt B2.150.2 Car Audio...

1 Answer

Problem when hooking two 12 inch subs to one amp


the amp is no where near strong enough that sound you hear is called hard clipping and it will destroy your subs in minutes. depending on what model JL subs you have I can sell you a better amp.

Dec 30, 2008 | Planet Audio VX602 Car Audio Amplifier

1 Answer

Subwoofer Output Not Working...


first check that the subwoofer function on the actual head unit is turned up,second check that the gain on the amp is at bout half way then check that it is on a lp (low pass setting)
then check that the boost on the amp is turned up.
please leave feedback.
cheers

Jul 02, 2008 | Eclipse CD5405

1 Answer

No sound to speakers


is the sub dual or single?check sub first then try disconnecting all power including ground for 20min to discarge caps some amps mute if driven hard at low impedience .

Jul 01, 2007 | Hifonics BX1500D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9102D Car Audio Amplifier Logo

Related Topics:

588 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4823 Answers

yadayada
yadayada

Level 3 Expert

71288 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7009 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...