Question about Canon Optics

1 Answer

Internal battery terminal corroded and fell off

The internal battery terminal (or flexible metal connector) corroded and fell off.  I have a Canon Image Stabilizer 12x36IS 5.6 degrees, and the cylindrical battery housing for the battery with the negative end down in the camera should contain a metal terminal to connect the negative end of the battery with the stabilizer.  It is now gone such that I cannot "turn on" the stabilizer.  Help!!!!

Posted by on

  • Anonymous Jul 28, 2017

    Electronics do not corrode without being either mistreated or neglected.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Canon Master
  • 21,286 Answers

Old batteries leak and the battery terminals corrode. Replace the terminals and clean the area thoroughly.

Posted on Jul 28, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 903 Answers

SOURCE: MEGA Optical Image Stabilizer

The MEGA Optical Image Stabilizer helps correct hand movement from shaky hands, one of the main reasons why cameras produce blurry images. Lumix® Digital Cameras with MEGA Optical Image Stabilizer technology have a built-in gyrosensor that detects any hand movement and relays a signal to a tiny microcomputer inside the camera, which instantly calculates the compensation needed. A linear motor then shifts the Optical Image Stabilizer lens as necessary to guide incoming light from the image straight to the CCD. You won't even notice it working—all you'll see are the outstanding results!

Posted on Aug 31, 2005

  • 1 Answer

SOURCE: camera stabilizer not available

You should update a firmware to new version 1.03 / download from Casio site / . It will allow You to take pictures without camera stabiliser.
This problem with camera stabiliser needs lens alignement in authorized service.
Regards
Gryf

Posted on Oct 18, 2008

SOURCE: image stabilizer stopped working on Canon 70-300mm lens

Taken that you made sure that the IS switch was on, on the lens, yes you have to find a camera repair shop to get it fixed.
The best shops are authorized Canon repair shops. You can call Canon support, and they should be able to give you advice on what shop to send the lens to.
I hope this helped!
/Chris

Posted on Jan 20, 2009

  • 112 Answers

SOURCE: Our group has 2 pairs of Canon Image Stabilizer

when salt water gets in ..if its not cleaned soon then its probably to late...the cost of repair wuld be more than a new one...sorry...larry@reichinstruments.com

Posted on Aug 06, 2009

  • 11967 Answers

SOURCE: How to fix image stabilizer problem ?

If the subject moves, no image stabilizer is going to help.

Posted on Mar 06, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Running rough no power back firing


Hi, Scott and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage check for spark leakage in the dark.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
Good luck and have a nice day.

Nov 06, 2016 | Motorcycles

1 Answer

How to make a backfires in discover 125m bicycle?


Hi, Anonymous and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.

Nov 04, 2015 | Motorcycles

1 Answer

Why does my bike start misfiring over 3000 rpm, even it is ok on idle?


Hi, Daniel and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
Good luck and have a nice day.

Sep 05, 2015 | Motorcycles

1 Answer

Backfires while in reverse


Hi, Anonymous and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
https://www.tradebit.com/filesharing.php/search/0/2014+arctic+cat+bearcat+570

Feb 20, 2015 | 2014 Arctic Cat Bearcat 570

1 Answer

The bike when slowing down misfires and some times cuts out


Hi, Anonymous and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD Aprilia Rsv Mille

May 18, 2013 | Aprilia RSV Mille R Motorcycles

1 Answer

Serious misfire on power valve opening on full throtle on aprilia rs 125


Hi, Anonymous and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 1999 Aprilia Rs 250

Jun 28, 2012 | 1999 Aprilia RS 125 Extrema

1 Answer

1999 aprilia millie backfires whilst accelerating at about 6000 revs


Hi, Ross and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 1999 Aprilia Rsv Mille

Jun 06, 2012 | 1999 Aprilia RSV Mille

1 Answer

Battery light comes on


Hi and welcome to FixYa,

Based on your description, 2 possibilities:
  • internal fault on its electronic circuitry;
  • battery contacts.
Not that much that is user doable if it is internal, however, to address the battery issue:
  • clean the battery contacts of the camera;
  • in some instances, it may be needed to scrape these contacts to expose fresh metal;
  • while in some cases, it may even require that the battery contacts of the camera be stretched / bended in such a way as they exert more force/pressure to contact the battery terminals.

Hope that this be of initial help/idea. Good luck and thank you for using FixYa.

Mar 24, 2009 | Canon PowerShot S2 IS Digital Camera

1 Answer

Canon ZR400 red internal battery error


Just as a follow-up I managed to locate the problem. I opened the camcorder up as it is out of warranty anyways and found that there is a thin flat flexible cable which I will call a ribbon cable that is broken. It connects the main circuit board to the one that holds the external battery and internal battery. I have called Canon to purchase this part (it has a part number etched on it which when you read it off they say it sounds like a legitimate part number) and so far have not been able to get it (they assume it is part of the main circuit board assembly and have not been able to actually locate this part number). As it stands now I know the problem and can not get the part.

Oct 03, 2008 | Canon ZR400 Mini DV Digital Camcorder

3 Answers

Canon PowerShot G6 Stopped Working


no, there is not an internal battery in canon g6 for operating it.
probably the battery does not touch the internal connectors of the camera.

May 10, 2008 | Canon PowerShot G6 Digital Camera

Not finding what you are looking for?
Optics Logo

Related Topics:

614 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Optics Experts

kakima

Level 3 Expert

102366 Answers

old marine
old marine

Level 3 Expert

1972 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

168 Answers

Are you a Canon Optic Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...