Question about Kenmore Vacuums

2 Answers

I have a Kenmore Destiny Plus vacuum, and it doesn't have suction anymore. I've come to the conclusion that the tubes, I guess you can call them that, are plugged. I'm trying to find the user manual/service manual to know how to open the vacuum up to unplug the tubing.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It's October now so this is probably too late to be useful for you but it might help someone: I had the same problem. I used a bright light to see that there was a clog up high in one of the plastic tubes on the side. Using an untwisted wire coat hanger I went up through the flap on the bottom of the vacuum. I pushed the cork screw end of the coat hangar up the tube and twisted it then pulled it out. It took three times to remove the clog completely but it worked. A plumber's snake might work even better.

Posted on Oct 28, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If you have an air compressor take it and blow the heck out of it and the tubing plu the filters. you could also have your husband take a look at it or go to ebay and look up fantom thunder owners manual because it is the same product as yours just different name.

Posted on Feb 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miele Silver Moon Losing Suction Power


That is possible, also check for a.m. exhaust filter off the motor. Usually a very fine filter to stop dust that gets past the bag. May just need to open it up and clean out the accumulated debris.

May 02, 2013 | Miele s558 Silver Moon Vacuum

1 Answer

No suction


the hose can clog up insid where you cant see it my husband takes it off and runs water thru it to flush stuff out lets it dry then reconnects it

Sep 18, 2012 | Dirt Devil Featherlite Bagless Vacuum...

1 Answer

I have the bissell pro heat turbo microban cleaner. It's about 2 1/2 years old and maybe used 8 times. The brushes do not work and it's not suctioning up the water. I've checked the belt on...


You already said it, so check the carbon brushes. Once it is no longer able to push the rotor or stator it need to be replace. Carbon brushes are customized at the machine shop, so you should bring it so that you have a sample of the brushes itself. Just be observant when disassembling the motor so that you put it back to exact place.
Thanks for asking.

Jul 13, 2011 | Bissell ProHeat Turbo Deep Cleaner Upright...

1 Answer

No suction for Kenmore upright vacuum


You have not stated which model vacuum you have. Bipass vacuum have a bipass compartment which is under drive unit. Make sure there are no cracks around housing as this is where you vacuume is created. In order to have vacuum you must have airflow, in assences suction. No air flow, no suction. If the airflow is deverted somehow suction will stop. Your filter, your bag are all sources of air flow. Clog either and you lose suction. Start with loss of air, being cracks in housing,bag or filter

Feb 23, 2010 | Kenmore Vacuums

1 Answer

There is no suction from the hose on a Kenmore Destiny Plus Vaccuum Cleaner


there is clog in the unit. Either the bottom or in the hose. If you can take hose off, stick hose on end of broom handle and push out clog.

Jul 09, 2009 | Kenmore Canister Vacuum Vacuum

2 Answers

My kenmore centtral vac runs but does not ****. HELP11


#1 i assume u checked the bag and filter if so equipped?
#2 verify the hose is not plugged
#3 verify hard plumbing not plugged by taking something metal (quarter) and crossing the 2 little metal nubs at inlet (don't worry it is low voltage u wll not get shocked) it should ****
#4 if hard line plugged you may need a second vacuum to reverse flow
are all outlets not creating suction f so detach vacuum from piping and verify that vacuum is not the problem

May 06, 2009 | Vacuums

1 Answer

Kenmore vacuum model 37105 no suction


are the brushes moving?if so , it is clogged somewhere, that is my guess

Jan 26, 2009 | Kenmore Vacuums

1 Answer

Vacuum has lost suction


Check the throat of the vacuum head where the air is sucked to the filter box. Check that it is not clogged.

Jan 23, 2009 | Kenmore 34722 Grab-N-Go Upright Vacuum

2 Answers

Getting suction to use attachments


When the vacuum is in the upright position, it should give you suction thru the hose.

Dec 02, 2007 | Kenmore 31913 Progressive Direct Drive...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

604 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18331 Answers

Roger Potts

Level 3 Expert

694 Answers

kakima

Level 3 Expert

98796 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...