Question about Flotec 1 - 1/2 Sprinkler Pump Composite Quick Priming High - Capacity 115/230v

1 Answer

Need to replace impeler on flotec pump - Flotec 1 - 1/2 Sprinkler Pump Composite Quick Priming High - Capacity 115/230v

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 21 Answers

Contact flotec directly for impeller tollfree 1-800-365-6832
or they may have been acquired by Pentair so try
PENTAIR WATER

STA-RITE INDUSTRIES
200 Tate Street
Union City, TN 36261-024
(800)-800-468-7867
(FAX)-800-390-53

Posted on Mar 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rotor spins, but pump does not push water


This could be a plugged impeller. If you open the pump so you can get to the impeller you should be able to run a bent wire through the veins of the impeller. This is the first simple thing to check.

Aug 12, 2011 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

Flotec 1/12 sprinker pump runs 5 sec. and trips breaker


Hi,
The pump is seized up... you can try to open it and get it spinning... make sure that there is nothing stuck in the impeller...
other then that the motor bearing are locked up and that will also cause the pump not to turn...

heatman101

May 15, 2011 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

I have a 1 hp in ground Flotec pool pump. It is not pumping the proper flo. It makes noise when it starts but then clears up. The motor sounds good. How do I get a manual on the parts for the pump...


GOOD LUCK GETTING PARTS FOR THIS.. FRANK , IF WERE MY POOL I WOULD CHANGE THAT PUMP OUT TO A STA-RITE DURA GLASS.. FLOTEC IS A POOR COPY OF THE STA RITE.. OR YOU CAN CHECK THE IMPELLER IF IT IS PLUGGED WITH TRASH OR IT COULD HAVE A BAD CAPACITOR.. BRING IT IN AND HAVE IT CHECKED..

Aug 15, 2010 | Flotec Corrosion Resistant Convertible Jet...

1 Answer

It will start out with a good flow then will not pump any water even though it is keeping its prime.


You have some debris floating around somewhere. If you are pumping from a pond or a rain-barrel, you might have debris clogging the inlet. Or maybe you have a stone in the impeller - if your outlet is on top of the impeller a stone will sink to the bottom so you could have flow initially, but the stone would be carried up to clog the outlet within a few seconds. Or you might have stone in the hose feeding into the impeller - that stone could roll back down the hose even though you don't loose prime.

Jun 28, 2010 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

Pump quit....gets hot!


THAT IS A CHEAP PUMP. JUST BUY A NEW ONE, THEY ARE HARD TO GET SEALED BACK UP AND JUST TO FIND IT WORKED FOR A WEEK.. VEGETABLE OIL .. IT MUST BE NON TOXIC OIL !! .. VOTE

May 24, 2010 | Flotec 1/6 Hp 1260 Gph Utility Submersible...

1 Answer

How do I remove the impeller from my Flotec pump?


I called Flotec and they provided perfect instruction. Opportunity solved.

Dec 07, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

How do you remove the motor from a Flotec FPS5172, 1-1/2 HP.


The impeller screws on the motor shaft. First replace the through bolts in the motor. These are the long bolts, they will just cause headachs. On the back of the motor their will be a place to hold the shaft from turning, If you hold the shaft the impeller just unscrews. If you look in the center of the impeller it may have a set screw holding it to the shaft. If you have one of these it will be a left hand screw. Then you will need to break the impeller free as the brass that holds the impeller on will stick to the stainless steel of the shaft. Don't let how tight this is fool you when you put this back together it just goes on hand tight. Good luck

Nov 23, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

My flotec 4/10hp waterfall/utility pump was working fine for about 1 hour, now it's only humming and not pumping any water... ?


Clogged, Impeller loose and not turning. Remove strainer from bottom of pump and check for clogg and see if the impeller is turning.

Sep 21, 2009 | Flotec 4/10 Hp 3000 Gph Waterfall Utility...

2 Answers

Flotec Sprinkler Pump not priming


it might be that the pump is prewired at 230 volt and you are running a 115 power supply to it, if motor just humms and little water comes out this might be your fix

Mar 13, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

Not finding what you are looking for?
Flotec 1 - 1/2 Sprinkler Pump Composite Quick Priming High - Capacity 115/230v Logo

Related Topics:

1,166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Flotec Fountains & Ponds Experts

tsmith198007

Level 1 Expert

40 Answers

nathan

Level 3 Expert

634 Answers

Jay Finke
Jay Finke

Level 3 Expert

1222 Answers

Are you a Flotec Fountain and Pond Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...