Question about Eureka 1810 Central System Vacuum

1 Answer

My Eureka centre vac has no suction unless the motor is running

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 547 Answers

You must run it to have suction

Posted on Feb 19, 2009

  • albert getty
    albert getty Feb 19, 2009

    do you mean unless power head is running?

  • albert getty
    albert getty Feb 19, 2009

    if yes clean out filter or exhaust

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Eureka Smart Vac The Boss no suction from either setting. I have taken it apart trying to see if it was clogged but it isn't. Checked the hose it is not sliced.


Remove the bag cover and feel for suction above the motor. If their is suction there then check the bag compartment is sealed. You can drop a coin down the hose to check for blockages all the way to where the bag attaches.

Aug 16, 2013 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

I have no suction on my Eureka Smartvac. I cleaned the inside, it had been attached incorrectly so the inside compartment was full of lint, changed the bag but still no suction. My husband unhooked the...


Tear apart all hoses and make sure no clogging, also take apart to expose motor and make sure their is no dust on motor, this will cause symptoms you are describing, another thing check Impeller fan and make sure the fan is running and not blocked if fan is not working then will need to replace Impeller.

Aug 16, 2013 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

No suction. dirt goes into the filter instead of the canister


Check the motor and clean it properly. A very dirt motor will cause no suction or weak suction.
Be sure the motor is running on proper speed, a weak motor will cause a weak suction.
Thanks for asking.

Jun 25, 2011 | Eureka 4700A Maxima Bagless Upright Vacuum

1 Answer

Eureka Boss 4870gz shuts off (thermal protector) after 2 or 3 min


wiggle the cord while running the vac. if it cuts off from that, then you most likely have a bad switch or cord. if the motor was bad, you would smell it. it smells aweful.

Apr 25, 2010 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

Eureka 4870: Brush roller turns even in hose setting.


You either have the wrong size belt, most likely too small, or you have installed a new belt incorrectly. When you open the cover on the bottom of your vac, you will see the pulley that moves as you flip the switch from floors to carpet. The belt does not go around this pulley. When activated(carpet) the pulley puts tension on the belt causing it to turn the roller. When switched back to hard floors, the belt looses tension allowing motor to cause suction but disabling roller. Also, the dial on top of vac is only to direct suction, not for disabling roller

Jun 21, 2009 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

How do I remove motor from a Eureka 4870 GZ vac so I can replace


I don't know the 4780, but I do know eureka uses two basic types of motor housings:.. One, on the sanitaire is pretty straightforward with 3 screws on the topside after removing the topcover.
The second type involves splitting the case, since the motor is mounted vertically and is a more involved project necessitating removing most everything. Here is a schematic, and while you can see there is a lot to pull off to do this, it's not impossible!
http://www.elkypro.com/hoops2005/vacuum_parts/eureka/4750a.html
bear in mind, however, a replacement vac should only cost 50-70 dollars, so whatever your time is worth...

Jan 02, 2009 | Eureka Smartvac 4870 Bagged Upright Vacuum

2 Answers

Eureka Enviro Vac Model 4470 Not Sucking


First, check to see if there is suction without the hose on the base. If not, and there is no blockage, the problem is likely a damaged impeller, the small fan that makes the suction. That will have to be replaced.

May 21, 2007 | Eureka Smartvac 4870 Bagged Upright Vacuum

Not finding what you are looking for?
Eureka 1810 Central System Vacuum Logo

Related Topics:

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...