Question about PPI DCX-500.2 Car Audio Amplifier

1 Answer

I got a 500.2 dcx precision power amp, at first it bumped but lately it bumps but turns off (well not off it says clip out/ termal protect). I have to mess around with the power and ground outlet and then it bumbs but does the same thing agin.what could it be, is it the amp or the battery,or do I just need to buy new power and ground imputs?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

You might need to just solder them better

Posted on Jul 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Tail lights not working


Not for tail lights.
GeT a 12 Volt probe screwdriver with the handle that lights up or volt meter. Remove the bulb turn on tail lights clip to any good ground and put the probe tip on the bump at the bottom of the socket and it should lite up. Now clip ground to side wall of socket and probe both bumps in the center one bump is tail the other is brake. Have someone push on brakes and see if they light when on one bump then check tail on other bump. DO NOT TOUCH THE SIDE WITH CENTER PROB OR IT WILL SHORT BE CAREFUL. this will tell you where the problem is,

Also check fuse holder.
leave fuse in clip to ground turn on tail light and probe both ends of fuse for power.

Hope this helps Mike

Mar 03, 2016 | Cars & Trucks

1 Answer

Bump on carriage


We would need a bit more information.
Where and when does the bump occur?

Apr 18, 2013 | HP DesignJet 500 InkJet Printer

1 Answer

I just got my PPI dcx 300.2 amp back and i hooked it all up, and connected the fuse back in and started the truck, the amp turns on but the red light starts blinking and says clip out. The amp doesnt smell...


Are you sure everything is correctly connected. If you are running the amplifier in bridge mode then take note that the load to the amplifier can be no lower than 4OHM. dreamsystems

Feb 25, 2011 | PPI DCX-300.2 Car Audio Amplifier

1 Answer

Bumps good but every 10-15 min of bumping it


to much power hooked up to it take something away

Jul 21, 2010 | AudioBahn A8002T Car Audio Amplifier

1 Answer

My amp keeps going off on protection mode as soon as the bass starts bumping


check powers and earth, unplug sub and crank it up see if it still goes into protect if it doesnt the sub is too much load for that amp and could have damaged the amp, if it still does it then its a fault in the amp or power problem make sure you have good thickness 4gauge and good earth

Apr 26, 2010 | Legacy Audio American Legacy II LA290 Car...

1 Answer

No sound but still has power


Yes, one bad speaker connection can cause the radio to shut off all output in a type of protection mode to protect the rest of the speakers...if not that, if the vehicle is equipped with an amp, make sure the amp turn on wire is well connected.

Oct 23, 2009 | Pioneer AVIC-F700BT Car GPS Receiver

1 Answer

The protection light keeps coming on


That means something isn't wired right. Make sure that all of the power inputs from the battery are correct. Most importantly make sure no bare wires are touching (IE the positive and negative bare wires going to the subwoofer terminal.) If it keeps persisting, check the voltage level in the car and make sure it is normal, because some fancy amps have protection where it will go into protect mode if the amplifier is not getting enough power to supply. Also, does this happen when you are really bumping (like high volume) or just the second its on it cuts? Because when you really play it loud and it cuts, sometimes you are putting too much a load on the amp. Make sure the fuse in the amplifier is the correct fuse for the amplifier.

Oct 13, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Ppi dcx 1500.1 is it 2 powerful 4 da 12in. L7?


Hello montyski20,

The amp outputs 500 watts RMS into 4ohms, 750 watts RMS into 2ohms and 1000 RMS into 1ohm.

The L7 can handle 750 watts RMS (375 watts per each coil). If your L7 is the 2ohm version, you should wire the voice coils in series, the positive marked coil to the negative unmarked coil. Then connect the remaining positive and negative to the amp terminals. This gives you a 4ohm load (500 watts). If your L7 is the 4ohm version, wire the voice coils in parallel, both marked and unmarked positives together, likewise both negatives and then to the amp terminals. This gives a 2ohm load (750 watts).

Paralleling the 2ohm sub will result in a 1ohm load (1000 watts) and that is too much for the L7.

Hope this helps.

Aug 02, 2009 | PPI DCX-1500.1 Car Audio Amplifier

1 Answer

Mine has done the same thing. except its says "clip out"


sounds like it may be a power supply problem in the amp. If it was slowly getting worse, you may suspect a capacitor in the power supply to have failed, or popped. Open the amp, and look for any swollen tops of large capacitors around the big donut shaped coils. If any of their tops are swollen or bulged out, that's your problem.

Jun 12, 2009 | PPI DCX-500.2 Car Audio Amplifier

1 Answer

Protection mode


Disconnect all speaker wires from the speaker terminals of the amp. If it powers up and doesn't go into protect when you increase the settings, the wiring needs to be checked. If it still shuts down, the amp may need to be repaired.

Does it shut down or make loud noises when you move the RCA cables where they plug into the amplifier?

Mar 27, 2008 | Power Acoustik LT-980/2 Car Audio...

Not finding what you are looking for?
PPI DCX-500.2 Car Audio Amplifier Logo

Related Topics:

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top PPI Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a PPI Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...