Question about Peavey Audio Players & Recorders

1 Answer

No sound from power amp

The light comes on but no sound comes out of the speaker. What can I test and replace to get it working again?

Posted by on

  • 2dcapcom
    2dcapcom Feb 18, 2009

    thanks for looking,
    it is a peavey minx 110


×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

Without knowing which model you have, there is little I can do. Can you please update this with the model number? Also, are there any other indications that the amp is trying to work?

Thanks,
Dan

Posted on Feb 18, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The subwoofer just quit working the green light is on sound comes out (here voices) the subwoofer no bass


if the light still comes on then the fuse is still good....

a possiblity exists that either the amplifier or the actual speaker itself went bad....if you like you can dissasemble the the subwoofer to access the insides....a simple test....if you connect the driver to another amp (any amp will do as this is just a test) and it makes sound then chances are your amp is bad or just a loose connection.

Aug 30, 2010 | Sony SA-VF700ED Speaker

2 Answers

Red light is on and subs won't play all the wires are connected correctly it all of a sudden just stopped working one day idk y


sounds like the amp is in protection mode. try disconnecting the subs and see it the light changes to green. if it does then the subs are your problem. if the light was allways red while it was working then the subs may be disconnected inside the box or have gone bad. try using a diffrent speaker and connect to the amp.

Feb 06, 2010 | Audiovox Car Audio & Video

1 Answer

Amp powered protection on no sound


Disconnect the speaker wires and test again. If the protection light goes out, check your speaker wires at the amp and to the speakers. re-connect speakers one at a time and test until it goes into protection or your problem is solved. If a speaker connection causes the amp to go into protection, test that speaker with a meter or put it on a different channel. may be a blown speaker. If you need more help, post a comment and I can help you troubleshoot more.

Jul 06, 2009 | Car Audio & Video

1 Answer

I have an older red sony xplod 500w 4ch amp. the power/protection light is glowing red. what does that mean and how do i fix it? I have no sound.


The protection light comes on if the amp overheats or if the speaker outputs are shorted.

Turn everything off and check all of your speaker wires for shorts. When you locate and repair the short, the protection light should go out and your amp will work normally again.

Hope this helps!

Mar 26, 2009 | Car Audio & Video

2 Answers

RCA Pre-Out Making Producing a Mumming and a Popping Sound.


the speakers hook to speaker wires not to any thing else no power no negative poles do you have a remote shut off switch connected to amp this would be important to cut off amp

when cut off amp if you still here the humming this can be an indicator of low power being produced by alternator alternators produce 14 anything below 12 would mean replacement of alternator

if alternator fine then you need to find new ground for amp and make sure you have a good ground for sterio this can be checked with a test light
to check a ground all you do is hook gator clip to power then touch test light end to ground on radio end light comes on got a good ground (make sure not to touch any other sterio wires just the ground wire while connected to power to check grounds)
if pulsing in test light on the ground means you have a bad ground
just disconnect move to better ground

check the amp ground the same way as decribed above

May 09, 2008 | Pioneer DEH-P3900MP CD Player

1 Answer

Sony XM-2200GTX...Power, Green Light, All OK, No Sound!


Sony generally drives their power light from a source that does not rely on the amplifier's switching power supply. This means that it's not a good indicator as to the health of the amplifier.

 

As long as you have B+ and remote voltage, it will light up. Since you've tested the speaker and the signal source, I think the amplifier is likely defective.

Oct 17, 2007 | Sony XM-2200GTX Car Audio Amplifier

1 Answer

Kicker DX350


it sounds like you pop the power Reg. transistor or one of the Amp. chips instide. Some Amps has a pic fuse inside on the main board its green very small shape like a tear drop with a wire comeing out both ends it would in a socket some times white or black.

Sep 22, 2006 | Kicker DX350 Car Audio Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Peavey Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4872 Answers

Vito Vacirca Jr.

Level 2 Expert

137 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Peavey Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...