Question about Crown XTi 4000 Amplifier

1 Answer

Amp lights up but when it goes to actually kick on it shuts off

The amp is a crown xti4000 and when u push the power button in the lights sequence but when the amp is about to produce a signal to the speakers it completely turns off the amp is not getting hot exceot one piece it looks like a blue piece of ceramic bieng held by a black piece of plastic and it gets very hot. please help i need my beats

Posted by on

  • Anonymous Mar 25, 2009

    I have the same issue. The same capacitor is over heating (red hot). I bought this unit last week.. but it was manufactured April 2008.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

The only component I can think of that fits your description is a bypass capacitor for filtering high frequency interference. That should NEVER get hot. This amp is going into protective shutdown. This unit should be brought in for service. Continued attempts to run this will end up causing additional damage. Where are you located?

Dan

Posted on Feb 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My crown vid 4000 amplifier doesn't work.after switching power it goes off after maybe 2 sec.no speaker and input during powering. Same thing happen even there is speaker and input connected


Check speaker to power bank protection circuit. The circuit is faulty indicating to the power amp that speakers are disconnected that shuts down the amp to protect the unit

Mar 10, 2015 | Crown Amplifiers & Preamps

1 Answer

No sound from speakers or headphones fan not working gets warm


The Crown CE series of amplifiers have a 7 stage fan that runs as needed when the amplifier is working. Generally the fan is running at some point most all of the time, and you should be able to hear it ramp up as you push the amp to deliver more power. If the amplifier fan is not functioning, you may be in a thermal shut off mode that protect the amp from overheating by shutting off any signal. My advise would be to contact the manufacturer, and have it serviced.

Apr 05, 2014 | Crown CE2000 2-Channel Amplifier

1 Answer

Crowm micro-tech 2400 goes straight to protect upon start


Ok,

Lets get this straight, you are saying that a CROWN MICRO-TECH2400 power amplifier show the two front red lights when you turn it on? Because it supposed to do that if everything is fine, when you turn your amp on and one of the lights or both don't turn on then you have a serious issue with this great amp, keep me informed in case you need further help.

Nov 07, 2013 | Crown Amplifiers & Preamps

1 Answer

I have a crown xs500 amplifier. The right side stopped working. I got the "clip" light and the green light for about a minute as I was testing it, then both lights are out all together. This...


With a crown amp it can be any number of things. I would recommend having a service center test it and send it back to you. Working with the interior of a commercial amp can be hazardous because of the size of the capacitors inside of it. For the future I would recommend always having the amp turned of for any connection or disconnection of equipment.

Mar 22, 2011 | Crown XS500 2-Channel Amplifier

1 Answer

My crown 602 xls tripped a breaker, I reset breaker regained power to receptacle , I lost power to the amp no led's come on front when i pushed the small reset button on the back I still did not regain...


They use a breaker instead of a fuse.

http://www.retrevo.com/support/Crown-XLS-602-Amps-manual/id/19050ci763/t/2/

CONDITION: No

power to the amplifier.

POSSIBLE REASON:

• The amplifier's Power switch is off.

• The amplifier is not plugged into the power receptacle.

• The amplifier's high-voltage power supply circuit breaker has tripped. Verify that the AC mains

voltage is correct, then press the Circuit Breaker button on the back panel.


Take it to the ER.

Jan 12, 2011 | Crown XLS 602 2-Channel Amplifier

1 Answer

I have a crown Itech 4000 and when I plug it in it the green light around the front power button does not light up and when I turn on the power button on the front only the blue "power" light...


Nice amp. There is a breaker/switch on the back that trips to protect the amp. Turn it off, then back on and see if the green indicator comes back. If the breaker trips again, that's probably an indication of a more serious internal problem.

Nov 09, 2010 | Crown I-TECH 6000 Amplifier

1 Answer

No power just cleick when pushed the power button.


On a crown amp you will need a service manual man. That's like working on a Rolls Royce and trying to work on it with Toyota tools. Get the manual or do not wist your time, you will be spending loads of time on this if you don't. If you know where the diff. transistors are, check them out of circuit on high resistance.

Jul 06, 2007 | Crown CTS600 2-Channel Amplifier

Not finding what you are looking for?
Crown XTi 4000 Amplifier Logo

424 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68202 Answers

Are you a Crown Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...