Question about Kenwood KVT-512 Car DVD Player

1 Answer

Monitor says protect

I added new speakers to my jeep the first one was fine the second one after installing i turned on the car and now the monitor says protect with no sound please can someone give me an idea of how to fix this

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My kvt512 shows PROTECT on the moniter, how do fix it?

Posted on Jul 03, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

94 Jeep wont start running after 3 seconds.


It could be the security system or maybe a crank sensor.

Jan 04, 2010 | 1993 Jeep Grand Cherokee

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

3 Answers

I have a HPw1907 monitor and it will turn on for about 2 seconds, and it turns off. The CPU is fine, just a problem with the monitor. Any way to fix this?


We have the same model of monitor and had the same problem few days ago. The monitor just goes black/turns off. I noticed that the power button has a yellow blinking light and cannot be turn on/off again using the power button. The CPU is working fine also. When I turn off the avr, the power button's light turns blue for a few second and you can hear a click sound from the back of the lcd before it totally turns off. My lcd monitor is over a year old now and is 110v or 220v capable. Mine was originally in a 220v, i just put it in 110v and the monitor was fixed.. Hope this can somehow fix your problem.

Aug 02, 2009 | HP w1907 LCD Monitor

1 Answer

Protect mode??


Check your speaker wire and terminals at the speaker, it's shorting. The receiver goes into protection to keep from causing damage to itself.

Jul 04, 2009 | Kenwood KVT-512 Car DVD Player

2 Answers

Yamaha receiver turns off seconds after being turned on


It sounds like the amp is going into protect mode.
Dissconnect all speakers from back of amp and then try to turn on.
If it works, you have a short on one or more of the speakers.

Jun 13, 2009 | Audio Players & Recorders

1 Answer

97 JEEP WRANGLER


run a new earth wire to the bulb holder

May 30, 2009 | 1997 Jeep Wrangler

1 Answer

Stopped working


the ohms of your speakers might not be in your amps range

Apr 05, 2009 | Car Audio & Video

1 Answer

Kenwood deck reads protect and won't function


you have one of your speaker wires shorted out to the body of the car somewhere, or the speakers that you installed are bad. That is the only two reasons it will go into protect. Correct the problem, then reset the deck - it should work fine.
Kenwood builds this feature in to protect the outputs - so they dont burn up in the case of shorted speakers or wiring.

Jan 16, 2009 | Kenwood KDC-MP235 CD Player

1 Answer

No sound from monitor speakers. Worked fine for 5 years. Can hear sounds when using headphones plugged into CPU. Hope you can help even if only to tell me I need a new monitor. Sincerely Dizzyme.


Hi...there,
First of all, check if your audio cable are still plugged into the monitor and pc output (light green) audio jack. If not just plugged it back in... Still still got no sound... Then turned off the monitor and pc. Unplugged all the cables from the monitor and pc, wait for 10 second till all the surged built up are cleared out. Then you can plugged all the cables back Monitor should have 3 cables, a audio cable, a VGA or DVI cables, and a power cord... OK! now you got all the cables plugged back in...
Turned on the monitor and PC....and a few seconds....you should hear window started. Still... had a problems....just get a external speakers. Have nice day!

Oct 08, 2008 | Hansol H550 15" LCD Monitor

Not finding what you are looking for?
Kenwood KVT-512 Car DVD Player Logo

Related Topics:

315 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...