Question about SmartParts (1DPFSP01) Digital Picture Frame

Open Question

OUR SPX7E DIGITAL PICTURE FRAME DOES NOT START (DARK SCREEN)

Output of transformer checks OK at DC 9V.
Internal battery is at full charge.
Power cord continuity checks OK.
9 VDC reaches all the way to the terminals of the motherboard.
Ribbon connectors between motherboard and screen check OK.
All other connectors checked twice.
Unit is about one year old.
What's the next step?

Posted by on

1 Suggested Answer

  • 7 Answers

SOURCE: SmartParts Frame SPX7E only allows me to load 165 photos

2 answers...

To remove a picture, connect the frame to your PC via USB. you should see the frame appear as a drive, in my case,
36972 (E:)

open the drive as Explore, you can now see the pictures, and delete what you no longer want.

you can download the software from
http://www.smartpartsproducts.com/content/support/optipix/index.php

Posted on Oct 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

There is a malfunction in the THT


Hi Hashim.
EHT (Extra High Tension) usually reefers to the 24kv to 30kv, focus and first anode (A1) voltages required to operate the crt (picture tube). These voltages are supplied by the line output stage, primarily the line output transformer (often refered to as the flyback transformer). This transformer steps the voltage up to 8kv and an embedded rectifier trippler circuit tripples this to 24kv dc to supply the final anode voltage to the tube (Hence the big rubber cap and thick cable.
The line output transformer is driven by a smaller transformer (line driver transformer) via the line output transistor.
The driver stage is fed by the hoizontal oscillator circuit.
So we can see that a failure in any part of this circuitry will most often result in no picture. The line output transformer is the heart of the system, it not only supplies the EHT voltage it also has to
supply an LT voltage for the vertical output stage but also the sound output stage.
A Fault in the A1 circuitry would result in a very dark picture but sound ok. Or the picture badly out of focus.
The line output transistor going short circuit results in no picture and no sound with the set shutting down to the standby mode or
hic upping (making a ticking noise. This problem would be amongst the most common and is easily confirmed with an Ohm meter. The line output transformer itself can develope an internal short with the same results (less common). Failure of the line oscillator and driver stages are most easily confirmed with an
oscilloscope. A fault in the power supply will also give these symptoms. To confirm line output stage is functional look to see if the tube heaters are glowing, this supply also comes from the line output transformer. Can you feel the static if you run the back of your hand across the front of the screen (often feels like running your hand through cobwebs. this would indicate that the EHT is present and the fault is elsewhere. Understanding how something
works enables you to find out why it doesn't. If you have occasion to replace a short circuit transistor, be sure to reslder all pin connections to the line driver transformer. I've found dry joints here
to be a cause for random inttermittent failure of this transistor,
Best regards from Vintie.

Jan 07, 2014 | Sony WEGA® KV-XR25M80 TV

1 Answer

Cannot start up tabet and ac charger transformer is cold when plugged in


You will need an adaptor of at least the same output in both voltage and power. The only level that MUST be the same is the voltage. The power level must be the same or higher.

Jun 28, 2012 | Computers & Internet

1 Answer

Kodak picture frame will not turn on, has no reset button, unplug and restart does not work. How do you open the frame?


I had this same issue. I hadn't used my frame in about a year and wanted to turn it on to show photos during the holiday gatherings. When i turned it on it would boot up then shut off. I realized the cord I was using wasn't the original cord and the output voltage was too low to power the frame. Make sure you are using the correct ac/dc cord.

Dec 19, 2010 | Kodak EasyShare EX1011 Digital Picture...

4 Answers

Charger broke


common problem, go here
http://mrclm.blogspot.com/2009/09/black-decker-18v-firestorm-drill.html

May 14, 2010 | Black & Decker 18V Cordless Drill/Driver

1 Answer

I have a HT-3000 Casio keyboard. I can't get any power when I turn it on. The power indicator light does not come on. Is this keyboard worth fixing? or can it be repaired at a reasonable cost.I am not...


Of course, don't try higher voltage. Something wrong with your transformer, it should be 9V as an output. Parts of component inside transformer have broken, such as resistors, capacitors or even IC. I'm affraid it cause your kboard power circuits have broken also.

Oct 14, 2009 | Computers & Internet

1 Answer

My pandigital frame no longer displays anything. You plug it in and it's a blank screen


If you have an all grey screen than the frame is dead --- which menas throw it away. Check voltage on the power supply. Make sure voltage matches the output on the power supply. Also try connecting it tto the computer and formatting the internal memory.

Dec 02, 2008 | PANDIGITAL (DPF802) Digital Picture Frame

2 Answers

SmartParts Frame SPX7E only allows me to load 165 photos


2 answers...

To remove a picture, connect the frame to your PC via USB. you should see the frame appear as a drive, in my case,
36972 (E:)

open the drive as Explore, you can now see the pictures, and delete what you no longer want.

you can download the software from
http://www.smartpartsproducts.com/content/support/optipix/index.php

Nov 27, 2008 | SmartParts (1DPFSP01) Digital Picture...

1 Answer

Power cord


http://telephones.att.com/docMgt/public/art/162/1717_manual.pdf

The power cord is
Input: 120V, 60 Hz.
Output: 9V AC, 400 mA.

So , there is no need to worry about Polarity here. Just make sure , the output voltage is around 9V. DC input is ok. since there is bridge rectifier inside.

Aug 17, 2008 | AT&T 1717 Digital Answering Machine

1 Answer

Vtech DECT 6.0


get a multi meter and test the charging unit for 9v. if the transformer output to batteries is other than the 9.6, you will see that output.
it will say right on the transformer what the ouput should be.
it has to be at least what the output of what the battery is.
if it's not you'll need a new transformer.

i've seen this before where the battery output is 9v but the charger is only producing a limited out of around 3v.

Jan 14, 2008 | GE 28112EE2 Cordless Phone

Not finding what you are looking for?
SmartParts (1DPFSP01) Digital Picture Frame Logo

Related Topics:

199 people viewed this question

Ask a Question

Usually answered in minutes!

Top SmartParts Photography Experts

kakima

Level 3 Expert

102366 Answers

Joseph Hoffmann

Level 3 Expert

1701 Answers

Tony

Level 3 Expert

2599 Answers

Are you a SmartParts Photography Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...