Question about SimpleTech SimpleDrive 160 GB External USB 2.0 Hard Drive

1 Answer

Can't get my HD to connect

I have a simpletech signiture mini (160gb), but my computer will only supply power to the HD (acknowledged by the solid red light). The blue light however will not light up. I can't access my files I have stored on the HD and I need them. How can I get this fixed?
I have Windows XP.

Posted by on

  • 3 more comments 
  • bballmaniac2 Feb 12, 2009

    So with they "Y" cord I should connect them both?

  • bballmaniac2 Feb 17, 2009

    I have tried that. It did the same thing but thanks anyways.

  • fjwags Feb 18, 2009

    Same problem, i have used the y-card and plugged into 2 usb ports with no luck.

  • Anonymous Feb 28, 2009

    Same problem, with 7 out of 8 computers. Only one computer will find this HD.

  • Nicholas Gan
    Nicholas Gan May 11, 2010

    did you connect 2 usb ports to your computer? If you haven't, try doing so cos it'll give more power supply to your HD.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Yes you should. 

Posted on Feb 13, 2009

  • Nicholas Gan
    Nicholas Gan Feb 18, 2009

    have you tried plugging your HD to another computer to see if it can be detected? 

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The SimpleTech 160GB ext. drive has a usb 2.0 cable with a y plug. I can only plug in one but I use the additional power supply. I get a message at times telling me to use the usb 2.0 port for faster...


You are using the correct connection, the external power supply is powering the drive, so the USB cable is just handling data. I believe the message may be telling you that you will get faster performance using a USB 2.0 connection, it is probably sensing that your computer's USB port is USB 1.1.

Feb 24, 2011 | SimpleTech Signature Mini 160GB External...

1 Answer

I just recently bout a 250gb simple tech external drive. I came home installed but it wont show in my computer


You might try a different cable or use a USB "Y" cable to supply enough powere for the drive to work, as some computers have difficulty providing enough power from a single port. If you need more help, please call HitachiGST Tech Support M-F 8AM to 6PM PST at 1.888.426.5214 and a technician will be happy to help you.

Feb 02, 2011 | SimpleTech Signature Mini 160GB External...

1 Answer

I have a mini simple tech 160gb hard drive that when I plug it in an error message about power surge on the USB port. What can I do to get the data off of the drive


Probably not the right answer for your problem. Mine is an external 1 TB Simple Drive. Mine wouldn't respond at all. I unplugged the power cable from the back of the hard drive and replugged it in and instantly it worked (with the computer and hard drive plugged in). I had tried rebooting the computer, plugging/unplugging over and over into the computer and that didn't work.

Jun 17, 2010 | SimpleTech Signature Mini 160GB External...

1 Answer

I have a 160GB signature mini external harddrive. It has been working fine for months but all of a sudden my laptop won't recognize when I plug it into the usb port. The red light comes on to show that it...


It sounds like your hard drive is dead. If you have tried it on a different computer and it did the same thing then your drive isn't booting up and is probably bad.

Aug 09, 2009 | SimpleTech Signature Mini 160GB External...

3 Answers

External HD not recognizing USB ports as being Hi-speed ports


I have the same issue. I have 4 Simpletech Signature 250GB drives. They all worked fine at first. After about six months two of them started connecting at USB 1 speeds. It occurs on 4 different computers!!! The post about it being the computer assumes is wrong. How can it work fine for six months and then suddenly change. Also it occurs on different computers. I have submitted a tech support request with simpletech and will post the results.

Jun 14, 2009 | SimpleTech Signature Mini 160GB External...

1 Answer

Simpletech Signature Mini not recognized


Dear,
Please check this drive with another new cord to connect it with PC.

Regards,
Rakesh Kumar
Network Support Engineer

Apr 01, 2009 | SimpleTech Signature Mini 160GB External...

1 Answer

Fabrik simpletech 160GB external HD


Dear,
I think this is warrenty period and you should visit your nearest service center.

Regards,
Rakesh Kumar

Mar 31, 2009 | SimpleTech Signature Mini 160GB External...

1 Answer

Can't install SimpleTech 160 gigabytes


The usb port in your compute dosent support usb 2 please change the port if your system is latest dont connect both the usb cables of the hdd cauz the latest system is with usb 2 and dosent need power if old system please connect the power usb first and then the data usb cable it should work
please also try to connect to another port of your pc if available
thanks and regards
DUSHAYaNT

Jan 03, 2009 | SimpleTech Signature Mini 160GB External...

2 Answers

Not detecting


hmmm..what operating system you using..

Oct 13, 2008 | SimpleTech Signature Mini 160GB External...

Not finding what you are looking for?
SimpleTech SimpleDrive 160 GB External USB 2.0 Hard Drive Logo

959 people viewed this question

Ask a Question

Usually answered in minutes!

Top SimpleTech Hard Drives Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Arcadian Duran
Arcadian Duran

Level 2 Expert

284 Answers

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Are you a SimpleTech Hard Drive Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...