Question about JBL PB10 Subwoofer

2 Answers

When i plug in my subwoofer it has a constant hum

Constant humming in subwoofer. speaker hums when you plug it into wall. never had the speaker volume up to high so we don't understand what the problem may be.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Check to see where you are plugging it in. Plug all equipment into the outlet strips powered by the same AC outlet. Or use a direct box. Check your cords also. And lastly, return the product if you are under warranty and get yourself a new one. If the problem is still occuring, it probably has to be on your part, not the product. So try one of those examples before you return it.

Posted on Oct 15, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 52 Answers

Sounds like you have a bad connection somewhere. Make sure all of your connections are secure. If theres anything that is a little loose you'll get that hum. You might also try replacing your cable too. If it became pinched somewhere it could cause that problem

-Captain Jake

Posted on Feb 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have the Klipsch Sub-10 Subwoofer, and it no longer plays music. Now it hums (vibrates constant) and corresponds (louder or softer) with volume control. Light is home but no one home situation. V


Does the subwoofer have the same hum when the input cables have been unplugged? Many input cables use very fine conductors, which often fail. A bad cable will often introduce a hum and prevent a signal from getting through. If the noise is still present without the input cable(s) connected, then repair options are limited. No schematics are available. There's a daughterboard that has been available, but its failure usually causes the system to die (short-circuit). The cost to repair the amplifier may be close to the cost to replace the entire sub.

Sep 14, 2014 | Klipsch Synergy Sub-10 Subwoofer Speaker

1 Answer

Humming/buzzing


This is a nice speaker. You could get humming from the wires being crossed they actually do have polarity and better speakers will hum if the wires are crossed. The volume cloud also be too high without input. You also may have some interference with other audio wires or power wires close to the speaker.

Apr 05, 2014 | ElectroVoice . Speaker

1 Answer

Omni S8 Subwoofer Constant Hum


4amom-s8n is the part number for the amp assembly

Apr 08, 2013 | Speakers & Subwoofers

1 Answer

I have an Onkyo TX SR 700 receiver, Bose Acoustic Mass 10 speakers, Panasonic Viera 52" flat screen with my computer connected to the receiver. The computer uses a high end sound card. The flat screen...


Hi, what causes hums from speaker is when there is no ground shield from either the power supply or from the cable you plugged into the socket from the power supply.

So you will need to check that out and replace untrusted cables for connection..

If after doing this troubleshooting exercise, you will now need to test the speaker with another set to be sure the humming sound is not coming from there.

I guess that will Do.

Have a nice day...

Feb 18, 2011 | Bose Acoustimass 10 Series IV Home...

1 Answer

No sound


Hello endow1, hi, try this test, unplug you Logitech audio in plug and touch the input, you should hear a humming sound, Adjust the volume settings to high to hear it. If you cannot hear the humming sound, then there are problems you need to check. Place you speakers near your ear and adjust the volume Up and Down, you may hear a soft hum that should go up and down. Absence of the hum means that the speaker has loose connection from amplifier to speaker driver, or loss of power, check to see if there is pilot light.

Aug 19, 2010 | Logitech X-140 Speaker

1 Answer

My home theater speakers make a constant hum whenever my receiver is on. The loudness of the hum changes with the volume control, and goes away entirely when the system is muted. All components are plugged...


jd40,
Sounds like a grounding issue. The first two places to look into is the powered subwoofer and antenna. During your last test, did you leave the FM antenna and subwoofer connected? Many times the hum is directly related to the antenna and/or the subwoofer and to how they are grounded; creating a ground loop through the receivers ground on the outlet. If the antenna is grounded to the dwellings wiring, hum is inevitable and sometime you can get a ground loop hum from how or how & where the subwoofer is grounded. Try taking them completely out of the loop.

Also try taking it further back to the basics, start with the receiver plugged into a known good grounded outlet with no surge or line conditioner in the loop and nothing connected to the receiver, nothing. Use one speaker and different wire to test each speaker output while in tuner and any other mode but phono. With no signal, you will either get nothing (no hum or static) or just static in the tuner mode. No hum is a good sign. Some systems will mute the speakers if no signal is connected to eliminate the static from being produced through the speakers but a ground loop hum will most likely still be produced even in mute. If you get a hum when nothing is connected to the receiver, try looking into getting a better grounded outlet, even maybe to a different dwelling.

-Chris

Jan 30, 2010 | Yamaha 5.1-Ch. Surround Sound Home Theater...

1 Answer

Hi, I have a pair of Polk RT1000i powered towers and one now makes a constant loud humming or buzzing sound. It is not hooked up to the receiver. It does it as soon as its pluged into the wall. Any...


the volume on the speakers are too high. try to put make the speakers the master volume(whatever device you plug in into your speakers make that device's volume go all the way up and then adjust the volume on the speakers to what ever volume you desire.had the same problem with my computer speakers

Jan 16, 2010 | Polk Audio RT1000I Speaker

1 Answer

Humming sound when on/off


humming sound when on is usual if the volume is turned up.
humming sound the same when on or off could be transformer plates fluxing.
if loud recommend replacement of power supply.
if ok then recommend unplugging the device after use.

Nov 13, 2009 | Velodyne DPS-10 Subwoofer

2 Answers

Indicator light not working and humming noise


your circuit board is bad not repairable i have the same prob but not kenwood they said it would cost more then its worth.






Jan 03, 2008 | Kenwood 103SW Speaker

3 Answers

Miller & Kreisel Subwoofer 60Hz hum


This is a common problem.  The potentiometer is damaged and needs to be replaced.  Potentiometer is a fancy name for volume knob.  It's a $5.00 fix if you know what you're doing.

Dec 01, 2007 | Speakers & Subwoofers

Not finding what you are looking for?
JBL PB10 Subwoofer Logo

1,435 people viewed this question

Ask a Question

Usually answered in minutes!

Top JBL Speakers & Subwoofers Experts

Michael Edwards
Michael Edwards

Level 1 Expert

53 Answers

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

shaqsatin

Level 1 Expert

17 Answers

Are you a JBL Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...