Question about Cerwin Vega VE-28S Subwoofer

Open Question

Vegs 28s getting power but no sound

My vega 28s woofer just quit working. its getting power. when i turn it on the red light comes on and emmediatly green light comes on but no sound. whaat seems to be the problem ?

Posted by on

2 Suggested Answers

SOURCE: cerwin vega ve-28s

I had same prob ans cerwin replaced part in amp, it happened again few months later so they replaced entire amp assembly. i am very happy with it, they are a great sub, loud and deep.

Posted on Mar 05, 2008

  • 2 Answers

SOURCE: subwoofer goes to sleep

The receiver automatic speaker set-up set the sub volume at -12 and since it was not getting any signals from the receiver it was doing what it is supposed to be doing (going to the standby mode). This was troubleshooted by Onkyo tech support on a Sunday. All the best about Onkyo customer support.

Posted on Apr 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a cerwin vega ve 28s sub and noticed static sound coming out even when no music was playing. The next day sub went into standby in the middle of a song. If I turn it off for a couple hours it works...


First, disconnect it and let it run with no input. Problem here is that it probably has an auto-turnoff and will shut off. My bet is that either your connection wiring is faulty and/or your amp is sending down either RF or DC signals. I would get it close to the amp with another connection cable and check... Good Luck !

Aug 12, 2014 | Audio Players & Recorders

2 Answers

Hello. My ve 28s crackles when in standby mode, and also plays crackly bass. Please help me by telling me which component to replace within the amp. as I have no Cerwin Vega agent support here in South...


Hi,
This "Crackling" Problem is common with the Cerwin Vega VE-28S Subwoofer. If your subwoofer is out of warranty, and you know how to solder, you can fix the problem by replacing a few resistors, and transistors inside the amplifier. Get the parts on ebay: http://cgi.ebay.com/250756306868/

Sep 09, 2010 | Cerwin Vega VE-28S Subwoofer

1 Answer

Crackles and pops,even in standby mode


Does it only pop and crack when its connected to your amp or receiver ? i have the same thing with my sub [its not cerwin vega] but when i turn my amp off the sub doesnt pop anymore so i think my amp is the problem not the sub , yours might be the same problem .

May 19, 2009 | Cerwin Vega VE-28S Subwoofer

2 Answers

Subwoofer goes to sleep


The receiver automatic speaker set-up set the sub volume at -12 and since it was not getting any signals from the receiver it was doing what it is supposed to be doing (going to the standby mode). This was troubleshooted by Onkyo tech support on a Sunday. All the best about Onkyo customer support.

Apr 12, 2008 | Audio Players & Recorders

2 Answers

Cerwin vega ve-28s


I have the same problem and was told that it is failed amplifier....

Dec 02, 2007 | Cerwin Vega VE-28S Subwoofer

3 Answers

The red light on my amp keeps coming on and it wont work


You need to check your woofers. Most likely one or both may be a) blown or at a dead short or b) the ohm rating on them may be too low. What model woofers and amp do you have??

Nov 17, 2007 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

Cerwin Vega ve-28s subwoofer and new Cervin Vega 2-way satellites


I bought my VE-28s and it did exactly that crackled, cerwin replaced part in amp but few months later problem persisted. they then replaced entire amp assembly and its been fine. i really push it to and its been fine. to test it, unplug the connection from amp/ reciever and see if it persists. if so its the sub, if not its the amp/ reciever. dont dump it, these subs really crank and can put out some deep loud bass.

Oct 28, 2007 | Cerwin Vega VE-28S Subwoofer

2 Answers

Amplifier problems!!!


it sounds like your running your ohms to low, check to see what the amp can power and then read up online about ohms and your subs and how they should be wired

Oct 12, 2007 | Car Audio & Video

1 Answer

No Sound coming out of amp to subwoofer


check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

Not finding what you are looking for?
Cerwin Vega VE-28S Subwoofer Logo

Related Topics:

50 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cerwin Vega Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4804 Answers

Steve

Level 3 Expert

3287 Answers

Joe Lamb
Joe Lamb

Level 3 Expert

460 Answers

Are you a Cerwin Vega Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...