Question about Yamaha XS-350 2-Channel Amplifier

4 Answers

The two fuses f101 and f102 burned out at the same time, ?

My yamaha power amplifier xs 350 suddenly want out without specific notices. I opened the boxes and the only evidence was the two fuses, f101 and f102 are burned out. No other burning was visible. What can be at the origin of such an incident in my amplifier.
Thank you for your help.
Pierre Reymond

Posted by on

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 679 Answers

Hello,
You need to replace Both of the Fuse.
Guess:There is no other problem in your Amplifier.
Thanks for using FixYa. 

Posted on Feb 08, 2009

  • rockfixya
    rockfixya Feb 08, 2009

    and the Problem  occurs due to some Short Circuit in the cable of that Amplifier.
    so, please check the cable and power plug also.
    Thanks

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,110 Answers

Try to use a constant power supply..

Posted on Feb 08, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 848 Answers

Hi
it gets damaged when the input voltage is high .......thats it you need to replace it ......and check the voltage line.....

Posted on Feb 08, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,614 Answers

Could be a power surge on your area.

Posted on Feb 08, 2009

  • micromaster
    micromaster Feb 08, 2009

    or a not balance power input on the unit. better use a power surge protector next time.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HI. My Yamaha D80 while playing gave a burned smell and than sound quit. Rest works. I opened rearcover and notice 3rd fuse in the back was blown. Changed it. Blew again. So I stopped fidling around.


If the fuse blows and a smell of burning is present then its obvious there i a fault somewhere ahead of the fuse, the fuse is a protection device.

Oct 08, 2016 | Yamaha Cars & Trucks

1 Answer

Do capacitors in Yamaha Power Amd XS 350 hold the charge?


Yes if they are good they can hold charge for a long time just like a battery.

Oct 12, 2014 | Motorcycles

1 Answer

Yamaha home theatre system RXV 350 amplifier


Check it without speaker connection. If the set does not go to protection mode, check all the speakers by connecting one by one at a time and switch the set ON; to find the faulty speaker. If the set goes to protection mode even no speaker connected, check and replace damaged components at its audio output section circuit. If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Oct 07, 2014 | Yamaha RXV-350 Receiver

1 Answer

Yamaha no power


you need to check the power supply input of your amplifier using a multimeter set your tester into a dc voltage reading.then measure the power input you must have a DC voltage supply reading..open the cover check the fuse an open fuse will turn the unit to no power.there are causes of blown fuse a shorted power transistor at the circuit will blown the fuse you need to replace faulty transistors before putting up a new fuse...check also the diode at the power supply section ,faulty diode could lead to the same problem..

Sep 30, 2011 | Yamaha P-2500 Amplifier

1 Answer

F150 wont start replaced pump module on rearchassis now eng wont crank


Sounds like an issue with the fuse for the starter motor relay, or the starter motor relay itself.

The fuses for the starter system are F101 & F102
The starter motor relay is in the cab fuse panel.

The other thing to check if turn the key from off to run, press and hold the brake, and shift the truck into neutral and try starting with the brake still applied. This is testing the DTR ( Digital Transmission Range ) Sensor on the transmission. Should have no impact on what you did, could just be coincidence that the no crank no start issue just started.

Jan 11, 2011 | 2005 Ford F-150

1 Answer

Yamaha AX-500 amplifier won't turn on!


Check fuses in back. If not fuses the power supply is dead. Buy a new one. They do weae OUT EVENTUALLy

Mar 09, 2010 | Audio Players & Recorders

2 Answers

Amplifier For Powering Sony Xplod xs-l121p5


Pump the brakes!
You need to know the RMS power rating of the sub you are powering.
Dont exceed the RMS power rating of the sub by more than 25%.
If you see a peak power rating on either the sub or the amp, ignor it, means nothing. Always compare RMS ratings.
Example: a Sony 12" Xplod sub, boasting 1200 watts, will only handle, 350 watts RMS, so the amp you choose to power the sub should be 350 watts RMS as well, and should not exceed more than 25% of the RMS power handling (487.5 watts).
Bottom line, know your RMS numbers, not Peak.
Byron
www.distinctbeat.com

Dec 06, 2009 | Sony Car Audio & Video

1 Answer

I have a yamaha amplifier in here for repairs, the model no is A500, i cannot get the speaker protect relay to come on, i have replaced all the transistors & capacitors in the speaker protet circuit to no...


Measure DC to ground on the output transistors to check for any offset. The protect circuit is the least likely to be the problem. Post the readings here and I'll guide you from there.

Dan

Mar 11, 2009 | Yamaha XS-350 2-Channel Amplifier

1 Answer

Yamaha xs 350 no sound and protection lights are on


check your speakers cables and confirm good condition(no short circuit-no wire touches amp chassis)-no short in speaker itself connect it one by one and test after connection.

Jan 24, 2009 | Audio Players & Recorders

Not finding what you are looking for?
Yamaha XS-350 2-Channel Amplifier Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4850 Answers

The Knight
The Knight

Level 3 Expert

72601 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Yamaha Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...