Question about Audiofonics ADF-243 Car Audio Amplifier

1 Answer

T1500-1bd burnt mosfet

This amp was still working fine but drained my battery so i unhook the battery and remove amp-- It definatly smoked a mosfet. But I am unsure if this is the only problem or how to check for possibly faulty components. Any advise would be appreciated.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 68 Answers

First of all is the mosfet your talking about in the output section or in the power supply section? Most car amps use mosfets in the power supply section, some use them in the output section. To test the transistors in your amp, take a digital volt meter and set it to diode check. Then take the leads and put them accross the first and third legs of the transistors. Usally the red test lead on the first leg and black test lead on the third leg of transistor. If you get a reading of 000 then transistor is shorted. If you get a reading below 600 then transistor is on it's way out if not allready or it's next to a shorted transistor that is it's complimentry output transistor. comonly you will have 2 transistors working together, one NPN and one PNP per a channel, or 4 of them in a bridged type output circuit depending on the watts and how man channels your amp has. I was just looking at the specs of this amp and it's got me confused. It says it's a 2 channel but looking at all the info on different pages it says at 4ohm:200wattsx4 and at 2ohms:300wattsx4 and 1 channel mono 600watts into 4ohms. weird for a 2 channel. anyway that is how you test your transistors. Same way for the power supply section but, you will come accross a couple or more switching diodes that look like transistors and you will get a 000 reading when you test those like I specified. They rarely go out and most of the time there is only 2 of them. They will have a diagram like a diode on the front showing you which way the power flows. Let me know what you find out. Your amp should have went to protect mode if you smoked a mosfet.

Posted on Feb 12, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Boss 5500 watt amp stays in protection mode


The amp is going into protection mode because one or more of the output transistors is fried inside. You want to check for resistance on all the outputs. I repair these everday. Either have it repaired or do it yourself. I buy broken amps and I also repair them. Let me know if you want to sell or repair or want instructions on how to repair it.

Jan 05, 2014 | Boss Car Audio & Video

3 Answers

My amp started to smoke, and cut off,had a real loud burning smell,has not worked since.


Sounds like it was playing? If it was your voltage dropped and the mosfet power supply got toasted. These amps are notorius for burning up at low voltage. Kicker did not put a low voltage shut off on it.,

Sep 08, 2011 | Kicker ZX15001 1Channel Car Amp

1 Answer

Hooking up the amp i had the ground wire connected and was going to hook up the power wire and it hit the case of the amp know the amp turns on but there is no sound from the speakers other amps work on...


sadly, your amps' output MOSFETS are more than likely toast.

your amp was grounded, and you touched the amp chassis with the power line.
electricity will follow any path available to find ground. in your case, the output mosfets became your main ground-path since they are directly connected to the amps chassis (heat sink) and internally you had grounded the amp so power would flow full force through the output transistors in the serach for a ground.

open up your amp and smell the row of MOSFET transistors. you'll probably even be able to see some burnt transistor legs.

repair or replace.

May 08, 2011 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

I hooked up a dual mosfet 4 channel amp and i am not getting power to it. the way it is setup is from battery to 100 amp fuse, from fuse to inside cab of truck then to 500 K farad, Split from + to power on...


Bad ground sounds like you may have paint or undercoating stopping the ground from making good contact or unhook the remote wire and run a small wire from the main power to the remote hook up and see if it works ...... May have a faulty remote

Apr 25, 2011 | Dual 2-Channel Bridgeable MOSFET Amplifier...

1 Answer

I installed my amp into my 02 neon and it just drains the battery, even while amp is off.. while driving even the amp makes al te lights dimand flicker. i unhooked the power supply for the amp and now the...


Your amp is straining for power, try upgrading your alternator or and a battery in your trunk... or capacitor.And also make sure that the fuse closest to your amp is the total value of the fuses in your anp

Aug 02, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Kicker zr600 smokin havent even bumped yet today


Well it seems to me that the pictures of this amp show green ATC fuses which would be 30 amp fuses. What is your inline fuse from the battery? 40 amp fuses for the amp is too much current for the amps powersupply. If there was a short in the powersupply the max ammount of current that it could draw would be larger than designed to handle therefore damaging the amp.

Jan 02, 2010 | Kicker ZR600 Car Audio Amplifier

1 Answer

Trying to find the right FET to replace burnt up ones with


hafler use international rectifier hexfets. there is alot of confusion what constitutes a mosfet amplifier.
if the outputs are mosfets instead of bipolar transistors, it is a mosfet amp.
some designs are using mosfets to drive the switch mode power supply,but use bipolar output transistors.that is not a true mosfet amp.
you need to go to an electronic supplier for the repair industry.
or the manufacturers warranty depot,who will be able to order them.mosfets are very high current devices,you have to ask ...why did they fail. if they are the switch mode drivers,there is bad capacitors in that circuit

May 23, 2009 | MTX Thunder 5-Channel Amplifier 895 Car...

2 Answers

T1500-1bd burnt mosfet


Fosgate's get very hot.My first amp was a fosgate and I freaked out because it got really really hot. And smelled bad. So I moved it so where it could get more air That should help you out a lot and the smell went away on its own. As for your battery dying. Basically your stressing out your battery and your alternator is having a hard time keeping the battery changed. I'm sure you see your light dim when a low bass note hits. Invest in a cap. This will help save your battery your alternator and should even sound better.

Feb 08, 2009 | Rockford Fosgate Power 1500.1BD Car Audio...

2 Answers

Rockford p5002 amp is smoking...


Completely disconnect the amp and remove the cover. Look for anything that is discolored or burned.

Did you have one sub on each channel before the sub blew?

Jan 23, 2008 | Rockford Fosgate Punch P5002 Car Audio...

2 Answers

Audiobahn A6004T Amp Blown PLEASE HELP!!


They are most likely a MOSFET type of transistor. If they are in the power supply part of the amp then you will probably need to replace all the MOSFET's in the power supply along with perhaps some gate control resistors for them. They each have their own resistors. It wouldn't hurt to see if the 494 IC in the power supply is working properly too. This IC is what sends the pulse width modulated square wave to the MOSFET's. Next you will want to test all the MOSFET's that are used as the audio output drivers and their predrivers and bias resistors. Don't forget to check the DC bias and offset on the outputs too, to make sure everything is OK there. In short, you will most likely need to go to a repair shop that can do all this and who would know what the heck I'm talking about. Good luck.

Mar 05, 2007 | AudioBahn A4004T Car Audio Amplifier

Not finding what you are looking for?
Audiofonics ADF-243 Car Audio Amplifier Logo

210 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audiofonics Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

63801 Answers

Are you an Audiofonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...