Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

Windtunnel ultra U6425-900 stops running after 5 minutes

We have replaced all filters and bags

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 134 Answers

Sounds like its overheating and cutting out.
This is normally caused by a blockage or blocked filers.

Please leave feedback
Thanks
Rob

Posted on Feb 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

As I was vacuuming my vacuum cleaner stopped working


Hi, it's Allie from Crucial Vacuum!

Your Hoover Windtunnel may have stopped working for several reasons. First, make sure that your unit is properly plugged into an electrical outlet and make sure the electrical outlet is working correctly. Vacuum units, and other appliances, protect themselves from sudden electrical charges, ups and downs. Make sure the electrical fuse and breaker are on, if not reset breaker.

Some units may heat up and will automatically shut themselves down to prevent fires. Allow your unit to cool down for 30 minutes while the thermal protector is automatically reset. Overheating, may have been caused by a clogged hose, dirty filters, full bags or a roller brush that is not running properly. All these situations compromise the unit's air flow and make the unit work harder, making it to heat up.

To avoid these situations and to keep your unit running at it's maximum capacity, make sure to change filters regularly (recommended every 3-6 months), clean your brush roll from any tangled hair strands or debris monthly (roller brushes are recommended to be replaced at least yearly), and replace belts every 6 months.

You can purchase direct your replacement belts, bags, roller brush and filters from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10

http://www.crucialvacuum.com/hoover-windtunnel-self-propelled-roller-belts.html

http://www.crucialvacuum.com/vacuum-bags/hoover-type-y-paper-bags-18pk.html

http://www.crucialvacuum.com/hoover-40110006-three-layer-final-filter-2pk.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.



Alejandra (Allie) Sepulveda-Rivera
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Oct 04, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Why is my hoover windtunnel vacuum cleaner shutting off?


Hi there! Sounds like the thermal protector is being activated. This is usually caused by a clog or a filter that needs to be cleaned or replaced. Follow the steps below to prevent the unit from shutting off.

1. Remove the hose completely.
2. Use a broom stick to gently loosen and clear hose of clogs.
3. Remove the bottom plate and brush-roll.
4. Use a wooden spoon or something similar to break up and remove any clogs from lower hose.
5. Check the primary filter behind the side grille. If it is dirty you may rinse it under running water and allow 24 hours to air dry outside the vacuum.
6. Remove the bag door. Clean the primary filter located on the vacuum under the bag. Rinse with water and allow 24 hours to air dry outside the vacuum. The primary and secondary filters should be replaced at least once a year.
7. Check that the bag is not full. If it is, replace the bag.

The vacuum will turn back on when it cools off. This can take up to an hour. Hope this was helpful!

Jul 08, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Mach 4.7 runs for 2.5 minutes and shuts off


Did you use it to vacuum up fine materials like powder? If you cleaned the filters, but they are original to the machine, replace them. Try changing the bag to a fresh one as well. Beyond that, check how freely the brush turns. If it doesn't turn freely that can but excess load on the motor, if its covered in threads, remove those.

Aug 01, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I replaced the handle on my Hoover UH30010 Platinum Bagged upright and now the check bag light is on and vac will nut run.. Is there a reset button? How do I fix this?


Hey. I believe you will need to replace the main PCB board too. My new handle was sent with a new PCB board. However, I tried just replacing the handle first and it acted the same way you describe. Once I changed the PCB board it worked fine. Hope this helps.

May 25, 2012 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum what belt # do I need both belt # please


The wider belt is # 38528035,( package # 40201170 ), and the v-belt is # 38528034, ( package # 40201200 ). The wide belt should be replaced twice as often as the v-belt.

Jul 06, 2011 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

Hi I nee d remove the hood to get at the idel arm assembly for the belts. Thanks


Besides changing the bag, is there a filter to clean? Will not pick up even small
debris

Jun 05, 2011 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

I have a Hoover WindTunnel with a bag that makes a burning smell. I cleaned the brush and the belt looks intact. It still smells really bad. Could it be as simple as needing a new belt?


Hi there,

yes it could be that simple. sometimes the belt will wear and stretch. Generally I advise my customers to replace the belt once per year, or as soon as something gets caught to stop the brush from turning.

Your belt number should be on the model/serial plate on the bottom of the unit there. 38528-###. I am guessing its a 38528-033 but could be 38528-040. Your model/serial plate will be more accurate.

Nov 05, 2010 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

My hoover vacuum runs for about 10-15 minutes then the saftey feature shuts it off(overheat?). i have taking it apart a cleaned it with no results, added new bag also. after an hour it cools down and works...


Do you have suction through the tools? Does it look like it picks up when it runs? The machine could be clogged and that would cause the problem, but unfortunately the sensor that shuts the machine off could be bad if the machine isnt clogged. Its not easy to get to it, I'd take it to a repair shop.

Sep 16, 2009 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

MY CLEANER CUTS OFF


My Hoover S3639 on/off switch stopped working. I don't hear the 'click' any more. I removed the top of the vacuum but can't determine how to replace the switch.

Aug 18, 2007 | Hoover S3639 WindTunnel Bagged Canister...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

Related Topics:

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18330 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...