Question about Sony FD Trinitron WEGA KV-32XBR400 32" TV

Open Question

SONY WEGA XBR - good sound but dark/no picture

I have a SONY WEGA XBR - good sound but dark/no picture. Tried to play DVD, got sound, but no picture

Posted by on

  • wspegg Mar 25, 2009

    Good sound, no picture on TV or DVD.

×

3 Suggested Answers

  • 6 Answers

SOURCE: SONY 36 XBR SOUND BUT NO PICTURE

posible solution is adjust the screen to low.also check the trimer if it is working.check the resistor in the heater line...weng

Posted on Dec 29, 2007

jerryg50
  • 1667 Answers

SOURCE: Sony 36 Wega XBR Flat Screen - sudden death.

This could be a scan amplifier failure, and there is a loss of high voltage to the CRT. Part of the power supply may have also failed. In these sets, if the CRT emission goes low in emission, or the CRT goes defective, the bias supply to the CRT will go in to protect.

An experienced TV service tech can troubleshoot the set and give you an estimate for service. Considering the age of the set, the cost of service may not be worth it.


Jerry G.


Posted on Jan 08, 2009

  • 4 Answers

SOURCE: Sony Trinitron XBR TV, picture-in-picture got

A solution I found for our KV-32XBR200 was to press Setup on top of the set, then select the "Demo" item with TV/Video. The text overlay apparently banished PIP. Verified this twice, as I'm at this page because our remote can only turn PIP on :-).

Posted on Feb 17, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony 32" xbr trinitron trusurround T V picture is black


Most likely on a trinitron tube if it is dark is the high voltage capacitor has blown. This is the device that feed the 30,000 or so volts to charge the tube, it attaches at the back with a clip and ****** and a single cable coming from it.

You can check easily if it is definately that as you will notice if you power the tv on and off once or twice if you get that static charge feel from the screen, if there is none there then almost certainly that is the problem.

Mar 10, 2010 | Sony FD Trinitron WEGA KV-32XBR400 32" TV

1 Answer

No picture or sound when powered up. Red Standby light flashes continually. My Sony KV 36 XBR250 Wega Trinitron XBR is about 10 years old and has worked perfectly up to this point. What could be the...


Did you get your set fixed or did you replace it? My same set did the same thing. Turned it off for 2-3hrs after watching it and when I tried to power it up- nothing but the sound it would normally make just before the major power up, sort of a relay click sound. No picture or sound but the red light blinks non-stop.

Jan 20, 2010 | Sony KV-36XBR250 TV

1 Answer

My sony xbr 60 picture turns off and on


No solution for you...but I have the same problem. I also had the green blob problem which sony fixed earlier this year. It happens on an intermittent basis. Screen goes off, standby light blinks green, then comes back on. Its off for maybe 1-2 min.

Nov 07, 2009 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

Screen stays dark on my KF 60 XBR 800 (FROM 2003)


I think you need to check the high voltage in the damping diode if it is entering the picture tube. If this diode is faulty the tube will not light. you can also check the circuit before it enters the damping diode if there is voltage present.

Aug 17, 2009 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

No picture and buzzing sound on Sony XBR Wega


Is the bulb light flashing ? - Sony's bulb light is very accurate in telling you if the bulb is bad. The buzzing sound could be from the balist trying to strike the lamp. You also may want to open the lamp door and see if the bulb is shattered.

Aug 01, 2009 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

Sony xbr 60 grand wega color problem.


It sounds like to me you have a bad Optical Block. It is a expensive repair and you may want to call Sony at 1800-222-SONY and see if the would assist you in repairs. Due to the age of it, they would probably only cover a partial amount of the repair.
Hope this helps,
Skyassoc

Jul 23, 2009 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

Hdmi will not play for blue ray dvd


Bought playstation 3 and cannot use on Sony KDF-E55A20. No Pic No sound

May 21, 2009 | Sony Grand WEGA KDF-55WF655 36" Rear...

1 Answer

SONY 36 XBR SOUND BUT NO PICTURE


posible solution is adjust the screen to low.also check the trimer if it is working.check the resistor in the heater line...weng

Oct 30, 2007 | Sony FD Trinitron WEGA KV-20FS120 20" TV

Not finding what you are looking for?
Sony FD Trinitron WEGA KV-32XBR400 32" TV Logo

Related Topics:

576 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

72256 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...