Question about Legacy Audio LA770 Car Audio Amplifier

1 Answer

Amp Goes in protect whne bridged cuts out

I have a LA890 - American Legacy Series 2 4 channel amp and whenver i bridge it the amp cuts off and goes into protect. does anyone know what may be causing this?

Posted by on

  • whiteboy6917 Feb 05, 2009

    crossover 4 wut the channels?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

Do u have an crossover

Posted on Feb 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

When I bridge the BAMF 2200/2 Power Acoustik amp it cuts off


Hello munchisfun,

I'd suspect that the amp is operating into too low of an impedance and going into protection.

The 2200/2 is not rated to drive a 2ohm load when bridged (most 2-channel amps aren't) and when you connect 2 4ohm subs in parallel, the load is 2ohms. I'd run one sub from each channel.

Hope this helps.

Jul 26, 2009 | Power Acoustik BAMF2200/2 Car Amp

1 Answer

I have a PHOENIX GOLD RYVAL V1502 amplifier and trying to hook it up at 2 ohms as it describes it can be 450watts x2 at 2 ohms running wires from bridged positive and negative to the first sub then two...


Hello mgonzalez390,

It sounds like the amp/subs impedance is not matched. According to the published specifications for the V1502 amp, it is only stable in bridged mode down to 4ohms, not 2ohms. You need to get the final impedance that the amp sees up to at least 4ohms or it will continue to shut down and eventually fail completely.

If your subs are dual voice coil and can be rewired so that each sub has an impedance of 8ohms, then you can safely parallel them to the amp like you have described. If they are single 4ohm voice coils, then you have 2 choices. Connect one sub to each channel or if you want to bridge the channels, then wire the subs in series, not in parallel. Wire the positive bridged terminal from the amp to the first sub positive, connect a jumper from the negative of that sub to positive on the other sub, and then the negative from that sub back to the negative bridged terminal on the amp. This wiring results in an 8ohm load to the amp and it should work OK without shutting down. But the power to each sub will actually be less than if you wire them separately to each channel.

Hope this helps.

Jul 08, 2009 | Car Amplifiers

1 Answer

Protect Mode


Your probably not pusing enough wattage to the amp. Look into buying a capacitor for your set up. and you may need to run a thicker guage wire to your amp.

Jun 01, 2009 | Legacy Audio LA1030 Car Audio Amplifier

1 Answer

LA-1030 Protect Mode


you have an unloaded channel,so the voltage is exceeding what the protect circuit is supposed to see.you have to connect an 8 ohm resistor across the output of the unused channel.
do not drive a signal into it or you will smoke the resistor.
a 10 watt will do ok with zero signal input

May 23, 2009 | Legacy Audio LA1030 Car Audio Amplifier

1 Answer

Legend Amp hook up manual.


Pretty Straight Forward get a 8 or 4 gauge amp wiring kit.

Run your hot wire to the +12V from the battery make sure to install the supplied inline fuse near the battery don't connect to the battery until installation is complete.

Run the REM to your stereo power ant. Wire. if available.

Run the GND to Metal Chassis Ground keep it as short as possible.

Run the RCA Cable from the back of the Stereo to the RCA Inputs or Low Level on the amp.

This amp is 2 Ohm Stereo Stable which means you can connect 2 (4 ohm) speakers in parallel to each channel or 1 (4 ohm) speaker on each channel or you can connect 1 (4 ohm) Speaker in bridged mode.

There are other speaker configurations you could use but you cannot drop the load below 2 Ohm in stereo mode and no lower than 4 ohm in bridged mode.

Hope this helps


Mar 25, 2009 | Legend LA1490 - American Legacy Series 2 -...

1 Answer

KEEPS GOING INTO PROTECTION MODE


make sure that your running heavy enough gauge wire from the battery to the amp. make sure wires to bridge the amp is correct and the av wires from the deck are the right gauge should be like 8 gauge wires.

Mar 23, 2009 | Car Amplifiers

2 Answers

I dont know waths the amp for the two fuse on my Legacy II LA890


On your normal mid range amp it uses 20 amps, but on your up scales amps they use 30 amps

Dec 15, 2008 | Legacy Audio American Legacy II LA890 Car...

1 Answer

Why connect a car amp in series and will this help me?


Not sure if it's what was meant by previous poster. But if you're just driving the two subs off the 4 ch, and no other speakers, your best bet is to run pairs of bridged channels, ie use the 4 ch as a more powerful 2 ch amp. Then independently run one sub on each of these paired channels.

If you bridge all 4 channels (not sure if this is an option on this amp), and then run your subs in series, you will likely lose out compared to the peak power you could be seeing with two independently paired channels.

Dec 01, 2008 | Car Amplifiers

2 Answers

Bass sounds flat when volume is increased


probably your power is too short, increase your gauge wire, and your ground wire of the amplifier has to be shortly as possible, and the positive has to be enough to support peak power, you can also put a big capacitor on the positive wire to give some more power while the bass peak.

Apr 26, 2008 | Earthquake Sound PH-D2 Car Audio Amplifier

Not finding what you are looking for?
Legacy Audio LA770 Car Audio Amplifier Logo

Related Topics:

259 people viewed this question

Ask a Question

Usually answered in minutes!

Top Legacy Audio Car Amplifiers Experts

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Larry Spears
Larry Spears

Level 3 Expert

625 Answers

The Knight
The Knight

Level 3 Expert

68323 Answers

Are you a Legacy Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...