Question about Rockford Fosgate 800.2 Car Audio Amplifier

1 Answer

Car Amplifiers When i put one sub to my amp, it hits really hard, but when i plug the other one in it sounds much worse. How do i make both subs hit as hard as they used to?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 125 Answers

One of your subs is wired out a phase for your amp you must refer to proper wiring for that amp to wire two subs it will change the impedance. for more info go to :
http://www.rockfordfosgate.com/rftech/wire_calculator.asp
and follow instructions this site will show you how to properly wire two subs to your amplifier

Posted on Feb 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What would cause my fossgate t1500 to shut off everytime the bass hits hard I have two t12s that it pushes


Sounds like your amp isnt powerful enough to power your subs, whats the wattage of your amp and both subs? Its shutting off when hard bass hits to protect itself from blowing, a good feature as a blown amp means a new one. an amp should always be more powerful than the speakers / subs you are connecting to it. for 2 500w subs your looking at a 1200w amp minimum.

Feb 22, 2011 | Car Audio & Video

2 Answers

Hits hard with one sub but has no bass with 2


do you no what ohm your amp can do and what your subs are

Oct 07, 2009 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

Only one sub hitting


you most likely have them wired out of phase. Try reversing the wiring on only one of the speakers.

Apr 23, 2009 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

10 inch subs need help


It sounds like the wiring either to the amp or to the subs is put together wrong. This can be because you have them setup in stereo but have the sub on bridge mode or vica versa. This can also be from how you ran the audio input wither from speakers or rca..either wired wrong or the switch for the two options is wrong. Also make sure your gain is turned up. Sound also depends on what kind of box it is in. It HAS to be in a box.

Jan 28, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Amp problem


depends on what subs you are using that amp puts out a max rms of 150 watts x 2 no kicker brand sub will run of that low of power. the fading you are hearing sounds like the amp is being overdriven and it is hard clipping because it doesnt have enough power for the subs. that amp is designed for mids and highs.

Jan 09, 2009 | Kicker 04KX350.4 Car Audio Amplifier

1 Answer

Improper function


try hooking up your subwoofers in series. then connecting them bridged to the amplifier. as follows: positive from sub#1 into positive of amplifier left channel.. negative sub#1 into positive sub#2. negative sub#2 into negative amplifier right channel. turn the gain down as this will sound pretty loud.

Jul 13, 2008 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

Added another amp to system now subs dont hit as hard


This sounds odd, but try putting your subs out of phase from the mains. Just see if it changes anything.

Feb 16, 2008 | Jl Audio 250/1 Car Audio Amplifier

1 Answer

Treble come out with lowpass filter on


get it fix but sounds like a low current problem check cable connections

Jan 10, 2007 | Pyle PLA1485R Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate 800.2 Car Audio Amplifier Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...