Question about Kenwood HTB755DV System

1 Answer

Kenwood Home Theater

I have a Kenwood stero with the home theater package (not sure what model but apx. 7 years old) recently my powered subwoofer does not work. I have checked the fuse and power conections and they are all fine. I was told that the subwoofer wont work if the reciver is set on Front Loud and it does not solve the problem. If I use the reciver to check the speaker volume (it just sounds like static for all speakers and its normal) the subwoofer will work and turn on. Once the sound test is done the subwoofer will stay on for maybe 10 minutes and turn off. If I just turn on the reciver the sub will turn on somtimes and other times it will not. Any help ? Thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 84 Answers
Re: Kenwood Home Theater

Please update your post with any Model Numbers that you can retrieve, especially the subwoofer. Off hand, and with the limited amount of information that you have provided, I would GUESS that your subwoofer is simply overheating, and is being shutdown internally, hence protecting the fuse because no short is detected. If you haven't moved and or vaccuumed/cleaned around or near your system regularly, dust, pollution, name it, builds up and can easily prevent electronics from breeathing/venting properly.

Posted on Jul 31, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Can I connect a Kenwood sw-900 super woofer to a onkyo HT-R391 receiver home theatre sysyem

If your Kenwood super woofer is powered, look for an RCA subwoofer connector on the rear panel of your Onkyo and use that.

Dec 20, 2014 | Home Theater Systems

1 Answer

What is the impedance of the JAMO A3SUB.3 speaker?

22K is the impedance listed in the specs but you may have to look on the actual speaker itself to get the impedance of the physical speaker.

Sep 15, 2012 | Jamo HOME THEATER PACKAGE, 4 X A320,...

1 Answer

How to connect the speakers to the sb-wa342 panasonic subwoofer

I hope I understand you correctly.

As you can probably tell from the very different connector types on the subwoofer and the HTS, they don't match up. That speaker system and this electronics are not meant to be used together.

The SC-BT200 uses passive subwoofer while the SB-WA342 is an active (powered) subwoofer.

Jan 21, 2011 | Panasonic SC-BT200 Home Theater Systems....

1 Answer

I recently moved and am having trouble getting my phillips subwoofer system model : MMS171W hooked up properly There is a loud background hum when I attach it like I think it should be attached. Any ideas...

This is most likely a "ground loop" and is caused by using two different electrical outlets for the two parts of the system -- main receiver and subwoofer amp.

Try using the same electrical circuit (wall outlet) for all of the equipment in the home theater, using a power strip or strips as needed.

Nov 07, 2010 | Philips Home Theater Systems

1 Answer

I recently change my 2005 home theater speaker wires to monster cable wires, and now my subwoofer cuts of. Is this supposed to happen?

Shouldn't do this. Thicker cables do draw more power, but sub may not be able to handle the input volume wattage. Double check connections to make sure they are tight and getting full contact.

Jul 16, 2009 | Home Theater Systems

2 Answers

No Audio with home theater system

have you tried infra red link?

May 07, 2009 | RCA RT2760 System

1 Answer

Panasonic SC-660 speaker problems

The center and rear speakers are off if the PLII is disabled, make sure it is enabled by pressing the PLII button in the remote, you should see it on the display

Jan 22, 2009 | Panasonic SC-PT660 Theater System

1 Answer

No Power

I just recently moved back home to NY and hen I plugged in my subwoofer I have no power

Oct 21, 2007 | JVC TH-C3 System

Not finding what you are looking for?
Kenwood HTB755DV System Logo

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Home Theater Systems Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 2 Expert

232 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Are you a Kenwood Home Theater System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides