Question about Polaris New Genuine Polaris Snowmobile Accessories / X Treme Sidecut / Out of Bound

1 Answer

Wont start while riding at about 30 mph, sled suddenly stalled out.  I changed the plugs which started it back up.  after about 15 mins of riding, stalled out again.  Before stalling, sled backfired quite loudly.  I changed the plugs and added alittle water remover to tank.  Engine would not start.  Still will not start today.  I tried changing plugs again,  almost was going to, but next pulls were useless.  What do you think is wrong??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

You need to have your compression checked. this happened to me and one cylinder was toast. they should be around 120 psi and not more than 5% difference between the two. if not clean the carbs

Posted on Feb 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I bought a 2003 polaris edge X 800 last yr. with only 2200mi. on it, well taken care of and very clean.Only got 2 runs on it last Yr. First run out, 2hrs into it, she bogged alittle, I feathered the...


I literally had the same exact problem yesterday and last year. Perfect from start up to about 2 hours in...then sounds like it's bogging down, then dies at a trail stop. Fired right back up in about 2 minutes. Also it happened on a lake burn..wanted to die, so I feathered the throttle, came right back to life just as strong as it should be. It has me stumped. If you figure it out, let me know and I'll do the same. Mine is an 03 Edge 800 XC SP.

Jan 12, 2011 | Polaris New Genuine Polaris Snowmobile...

2 Answers

My sled loses power


Replace sparkplugs. Alsocould be a clutch or spark issue. Check the stator.

Feb 28, 2010 | Polaris New Genuine Polaris Snowmobile...

1 Answer

My sled bogs down going up hill or hitting the break


i have 1996 ultra sp runs great till i hit 80 mph then it starts to bog .

Feb 21, 2010 | Polaris New Genuine Polaris Snowmobile...

1 Answer

I have a 2004 polaris prox2600 snowmobile with perc reverse and every time i engage the reverse button the sled shuts off any ideas would be greatly appreciated


did you let the sled warm up first? If the sled is'nt warmed up flip the choke lever while its running and quickley press the reverse button make sure you shut choke back off or you can load up your sled. Good luck let me know

Jan 20, 2010 | Polaris New Genuine Polaris Snowmobile...

1 Answer

Sled started and ran fine then stopped ate dinner and then the sled was dead,. would not start. the nex morning started fine. do you know why


Maybe the coil.../ If it gets too hot it will not spark,once it cools will work.. have seen the same in some of the older cars....

Dec 24, 2009 | Polaris New Genuine Polaris Snowmobile...

2 Answers

Xc 600 stalling


when it stalls, is it on a warmer day? ie 20+ degrees? is it overeheating or hot? If you have never had the carbs serviced, the summer/fall may be a good time. inside the carbs, you have differnt circuits, they may be gummed up. Good luck

Feb 08, 2009 | Polaris New Genuine Polaris Snowmobile...

3 Answers

Snowmobile


First off, you need to put this under a different product.

For another, check the battery before you ask dumb questions!

Most efi sleds use a battery. Check it.

Feb 01, 2009 | Polaris New Genuine Polaris Snowmobile...

Not finding what you are looking for?
Polaris New Genuine Polaris Snowmobile Accessories / X Treme Sidecut / Out of Bound Logo

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris Snowboarding Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Lawrence Oravetz

Level 3 Expert

7565 Answers

bobalix

Level 3 Expert

443 Answers

Are you a Polaris Snowboarding Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...