Question about Kenmore 25512/ 25513 Progressive Canister Vacuum

1 Answer

Vacuum will not shut off

I have a model 116-25615506 and the power does not shut off. I have replaced the 3-position switch on the hose/handle and it continues to have the same problem. Once it is plugged in, it runs, even when the switch is in the off position. The switch (old and replacement) works to switch between activating the powerhead and turning this off (as it should) but when it is moved to the off position, the vacuum continues to run in non-powerhead-activated mode.

Posted by on

  • j_a_shiell Jan 31, 2009

    I hear what you're saying; however, this wasn't always a problem and I never adjusted any of the wiring prior to the problem beginning. It may be a wiring short somewhere?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,976 Answers

Sounds like you have wires crossed at the switch. The 2 wires coming in go to the center posts, 2 to the power head & 2 to the main motor.

Posted on Jan 31, 2009

  • David Shaub Feb 01, 2009

    Try turning the switch around. Put the power tool wires and the main motor wires on the opposite end of where they are now. If that doesn't make the motor shut off, there is a wiring issue in the main unit.

  • Jerry Servais Oct 22, 2012

    The old switch worked for some time then failed to turn off vacxuum. Replacement switch installed the same as old switch.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a dyson 07. Vacuum works fine, great suction using the hose. How do I switch to using the carpet vacuum. (I lost my instruction book) Thanks


If this unit has a suction hose built in to the handle, the carpet vacuum should start working after you return the handle hose to the proper position.

Dec 01, 2010 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

Central vacuum won't start even after depressing the reset button on the carpet sweeper. Hose and wand appear to be unclogged.


Is it only the power head that's not working, or the central vacuum itself? Disconnect wands from hose, turn on, and hold hand over hose end to check for suction. If none, go through first set of steps below.

If the vacuum:
1. Press reset button on vacuum.
2. Check circuit breaker at the circuit box to make sure it's ON.
3. Make sure the unit is plugged in completely.
4. Use a voltage tester to check for power at the outlet.
5. Check filter. If dirty rinse it with warm water, and allow to dry thoroughly. I strongly suggest having a second filter for use during drying, then just trade off using them.

If the vacuum still doesn't turn on, consider the following:]
Broken or worn out power switch in hose handle...Switch needs replaced.
Broken wire in hose...Replace hose.
Bad connection...Needs taken to an authorized Aerus service center for check and repair.

If the power nozzle (suction at end of hose, but power nozzle doesn't work:
1. Ensure the brush has been thoroughly cleaned of any hair, string, and other items that may have wrapped around it.
2. Power nozzle motor runs, but brush doesn't turn when vacuum is on...belt needs replaced.
3. Power nozzle motor does not run...All wiring, connections, and motor need to be checked.

If you can't determine the problem with the above helps, the entire machine, including hose, wands, and power nozzle, needs to be taken to an authorized Aerus service center for complete check.
If you don't know the location of the nearest Aerus Electrolux store, go to below site, type in zip code, and click on "view dealer list". They may also be able to send someone to pick it up.

http://www.aerushome.com/storelocator/

The reset button on the "sweeper" is only to start the "sweeper" motor after it has shut off due to the brush getting jammed. It doesn't effect the vacuum operation.

Oct 12, 2010 | Electrolux Central Vacuum

2 Answers

Power nozzle shuts on and off


HI There, When a Kenmore power nozzle cuts on and off, this usually indicates that your electrical hose has gone bad and has a short circuit somewhere. You can try and troubleshoot the hose to find out where the short is by trying to determine what position the hose is in when it cuts on and off, and try to isolate the short circuit by spinning the hose on both the end that plugs into the canister, as well as the end that plugs into the wand. Sometimes the short is in the wands, or even the swivel neck assembly on the power nozzle where the wands connect. I would say 9 times out of 10 though on Kenmore canisters, the problem is in the hose. Kenmore is actually manufactured by Panasonic, and the two brands use a lot of the same identical parts, including the electrical hose (most cases). If your Kenmore has a two position switch, with a setting for floors and carpets, then here's a link to the corresponding Panasonic hose that you can buy. The Panasonic hoses are a little more expensive then Kenmore, but the huge benefit is that they come 100% completely assembled, where as the Kenmore hose has to be assembled (which is extremely difficult even for me to do). Panasonic 3 Wire Electrical Suction Hose To Fit Kenmore Canisters On just a handful of Kenmore models, an additional modification has to be done with the internal switch. Kenmore must have had the hose modified so you'd have to buy the genuine Kenmore part, but luckily simply switching two wires on the switch will allow the Panasonic hose to work. Try just plugging in the hose into the vacuum first, and if it still doesn't work properly, then you can modify the switch. If you find that the short is in the wand or swivel neck, just use the comment field on this repair page and let me know, I'll be happy to follow up and walk you through either of these repairs as well. If this was helpful to you, please be so kind and rate the repair, or leave some feedback for me. This is greatly appreciated. Chris Jones GoVacuum.com

Jun 15, 2010 | Kenmore 22612 Bagged Canister Vacuum

1 Answer

The shut off switch is stuck to the on position


This sounds like you have an internal problem with the electrical switch. I would recommend you take it to a vacuum dealer who has experience with this model. This is a relatively simple reapir for a pro shop to handle.

Jan 13, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

Eureka Bagless Widetrack, The Boss, Vacume, model 5893


Had exactly the same problem with my upright Eureka Model 5893 bagless. Eventually, the handle would get hot, and finally it just quit. When handle was disassembled, the wires were melted and it was toast. Ordered a switch after talking to several repair men. Talked to Eureka, too, and they were absolutely no help. Cheap wiring and switch made in China. Good luck trying to find a switch. vacuum-depot.com has switches, so you might try there, but make sure you get the 3-prong switch (same switch used on Eureka's Genesis. It is Part #27871.

Jun 05, 2008 | Eureka Altima Upright Vacuum Model 2996AVS...

1 Answer

Kenmore central vacuum system


There is two possible causes. One you could be plugging in the end of the hose wrong. Make sure the hose end is securely in and in the right position. Second it could be a malfunctioning switch in your handle. Here is a site with a variety of different hose handle switches.

www.mountaincentralvac.com

Mar 12, 2008 | Hoover F5870-900 SteamVac Vacuum

1 Answer

No Power coming thru hose handle


It probably wouldn't help, it sounds like the switch. Have you tried pushing the reset button? (It's a little red button on the end of the power nozzle.)

Feb 24, 2008 | Electrolux Lux 5500 Canister Vacuum

3 Answers

VACUUM WON'T SHUT OFF


Need a model number to be sure, but alot of the Sears cannisters have a relay and it is found mounted in the motor comparment, it may be sticking in the on position.

Nov 26, 2007 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Main vacuum suction won't turn off


try cleaning out hoses,if that dont work turn it on its side if the roller doesnt spin u need to change belt if it does take the bottom cover and try cleaning out the hole under roller

Nov 22, 2007 | Eureka Altima Upright Vacuum Model 2996AVS...

Not finding what you are looking for?
Kenmore 25512/ 25513 Progressive Canister Vacuum Logo

Related Topics:

284 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60792 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...