Question about Sony XM-2150GSX Car Audio Amplifier

1 Answer

My sony xplod XM-2150GSX amp has a problen whenever i turn up the volume on my radio the amp turns on the current overload LED cAN enybody help me out i opened it but i just cant seem to find the problen in the circuit

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 156 Answers
Re: My sony xplod XM-2150GSX amp has a problen whenever i...

Often this is related to speaker wiring. Make sure your speakers aren't below the minimum rated impedance for your amplifier; 2 ohms per channel, or minimum 4 ohms in bridged mode. If you have two 4-ohm subs, you can't run them both in bridged mode if they're wired in parallel. If you have a blown sub, it can cause this problem also.

Posted on Jul 30, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have an XM-2150GSX 760watt sony amp, ive gotten everthing hooked up to it, but for some reason i have power to the amp but not to the subs, i know the subs are good still (i hooked them up directly to...

If you are hooking 'blue wire' (remote turn on for amp) to the power antenna wire (usually also blue) from the radio that could be your problem since the antenna only gets power when the radio is used

try using the switched 12 volt wire you used to connect your stereo power

i will assume all other wiring is correct and if so this should fix your issue - if not write me back with as many details as you can about how you have things wired and i will try to help more

good luck!!

Apr 15, 2011 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

My sony xplod 1200 whatt amps red light keeps coming on all the wires are good when it gos to hit it gos red

check your ohm load on the sub and see if your amp can do the same, That is why every time it shuts off into protection mode. Check your gain level on the amp to this is not a volume knob for your amp, It is to get both the amp and cd player on the same page. Hope this was helpfull

May 19, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

When i turn my amp up it goes into over current / offset mode and doesnt come back on until i turn the radio off and turn it back on

ive never liked xplodes it always did that to me..check youre wires make sure they are the correct gauges...if you buy an amp always buy from a dealer and make sure they install it correctly ...

Feb 21, 2010 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Amp turns on fine hooked up to factory cd player when u turn volume up red light pops on on amp

it means there not enough power going to the amp.or the power wire inside the amp has melted resalting in a bad conection

Dec 29, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Plays low volume but stops playen when u turn up

amp goes on protection few reasons
goes on protection, improper speaker connection,improper speaker class, speaker out-put damage (needs to get repair)

Sep 24, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

I have a Sony Xplod XM-1652Z 1000 W. I am using it to power my 2 Infinity 10" subs with 1052 watts on each Max. My problem is that when i turn on the volume too high the subs would stop working. My friend...

Sony audio products are not worth the buck, you will be facing worst problems in the future, my advice is just to change the amps. It is causing the problem, it cant handle frequencies when volume is turned up. and it may say 1000 watts but actually this is the peak rating your amp can handle thus meaning that it couldnt handle constant high volume usage, try crunch, kicker or hifonics amp, and look at the RMS rating on the amps when shoping.

Mar 31, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Overcurrent comes on when i turn up the volume on my head unit

The over-current LED tells you that you're driving a lod lower than the amp is rated to drive. You either have the wrong speaker ohm load, a shorted wire or a defective speaker.

Apr 30, 2008 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

Amp overcurrent problem

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down (overcurrent), the amp likely has blown output transistors.

Sep 20, 2006 | Sony XM-2150GSX Car Audio Amplifier

Not finding what you are looking for?
Sony XM-2150GSX Car Audio Amplifier Logo

Related Topics:

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56631 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides