Question about NEC MobilePro 900c Pocket PC

2 Answers

Device not detected

Hey all i'm a newbie, with a second hand mobilepro 900c. i downloaded activesync, tried to connect the mobilepro, but i keep getting "device not detected". i have done the obvious things, changing usb ports, reinstalling activesync, checking the COM ports... any other suggestions? this is making me want to throw the thing out! thanks

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: device not detected

If you have a sync cable ( just any USB cable is fine that fits in the SLAVE usb port of 900c ) -Active Synch > 3.x Version - USB Drivers for 900c then you are all set to go. Just connect the USB cable . New H/W found wizard shows up ---> install drivers from and check out that site for more stuff. and point to the drivers there. Once new device is installed. Take out USB and plugin again . Thats it . Good to go !!!!!!!!!!!!

Posted on Aug 21, 2007

Re: device not detected - NEC MobilePro 900c Pocket PC PDAs

Download the usb drivers

Posted on Aug 01, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Active sync

Do you have the proper drivers installed? Try here for USB to Computer Drivers if you have Windows XP: Also make sure that you have Activesync 3.8 or other version of 3. You can find it here:

Feb 26, 2008 | NEC MobilePro 900c Pocket PC

1 Answer

Device not detected

Incorrect, computers have no security measures for USB. Plug the USB device in without ActiveSync running and listen for some sort of jingle and look for any information balloons in the bottom right. If it jingles and says "searching for drivers", your device is fine and Windows is finding it fine. In which case, it's going to be an ActiveSync configuration issue. If it jingles in a somewhat "uh-oh" tone and says "windows does not recognise this device", you're USB device's USB interface is faulty. If it does not jingle at all, you may have faulty USB ports. What would help would be to tell me your Operating System type. Windows...?

Sep 17, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

NEC Mobilepro 900c will not connect w/computer

Are you using the NEC Mobilepro 900c drivers? I'm sure the drivers are different. YOu can find the XP drivers here: In addition, you should make sure that you have Activesync 3.8 or older. You can find it here:

Dec 25, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Mobilepro 900c won't sync

I'm having the same problem. Sorry man. I'll let you know if I find something out!

Nov 23, 2007 | NEC MobilePro 900 Handheld

2 Answers

NEC MobilePro 900c softeare

maybe is because processor ou version of windows ce

Aug 22, 2007 | NEC MobilePro 900c Pocket PC

2 Answers


Perhaps the programs you are trying to install are designed to run on your desktop PC and use activesync to transfer to the PDA..?

Aug 19, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Looking for software and I have a I.E. question

Olive Tree has a Bible program that runs fine on the 900c.

Aug 18, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Nec Mobilepro 900c

right clik my computer,go to properties,click on properties,click on hardware devices you will see the list of all the hardware components installed on your computer,check to see if your network adapter is installed,if not installed you will see a yellow balloon attached to the adapter icon,then try and install the device.if the device is installedbut you can't browse,i think that has to do with you internet configuration.try using the a unique computer name and the correct workgroup name,good luck.

Feb 27, 2007 | NEC MobilePro 900c Pocket PC

Not finding what you are looking for?

Open Questions:

0 Answers

I WAS TRYING TO INSTALL JLIME ON MY MOBILEPRO 900, EVERYTHING WAS DONE AS PER THE DOCUMENTATION AS PER THE WEBSITE. AFTER ALL THE STRESS OF PARITIONING THE FLASH CARD.. I GOT THE FOLLOWING ERROR.. "ROOT=/DEV/HDA2" NOT found kernel Panic VFS cannot mount I dont understand a bit of this error.. i ahve tried all the zImage files on the website.. but still I am getting the same error. I used the Henchman.tar--------( All the versions avaliable on website" Haret.exe as kernel Bootloader file which read as below # boot a kernel with HaRET # # have the kernel zImage and the Haret executable in the same dir as this file # this file if named 'startup.txt' will automatically launch the kernel when you start Haret # # 'set MTYPE 659' is for the NEC MobilePro900c # # in CMDLINE change 'root=' to point to the location of your root filesystem # eg 'root=/dev/hda1' is the first partition on your CF card # and 'root=/dev/hda2' is the second partition # set KERNEL zImage-2.6.23mp900c set MTYPE 659 set CMDLINE "console=tty0 console=ttyS0,115200n8 root=/dev/hda2" bootlinux i have tried mentioning "hda1" , "sda1","sdb1","sdb2" I believe its not the problem with the Henchman file or is it??? I have the following partitions sdb1 as boot flag which is fat-1GB sdb2 which is of ext2-2GB sdb3 as SWAP-1GB i loaded the boot files in the Fat ie the Haret.exe Zimage and startup.txt file in fat system Please help me out in removing this error and getting Jlime installed in My Nec Mobilepro 900.. I used a transend 4GB flash drive

Jul 16, 2011 | NEC MobilePro 900c Pocket PC

See all NEC MobilePro 900c Pocket PC Questions

NEC MobilePro 900c Pocket PC Logo

Related Topics:

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top NEC PDAs Experts


Level 3 Expert

18259 Answers

Jay Seifried

Level 1 Expert

51 Answers


Level 3 Expert

94198 Answers

Are you a NEC PDA Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides