Question about PPI DCX-600.4 Car Audio Amplifier

1 Answer

Orion 600.4 red light on & power light comes on & off

I just brought this amp & it was working fine then it just cut out now i get no sound & the red light stays on & the power light comes off & on only stays on for a brief second it goes on about every 20 seconds

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 61 Answers

Check the fuses and the ground to the body.

Posted on Jan 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

1 Answer

Sony xplod amp(XM-1652Z ) power/protect light


if your amp is overheating your sub is needing to much power that the amp doesnt have.
if its cutting out and the red light comes on you need to check the wiring. nothing not even the tinyest speaker wires can be touching.
proper wiring would be your best bet.
but i would upgrade amps.
cheap bang isnt reliable.

Apr 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

When powered on protection light comes on


ya i would say its not grounded right

Mar 02, 2009 | Car Audio & Video

1 Answer

Orion hcca 250 digital reference


if its hot its drawing to much current sound as if you have something improperly hooked up..if i could see your wiring i could help u out better steve

Feb 27, 2009 | Orion HCCA-D5000 Car Audio Amplifier

1 Answer

SOUND CUTS OFF AT HIGH VOLUME AND POWER LIGHT FLASHED RED


You need to check the DC voltage across the power and ground terminals of the amp. If the voltage drops below ~11v when the amp shuts off, you need to check the power/ground wiring and fuses.

If the voltage remains above 11 volts, you may have a problem with the load on the amp (incorrect ohm load, shorted speaker, shorted speaker wires...).

Jun 13, 2008 | Pioneer GM-X542 Car Audio Amplifier

1 Answer

Orion 12000


the speaker out let on back of speaker box went bad and burnt the circuits in the amp

Mar 15, 2008 | Car Audio & Video

1 Answer

Wiring for 2500d orion amp


ground wires(heavy black)is connected when the red light lit.so no need check the red hot wire which is connected to battery terminal maybe loose.or theres no power comming in.thre are 2 hotwire in that amp one is red which is the main and yellow or sometimes orange which is the remote on. now if you sure that the power terminals is properly connected,ur speakers is working and input wires are good and still no sound. your amp is probably gone...do not try experimenting the wires or hook up two amp by any means..u might destroy all ur amp. hope this help u....

May 11, 2007 | Orion 2500D Car Audio Amplifier

Not finding what you are looking for?
PPI DCX-600.4 Car Audio Amplifier Logo

Related Topics:

272 people viewed this question

Ask a Question

Usually answered in minutes!

Top PPI Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a PPI Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...