Question about Solo S2 Radar Detector

1 Answer

Varifying detection I have a escort solo 2 , about one year old. I am beginning to wonder if it is working correctly. A few weeks ago l accidently left my window down during a rain storm. I wondered if it had gotten wet, but it booted up fine. All displays work and self test seems ok, although I've lost the manual. And I seem to get the usual false signals from the usual filling stations etc. in town.One filling station gives a false K warning. A flashing signal south of town still give a false x signal. I use the AUTO setting. BUT I have passed a dozen cops , city and highway patrol in that time since the rain without it ever displaying an alarm. I can't believer none of the cops around here ever cuts on his radar any more. Any chance the solo can self test ok. And false warn on the usual places, but not be working on real cop radar?????

Posted by on

  • Anonymous Jan 19, 2008

    same problem, passed several officers and no notifications

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This happens often, as the units are basically very expensive bricks. They usually work quite fine for 12 months and 37 seconds though! The devices are built by prisoners in Ohio on a work-release program ... do you think they care? No, really, do ya? After getting hosed for $340, be prepared to cough up more cash. And, even then, there is no guarantee that the "repair" will last long, as it is only warranted for 6 months after the "repair" is completed. Oh, and btw, it WILL fail again. ZZTop watch  your speed, as the S2 you describe is doing squat. As for an onboard self-test feature, this is a GREAT idea, but, of course: 1) You are dreaming and 2) This would completely ruin Escort's business model. 

Posted on Nov 20, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Escort solo 2 won't power on


cinnatti microwave corp will repair the unit if returned to them,seems as if the power cable got switched around and power was reversed to unit causing internal fuse to blow. the chg is appox $25 takes about two weeks

Nov 14, 2011 | Escort Vehicle Parts & Accessories

1 Answer

Toshiba 32" Model# 32A33 TV About 5 years old


change tact switches
you have windex syndrom
using too much windex cleaning tube

Aug 26, 2009 | Toshiba 32A33 32" TV

1 Answer

Engine seems to be burning oil. escort van 1.8 d year Y 2001 used 2.5 litres of oil within 3,000 miles no leaks showing and co is correct as just passed mot less than a week ago.


You should have the compression checked to see if the cylinders are in good shape. When a deisel starts to use oil, it burns it as it would fuel. The mot test is o/k because your emission system is working well. Hope this helps.Moe

Apr 28, 2009 | 2001 Ford Escort ZX2

1 Answer

Won't go off


The first thing to try is to do what is called a "factory reset". What this does is to force your RD to reload all of its factory default settings straight out of the programmed firmware. These new settings will then overwrite any present settings which may be corrupted. Here is how to do it (specifically for the Solo S2):

Solo S2’s Factory Settings
To reset Solo S2 to its original factory settings,press and hold the Mute and M (Mode) buttons while turning Solo S2 on.Solo S2’s display will provide a “Reset” message,accompanied by an audible alert,acknowledging the reset.

Mar 11, 2009 | Passport Solo Radar Detector

1 Answer

Escort doesn't work


There is no place where you can send it in for any type of service. Not only that, your Solo's performance is horribly outdated compared to any current Bel or Escort radar detector model. Even Whistler offers high end models which significantly outperform your old Solo. It is time to upgrade, plain and simple.

Dec 18, 2008 | Solo S2 Radar Detector

1 Answer

Television picture issues...


I had the same problem when I accidently hit the remote. If you are hooked up to cable make sure INPUT is on the correct setting -- AV, S-Video, YPbPr1, YPbPr2, VGA, HDMI1, HDMI2, ATV & DTV (see button on TV or remote). Hope this solves your problem.

Jul 27, 2008 | Astar LTV-3201 32 in. LCD Television

2 Answers

Rear wheel bearings keep going after only a short period of use.


When you install the bearing are you replacing the complete hub? The torque spec for this is 130-174 ft.lbs. Also are the rims and tires of stock size?

Jul 07, 2008 | 1998 Ford Escort

2 Answers

Camcorder has problems


I've had mine for about 3 years and just last year it started giving me playback problems....the screen would have blue stripes across it and sound won't play. I could usually fix it by rewinding and playing again...but it's not correcting itself right now... I hope I didn't waste 60000 yen on this c_c;

Oct 07, 2007 | Video Cameras

Not finding what you are looking for?

Open Questions:

See all Solo S2 Radar Detector Questions

Solo S2 Radar Detector Logo

Related Topics:

400 people viewed this question

Ask a Question

Usually answered in minutes!

Top Escort Vehicle Parts & Accessories Experts

Steve

Level 3 Expert

3289 Answers

Marvin
Marvin

Level 3 Expert

81285 Answers

jason

Level 3 Expert

905 Answers

Are you an Escort Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...