Question about Kenwood KAC-8152D Car Audio Amplifier

1 Answer

Kac-8152d powers on, but no power output to subs

I have a kenwood KAC-8512d amp and i had it professionally installed to power two 12" kickers. It worked great for about a year or so and while ill was driving one day, my subs just quit working. I thought it was faulty wiring from the amp to the subs so i got new and better wire and hooked em up and got nothin. Moral of the story is, the amp's power light shows that its on, but it does not put out any power and ive checked its fuse and its good. Any suggestions?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Well, the sad thing is, it can be a number of things. You will have to do a process of elimination. Try replacing the amp first, borrow one off a friend. Second try replacing the subs. If those don't work, read the manual to your deck. Find the audio settings, and check to see if the sub section is "on".

Posted on Jan 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bridging two12" subs and one 15" sub to my Rockford fosgate T 1500bd amp


assuming all 3 subs are 3-4 ohms, running all 3 in parallel (the 3 positive leads all attach to the amp positive terminal, and all 3 speaker negative leads connect to the amp negative terminal) will bring you at or above 1 ohm, which the amp is capable of handling. With 1500 watts, you will want to use 8 gague power leads for the amp, 12 gague speaker cables, and an inline 120 amp fuse between the amp and the battery, within 1 foot of the battery.

Jan 11, 2017 | Rockford Fosgate Car Audio & Video

2 Answers

Do you need to connect the yellow and red wires together if not used in a car on a pioneer DEH-X1950UB


Yellow - Connect to the constant 12 V supply terminal.
Red - Connect to terminal controlled by the ignition switch (12 V DC).

Jan 11, 2017 | Pioneer Car Audio & Video

1 Answer

With the Uniden UH7700NB How do I tell which is positive and negative on the power input THANK YOU


You can connect the radio to any standard 12 volt DC power source, with either a positive or negative ground. If you don't know whether your power supply uses a positive or negative ground, consult the manual for your power supply or contact the manufacturer.

Jan 10, 2017 | Car Audio & Video

2 Answers

I have a Sony STR-KM7 AMP and the subwoofers have stopped working?


Sorry but it sounds like the subwoofer voice coil has shorted, you will need to replace the sub.

Jan 08, 2017 | Sony Car Audio & Video

1 Answer

How do I reset a Kenwood KDC-24BU flashing "PROTECT"?


Take of your positive battery cable. This should erase all your memory, since the car has no more power.

Jun 01, 2014 | Car Audio & Video

1 Answer

How do I reset a Kenwood KDC-24BU that is flashing "PROTECT"?


Replace the blown/shorted amplifier output Mosfets that are causing it, and it will then be happy to reset itself :)

Jun 01, 2014 | Car Audio & Video

2 Answers

No power to amp


check and try finding another grounding spot

May 16, 2010 | Lightning Audio B4.250.2 Car Amp

3 Answers

Lightning audio b150.2 as soon as +12 is hooked up blows 25 amp fuse and the c2 1000uf/35v capacitors blow???????


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Double check all connections .A thumbs up would be greatly appreciated if this answer is helpful to you.

Aug 25, 2009 | Lightning Audio PC2 Capacitor Car Audio...

2 Answers

RCA CABLES


RCA cables are the best way to get the audio from your head unit to the amp. If your head unit doesn't have RCA outputs, you might be able to use the speaker outputs of the head unit to connect to the "high power" or "high level" inputs of the amp, if the amp has such inputs (check your manual).

Mar 23, 2008 | Lightning Audio LA1.300.2 Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

218 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4732 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...