Question about Car Speakers & Subwoofers

1 Answer

I recently was told that the intake manifold for my 2004 Mazda 3i 2.0L engine needs replaced! The car has 47,000 miles on it. Regardless of my dismay and disappointment, I have to get it fixed! The dealer gave me the part number of LF62 13 100J. However, I cannot locate the part on the Internet. If you can help, I would greatly appreciate it! Clickety clank in Long Beach, CA Thanks, Dennis

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 27 Answers

Okay dennis you dont have to use the oem parts okay go to xs_power.com kk they should have what your looking for

Posted on Feb 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I bought Alpine X-305s head unit for my 2004 Mazda 6. My Mazda has the standard AM/FM with CD player. It does not have the BOSE system. It does not have an additional CD changer. My question is: will I...


The usual items you will need is a wiring harness and an install kit. The wiring harness will allow you to hook the radio to it, and then just plug into the car. The install kit will have all the little mounts and trim rings you might need. Each of them cost around $15 each, unless you have some crazy set up. Your's doesn't sound like that. You can purchase these items at www.crutchfield.com and you can search for your specific vehicle. Hope this helps.

Aug 24, 2011 | Alpine Car Speakers & Subwoofers

1 Answer

Just bought a mazda tribute 2007 - had new engine put in and now no radio..... is there a standard code i can input ?


Check your owners manual for the radio code. If its not listed in the manual you will need to contact a Mazda Dealer.

Jun 04, 2011 | Car Speakers & Subwoofers

1 Answer

98 explorer 4.0 missfireing and rough idle 147000 miles changed plugs and wires and coil pack no change tried sea foam injector cleaner and ran for 50 miles nochange code says #4 cylander misfire what...


Check/change the #4 plug. Make sure the gap is right, ceramic not broken, and that the plug wire is on correctly.(both ends) Did you use dielectric gel when you installed the plugs? Good idea to use it.

Apr 01, 2010 | MTX Ford Explorer/Mercury...

1 Answer

Factory bose speakers wont run on a normal stereo


Im sorry to tell you, but they are telling you the true. Unless you have the factory Radio that comes with those speaker they are useless to you unless your car is the same make as the one that those speaker came out of. Each speaker have four wires coming form them? If they have only two wires on them you can use them in series with other in your home theather system.

Nov 01, 2009 | Car Speakers & Subwoofers

1 Answer

Power but no sound 2004 mazda 3 s


Being a sport addition, I bet it has premium sound, premium sound means amplifier. If you have a volt meter, find your amplifier, and test for power. If it is getting power, and no sound is coming out then it needs to be replaced, or rebuilt. Those amps can be found at junk yards for a reasonable price. Those amps can be found at the dealership, for an absolutely retarded price.

Aug 08, 2009 | Car Speakers & Subwoofers

1 Answer

Rough idle on 1991 mazda navajo


It is the throttle positioning sensor about 40 dollars at your local parts store.

Nov 15, 2008 | MTX Ford Explorer/Mercury...

1 Answer

Rover 200 engine trouble


This sounds like a blown headgasket, which is not good. Pull the spark plugs and look to see if any are wet after the motor has run for a minute or so with coolant in it, or have a compression check done, that will find the problem. If it isn't the headgasket, it could be the intake manifold cracked, or the gasket there.

Either way, good luck.

Jan 01, 2008 | Car Speakers & Subwoofers

1 Answer

Misfire and rough idle


It may be the Ignition module. This is the little thin circuit card that tells the Coils to fire. Trace the small electrical wire from the 1,3 coil back to this module.

Dec 11, 2007 | MTX Ford Explorer/Mercury...

1 Answer

Kenwood GE-3i


1 wire might be a remote turn on 4 the lost amp. connect a light tester to the ground wire turn on and off the pre amp and see if the light goes on and off 1 might also be a floating ground wire .

Oct 30, 2007 | Kenwood KSC-WA100 Car Subwoofer

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

109 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Speakers & Subwoofers Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...