Question about Technics SB-AS60 Speaker

Open Question

No sound from Sub

Technics Subwoofer model SB-AS60. Listening to music and it just stopped. No sound. Checked the fuse, its good. Nothing blown. When i push the power button i can hear the computer in the back clicking and whirring like usual. Nothing out of place, other then the thing doesnt rattle my cages anymore!

Posted by on

1 Suggested Answer

  • 85 Answers


hi, i will sugest you , just clean the volume control with lighter fluid,, then let it dry,, its just a dirt,, try it,, ,, coz iv done it many times. . . . god bless .. gud luck

Posted on Mar 01, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

1 Answer

What can cause a sub woofer and room speaker woofer to stop

Check wiring for loose connection...may have to open speaker enclosure.

Jan 04, 2016 | Velodyne CHT-8 Subwoofer

1 Answer

Paradigm pdr80 no sound

If it is a powered sub, the sub power supply may have failed. There might be an open fuse.

Dec 25, 2013 | Paradigm PDR 12 Speaker

1 Answer

Klh s120eth subwoofer not producing sound.

Normaly C26 has turned bad. It's 22uF/25V and is easy to access when module is disassembled.

Dec 29, 2012 | KLH Speakers & Subwoofers

1 Answer

PS8 Subwoofer started buzzing non-stop

with nothing connected and the sub turned on....Most subs buzz when the circuitry starts to fatigue. The last time I heard this ..the repair ended up being one of the two fat capacitors inside the sub. I have a means of testing this,,you may not. I am a repair shop with a bit of experience in component level board repair.

May 06, 2010 | Proficient S12 Subwoofer

1 Answer

I have had my subwoofer for 6 years. It has always

One way to check the operation is to connect a source directly to the inputs of the sub.

A CD player will work fine. Connect the out puts of the CD player to the inputs on the sub. Play a CD.

If you get music from the sub, then no problems with sub.

If nothing, sub has problem.

Could be

A Dead amp.

A Dead speaker.

Velodyne products usually need to be returned to them for service.

Cost is unknown.

Sep 02, 2009 | Velodyne DLS-3500 Subwoofer

1 Answer

Wharfdale PC 10 subwoofer

Some basic trouble shooting is required here. First you need to see if it is a problem from your source or the sub. Try a different source to the sub-woofer and see if it changes the response. If still nothing on the sub, then most likely there is an issue with the amp or driver. Check to see if there is a fuse on the sub, if so, it could be blown. There could also be an issue with the auto switching circuit on the subs amp, in that case, it would need to be repaired in the shop. But before that I would check all of the connections to the sub, and also to the driver in the cabinet. If everything looks good, then put some type of source directly to the woofer to see if it works, if you get sound, then looks like the amp has a problem. Again a repair or replace issue.


Aug 20, 2008 | Wharfedale PowerCube PC-10 Subwoofer

1 Answer


hi, i will sugest you , just clean the volume control with lighter fluid,, then let it dry,, its just a dirt,, try it,, ,, coz iv done it many times. . . . god bless .. gud luck

Mar 01, 2008 | Technics SB-AS60 Speaker

2 Answers

Subwoofer just stopped working. There's power but no sound.

I have the same problem. My guess is that the subwoofer coil is messed up. You MIGHT have to get it recoiled. But before you do any of that get someone with a sub to play their sub in your car, if it works.... then your sub is messed up, if not.....then your amp is messed up ( trial and error ). Today i noticed my subs rubber surrounding is crooked, that may be the problem for me. Also when I press down on the sub it makes a sticking sound, like something came loose. So once i get everything opened and out ill let you all know the solution. Good Luck!

Jan 05, 2008 | Jensen JS1000-A Subwoofer

1 Answer

IC Component

Hi guardofsv....your Circuit may be ordered from any of the following Website URL's listed below....good luck my friend.

Aug 06, 2007 | Technics SB-AS500 Subwoofer

1 Answer

Jensen JS1000-A sub stopped working, why?

Is is possible that the receiver's subwoofer configuration turned off? double check your speakers setup in the receiver...Just an idea.

Jun 30, 2007 | Jensen JS1000-A Subwoofer

Not finding what you are looking for?
Speakers & Subwoofers Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Speakers & Subwoofers Experts


Level 3 Expert

4518 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5327 Answers

Are you a Technics Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides