Question about Sony XM-1002HX Car Audio Amplifier

1 Answer

Sony amp pops, when you turn on the car. how do i fix it

Posted by on

  • tommylk Jan 29, 2009

    i did it and stil pops . i tryer a new head unit and it is now fixed. thank you 4 your help tom

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

Run an Extra Ground or ReRoute Your Main Ground Straight to the Battery and it should Stop this Popping. Please Rate my Response, I need all the Help That I can Get! Thanks!

Posted on Jan 28, 2009

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When installed, amp gets power but produces no sound


If you have a small mom and pop shop in your area. I would have them check it out. You might have gotten lucky.

Mar 28, 2014 | Sony Exm-502 Mosfet 2 Channel Stereo...

1 Answer

I have a Sony Xplod 800w Amp running a 10' Sony Xplod Amp....i unhooked the amp to do some moving and i tried to put it back in today and it didnt have any sound coming from it! I did notice the power...


it sounds like it could be a blown channel in the amp. if the sub was blown it would still work just sound horrible. i have blown many subs and amps. you can bring it to an audio shop near you and they can fix it. i just got one of my channels fixed for 35$

May 11, 2011 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

Amp burned out


yes you shorted the output transistors and replacing them will fix your issue. inside the amp you will find three legged transistors that mount to the amps body/heat sink. replace all of them.

good luck man.

Jan 23, 2010 | MTX Thunder 4250D Car Audio Amplifier

1 Answer

Amp turns on fine hooked up to factory cd player when u turn volume up red light pops on on amp


it means there not enough power going to the amp.or the power wire inside the amp has melted resalting in a bad conection

Dec 29, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony amp 1000w


Check the wiring of the speakers (both inside the box and between the box and the amp). It sounds like one speaker is wired incorrectly at one connection point.

Sep 09, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony Xplod amp not working (deck cought on fire)


Hi there, please check the wiring. If there are some loose contacts the above mentioned symptoms are possibble. Best regards, Arpi If you need more info please advice.

Jun 15, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

How to fix a popping sound


This problem could be a normal thing in the amp, or there could be a problem in the muting circuit. I would contact the manufacturer to check with them , if theres any common issues with this amp. Also I've seen custom car amp installs where you hook up a speaker delay circuit that you can build from a few parts like a couple of capacitors a few resistors , a 555 timer IC and a relay with high current contacts. I have also seen these already factory nmade in good auto stereo shops. Good Luck

Jun 08, 2006 | Orion 2500D Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...